eZ Community » Forums » General » Search problem with "excluded" words?
expandshrink

Search problem with "excluded" words?

Search problem with "excluded" words?

Saturday 03 April 2010 12:50:40 am - 4 replies

Hello, I don't post often but a customer is having a problem with their ezpublish search. ie, "/content/search?SearchPageLimit=5&SearchText=omega"

The problem is most strange, and recently when customers use say default ezwebin siteaccess search form they no longer get results (because of excluded words but i cannot find a way to avoid customers from getting seemingly almost any word is excluded no mater how one searches).

Instead they are presented with the following phrase. "The following words were excluded from the search:: omega" "No results were found when searching for "omega"."

Customer: "one thing i notice, is when the search comes back, it says the word I am searching is excluded".

My customer does have large number of binary pdf files and article content objects. It seems that the more content we put into eZ Publish the more the default search stopped working and started "excluding" any word searched.

Q: How might one be able to prevent ezpublish from "excluding words" during my search query. My customer needs results more than excluding my uncommon phrases.

Modified on Saturday 03 April 2010 12:59:16 am by wtf

Monday 05 April 2010 11:13:48 am

The reply has been removed because of violation of forum rules.

Tuesday 06 April 2010 11:28:31 am

Hi <unnamed> happy.gif Emoticon

Is this website using eZ Find ?

Also, have you made any customisation to your search-related settings/templates/code ?

Let us know,
Cheers,

Wednesday 07 April 2010 5:47:35 am

Hello Nicolas,

The website is not using ezfind.
It runs on a small dedicated server.
I think ezfind is a bit out of this customers ballpark.

 

The website runs stock eZpublish 4.2
I have enabled binary search indexing
of pdf content object files. But no kernel
related modifications.

I found deleting the contents of ezsearch tables
and reindexing the site fixed the problem in the short term.
Still it would be much better if this negative feature was better documented.

Wednesday 07 April 2010 4:52:16 pm

Can you try setting a large value in site.ini.append.php for:

[SearchSettings]
StopWordThresholdValue=1000000

If a user types in lots of keywords, searches may be slow though

hth

Paul

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from