eZ Community » Forums » General » Searching
expandshrink

Searching

Searching

Tuesday 13 May 2003 7:29:07 am - 14 replies

What can be wrong if Search give no results at all. I know there is quite a lot of these words what I search for. It is no working with my templates nor with admin templates.
I use most usual Article datatype everywhere. Body is not filled and only intro is used. But Intro is marked as 'Searchable'.

So... I have no more ideas why it is not working. Have you? If you have, pleas share those with me. Thanks.

Tuesday 13 May 2003 1:15:10 pm

Try this
http://ez.no/developer/ez_publish...i_need_to_reindex_my_site_for_search
It will re-index the site as this may be the problem.

Modified on Tuesday 13 May 2003 1:18:11 pm by Tony Wood

Tuesday 13 May 2003 1:22:14 pm

Just a note, I have only needed to do this a couple of times, in the normal running of eZp this is automatic..

Wednesday 14 May 2003 12:58:13 pm

kaiko@hostname:~/ezpublish> php -C update/common/scripts/updatesearchindex.php
Starting object re-indexing

Fatal error: Call to a member function on a non-object in /usr/local/apache/htdocs/update/common/scripts/updatesearchindex.php on line 83
Fatal error: eZ publish did not finish it's request
The execution of eZ publish was abruptly ended.

-----
I'm quite confused! Can this be somehow my own mistake?

Wednesday 14 May 2003 1:49:55 pm

What version are you running?

Wednesday 14 May 2003 3:02:11 pm

3.0-2
I changed my version from 3.0-1 to 3.0-2 changing just directorys (kernel, lib, sdk, etc). So, it can be my mistake even I don't belive it now.

Wednesday 14 May 2003 3:23:04 pm

Your on the right version... I might be a database problem... Is this database an upgrade from RC1 or RC2?

Wednesday 14 May 2003 3:23:49 pm

Try running this routine on the test install from eZ and then you can check it isn't you version of PHP or env etc.

Sunday 08 June 2003 7:59:55 pm

Did you solve this? I also had problems with ezsearch not returning anything at all (MySQL 4.0.12), so I turned on debug and found out that mysql access was being denied when it tried to execute a 'create temporary table' command. Running mysql_fix_privilege_tables made the problem go away.

Tuesday 23 September 2003 1:36:40 pm

Hello,

the URL http://ez.no/developer/ez_publish...i_need_to_reindex_my_site_for_search

does not seem to exist anymore.
Could you please help with anoter ULR?

Saturday 13 March 2004 4:53:24 pm

I also get mysql access denied when it tried to execute a 'create temporary table' command. Where is this mysql_fix_privilege_tables script? I can't find it. I am worried that my ISP does not allow temporary tables at all.

Monday 15 March 2004 9:21:52 am

Hi Reiner

Try http://ez.no/ez_publish/documenta...i_need_to_reindex_my_site_for_search

(A site search of "reindex search" would have found this blunk.gif Emoticon

Cheers
Bruce

Monday 15 March 2004 9:27:45 am

Hi Brian

The CREATE TEMPORARY TABLES privilege was added in MySQL 4.0.2. In version 3 series the CREATE privilege was enough to allow the for the creation of temporary tables and for search to work.

You will need to get your hosting provider to add this privilege. (This should not be a problem for them as you will already have the ability to create normal tables.)

Cheers
Bruce

Tuesday 16 March 2004 12:50:11 am

yes, I asked my host provider to add these privileges to my mysql account.

Thursday 16 December 2004 11:25:46 am

I have had the same Problem.
I'm using Suse Linux, Confixx3, Apache2, MySQL

MySQL user priveleges are the right hint, but i wasnt able to change them, i didnt have enough knowledge in mysql commands.

My solution:
I use the root Account for the mysql database

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from