eZ Community » Forums » General » SVN .. Help :(
expandshrink

SVN .. Help :(

SVN .. Help :(

Monday 14 July 2003 9:50:10 am - 28 replies

each time I get this msg from svn on winxp when i trying to get the last revision copy, I get about 6Mb after this I get this msg !

svn: RA layer request failed
svn: could not checkout a file
svn: GET of /svn/nextgen/!svn/bc/2852/trunk/kernel/sql/postgresql/kernel_schema.
sql: 500 Server Error (http://zev.ez.no)

why the svn copy is TO BIG ?
is there are any way to make the svn start from the last step, I mean now i have 6Mb on disk i wanna svn start form here ?!

Monday 14 July 2003 10:09:03 am

I had reinstall again ezp 3.1 , when I trying to update it via svn I get this msg :

svn: Path is not a working copy directory
svn: '.' is not a working copy

How to update ?

Monday 14 July 2003 11:30:00 am

Which svn version are you using?

Monday 14 July 2003 11:37:44 am

0.23.0

would you please tel me how can I update from revision 2703 to the last revision ?

I think it`s looking for folder .svn, and I didn`t find in zipped ezp !

Monday 14 July 2003 1:42:26 pm

First go into your svn directory, then type svn up. It sounds like you are not in your svn directory.

If that fails then just checkout the code again. eg:

svn checkout http://zev.ez.no/svn/nextgen/stable/3.1/
stable-3.1

Once you have this you can export the code (removing all of the .svn entries) by:

svn export stable-3.1 ez3.1

which you can then use.

For the trunk code (3.2) use:

svn checkout http://zev.ez.no/svn/nextgen/trunk/
trunk

paul

Modified on Monday 14 July 2003 1:43:04 pm by Paul Forsyth

Monday 14 July 2003 1:53:06 pm

then the point i MUST download it via svn ... I had tried everything to update it with no result ... now am try to download it via svn !

Monday 14 July 2003 2:00:14 pm

In order to update a copy that was checked out by svn you must have done it before, you must be in the directory which you want to update and it must contain the .svn directories. Additionally you should confirm that the user that checked out the files matches your current user.

You cannot update files that were exported since they have had all version control subsidiary files removed.

You can easily recreate the directory through another checkout if all else fails.

Remember, Subversion (svn) is still an alpha product and it has risks. It seems pretty stable to me already but i do very simple tasks with it and it seems to like my mandrake system. Mileage may vary.

paul

Monday 14 July 2003 2:14:15 pm

thx paul ..

now am geting it again :
svn checkout http://zev.ez.no/svn/nextgen/trunk/

This mean that after unziped the ezp I must run checkout to the .svn folders and files, after that i can update ...

Then why the zipped file not include the .svn files for update !

Monday 14 July 2003 2:15:25 pm

btw ..

I had tried what you said to getin the ezp folder and run svn up, din`t work coz its need .svn folder !

Monday 14 July 2003 2:32:19 pm

Grrrrrrrr ...

The same probelm .... download 6Mb and get the same error msg :

svn: RA layer request failed
svn: could not checkout a file
svn: GET of /svn/nextgen/!svn/bc/2852/trunk/kernel/classes/workflowtypes/event/e
ztiming/eztimingtype.php: 500 Server Error (http://zev.ez.no)

sad.gif Emoticon(((((((

Monday 14 July 2003 2:33:56 pm

Selmah, are you using NFS filesystem on your computer? We've experienced problems with SVN and NFS. You should check out eZ publish on local filesystem, that seems to work fine all the time. ( e.g /tmp/ ).

--bård

Monday 14 July 2003 3:14:13 pm

Im not quite clear on the steps you are taking here. You imply there is a zip file to unpack but if you are using the svn version there is no zip file. It sounds like you are downloading the 3.1 install file and then trying to update those files from svn. This is not possible.

The svn version is entirely seperate from the downloadable zip files ez provide. It cannot be updated from svn.

Only a checkout from svn can be updated.

Does this help?

paul

Monday 14 July 2003 3:18:02 pm

ohh .. see now thx paul !

you mean i should run the svn on disk with format fat32 , or to install the svn on fat32 ?

Monday 14 July 2003 3:21:28 pm

Now the ezp is coming via svn to disk format fat32, befor was on NTFS !

Monday 14 July 2003 4:25:17 pm

downloaded 20Mb and the same error msg sad.gif Emoticon

maybe this kind of server error ?

Monday 14 July 2003 4:26:59 pm

E:\>svn checkout http://zev.ez.no/svn/nextgen/trunk/ e:\ez32
svn: Obstructed update
svn: revision 2855 doesn't match existing revision 2852 in 'E:/ez32'

maybe the revision is changed while downloading ?!

Monday 14 July 2003 5:02:37 pm

The revision may have changed but svn should handle that without a problem. Can you change directory to e:\ez32 and type 'svn up'?

paul

Monday 14 July 2003 6:28:40 pm

The same msg error .. revision msg !

Monday 14 July 2003 9:02:30 pm

ok... maybe try checkout at a specific revision.

svn checkout -r 2855 http://<usual address> ez32

Monday 14 July 2003 9:04:45 pm

You may have a too new version of svn. Try 0.21, I think that's the version we are using.

--bård

Tuesday 15 July 2003 9:57:22 am

The svn version on zev.ez.no is 0.23.0 ... I cann`t find it on subvsrion.tigris.com !

am using dsl 512, maybe this slow, so i`ll try on my friend pc 512up, 1Mb download ... maybe will work .. if not can you please make zip file for latest revision of ezp with .svn to download it ?!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from