eZ Community » Forums » General » Upgrading to the new 3.5
expandshrink

Upgrading to the new 3.5

Upgrading to the new 3.5

Friday 22 October 2004 6:24:11 pm - 9 replies

Is it possible to upgrade to the new 3.5 (when it is released) or will we need to reinstall?

kris

Saturday 23 October 2004 9:00:34 am

No reinstall will be needed. You'll probably have to do the following:

1) Make a backup of the current site
2) Run the system upgrade checks from the admin interface
3) Run the database upgrade script(s) to upgrade the database
4) Unpack the new files and overwrite the current eZ publish files
5) Maybe run one or two additional scripts
6) Clear the caches
7) You're good to go...

In other words: no need to reinstall; upgrading from 3.4.x to 3.5 should go smooth.

Balazs

Modified on Saturday 23 October 2004 9:06:59 am by Balazs Halasy

Saturday 23 October 2004 10:39:34 am

if i installed a fresh ez3.5.b, i got this error to open any page:

Fatal error: Maximum execution time of 30 seconds exceeded in /www/users/pcdogs.com/lib/ezxml/classes/ezxml.php on line 293
Fatal error: eZ publish did not finish its request
The execution of eZ publish was abruptly ended, the debug output is present below.

so here are my upgrading steps:
1.installed ez3.5.a
2.move all files and folders of ez3.5.a to /ez35a
3.copy ez3.5.b to root folder, and copy /ez35a/design/news to /design/news
4.copy /ez35a/sitesettings/override, /ez35a/sitesettings/siteaccess to /sitesettings/
copy /ez35a/var to /var
5 run http://mysite/index
it was ok, then go to admin page, and check files and databases, it said ok, does this surely ok?

had i upgraded my site from ez35a to ez35b?

what's the function of these scripts under /upgrade/...
do i need to run them manually or they will be run automatically when i click system check in admin.

but i can run ez35b now, there are no error like before,why? bug?
thanks!

Modified on Saturday 23 October 2004 10:43:02 am by kevin wei

Saturday 23 October 2004 9:49:49 pm

I have the same error with fresh installed ezPublish 3.5beta1 and php 4.3.8, apache 1.3.31 sad.gif Emoticon

Modified on Saturday 23 October 2004 9:50:15 pm by Dariusz Włodarczyk

Saturday 23 October 2004 10:19:10 pm

Hi,

turn the template compiling off.

-> site.ini.append

...
[TemplateSettings]
...
NodeTreeCaching=enabled
TemplateCompile=disabled
...

If you get the error again, just reload.

Sunday 24 October 2004 2:03:22 am

Hi,

If you have command line access you can run bin/php/eztc.php -s your-siteaccess-name

This is the ezpublish command line template compiler, you may need to run it after any clear all cache, the alternative is turning off template compiler as mentioned above

Sunday 24 October 2004 2:40:21 am

thanks, i will disable this to TemplateCompile=disabled.

however, i want to know after i overwrite all file of 3.5.a with 3.5.b, more than clear cache and upgrade check, what else i should?

how to use these files under /grade/common/ ?

i found after my upgrade, pictures and files are lost, how to use upgrade files to make these links work.

thanks!

Sunday 24 October 2004 12:05:41 pm

I switch templates caching off and have still the same error sad.gif Emoticon
Any ideas what to do now ?

Monday 25 October 2004 5:21:26 pm

me too

Wednesday 24 November 2004 2:00:46 pm

I just tried to test 3.5rc1 too, but I also get this timeout. Php ini settings are correct though...

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from