This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » General » Workflow article not show in list
expandshrink

Workflow article not show in list

Workflow article not show in list

Wednesday 24 July 2013 11:30:29 am - 2 replies

I have a problem that a user under a group who does not have the rights to publish the article, cannot edit it again once again and the article is not shown in the admin module list until and unless the admin approves it and the cronjob is executed.

Is it possible to change this behavior? or this is the standard workflow behavior from ezpublish.

Wednesday 24 July 2013 5:01:05 pm

That is unfortunately the default behavior in eZ Publish.

A couple of lightweight alternatives include:

- Using object states (see http://share.ez.no/learn/ez-publish/ez-publish-knowledge-series-editorial-workflow-with-object-states)

- Using the "hidden" flag instead (see http://www.mugo.ca/Extensions-and-Tools/Extensions/Hide-Until-Date)

Both of the above have an additional limitation that it only works for the first version of an article.  Once the article is published and you want the workflow to manage subsequent edits, either an object state or hiding the node would temporarily remove the published version from the front-end.

A more full-blown solution that overcomes that limitation is our market extension eZ Collaboration Workflow: http://ez.no/Products/eZ-Market/Explore-the-eZ-Market/eZ-Collaboration-Workflow

Tuesday 30 July 2013 10:46:47 am

Thank you Peter

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from