This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » 2012.5 - Virtual host setup doesn't...
expandshrink

2012.5 - Virtual host setup doesn't hide index.php

2012.5 - Virtual host setup doesn't hide index.php

Wednesday 24 October 2012 11:39:11 am - 11 replies

Hi all,

I'm having a peculiar problem with an installation of the community edition 2012.5. Despite following all the instructions on the virtual host setup to the letter -> http://doc.ez.no/eZ-Publish/Technical-manual/4.7/Installation/Virtual-host-setup/Virtual-host-example, this install wont hide the /index.php/ from the URL.

These are instructions that have worked like a charm on my previous installations and I can't figure out why it is not the case with this particular installation.

Is anyone else going through the same problem with the 2012.5 version?

Wednesday 24 October 2012 11:58:48 am

Are you maybe using a .htaccess file when the vhost config says "Allow Override None"?

Wednesday 24 October 2012 12:32:30 pm

Quote from Steven E Bailey :

Are you maybe using a .htaccess file when the vhost config says "Allow Override None"?

No, I'm not using .htaccess. I'm using vhosts.conf.

Wednesday 24 October 2012 12:43:52 pm

Try to set ForceVirtualHost to true in your override/site.ini.append.php

[SiteAccessSettings]
ForceVirtualHost=true

Wednesday 24 October 2012 12:54:48 pm

I've already tried "ForceVirtualHost" in override/site.ini.append.php several times.

The result is that I get "module not found" on the frontend and cannot access admin anymore.

Wednesday 24 October 2012 1:12:57 pm

Do you have a .htaccess then that is messing up the vhost config?

Is mod_rewrite enabled?

Wednesday 24 October 2012 1:39:00 pm

Yup, mod_rewrite is enabled. There is no .htaccess lurking around anywhere that could mess up things. This is an installation on its own dedicated IP address, so there's nothing else that could be affecting it.

Wednesday 24 October 2012 2:02:10 pm

You might want to try:

RewriteLog /var/log/apache2/rewrite.log
RewriteLogLevel 9

To see if your rules really are being hit...

Wednesday 24 October 2012 2:26:21 pm

Ok, I've included RewriteLog to the vhost.conf.  Will get back if I get something.

Wednesday 24 October 2012 2:45:32 pm

A tip: after enabling ForceVirtualHost, be sure to clear all caches, if possible by hand (rm -rf)

Wednesday 24 October 2012 11:18:57 pm

The best way I've found is to be logged into the admin before you upload the site.ini with the ForceVirtualHost statement.

As soon you upload it, click clear caches

the admin will break at this point. then just manually remove index.php?/ from the url and click return

The admin will then return and you click the clear cache button again and hey presto the admin works and so does the front end.

Thursday 25 October 2012 11:47:04 am

Happy days!

After carefully reviewing my previous installations last night, I finally solved the problem.

I'd forgotten that in all my implementations, I've always made the following changes:

virtual host example [link above]:

<Directory /var/www/example>
        Options FollowSymLinks
        AllowOverride None
</Directory>

<IfModule mod_rewrite.c>
        RewriteEngine On

        --- snip ---

        RewriteRule .* /index.php
</IfModule>

my vhost.conf:

<directory /var/www/path/to/ezpublish>
        AllowOverride All
        Options Indexes FollowSymLinks
        Order allow,deny
        Allow from all
</directory>

<IfModule mod_rewrite.c>
       RewriteEngine On

       --- snip ---

       RewriteRule .* /index\.php
</IfModule>

I don't know why it took me more than a week to realise this.

Modified on Thursday 25 October 2012 11:52:55 am by Charles Okech

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from