eZ Community » Forums » Install & configuration » 3.0 rc1 - Should I begin to translate ?
expandshrink

3.0 rc1 - Should I begin to translate ?

3.0 rc1 - Should I begin to translate ?

Monday 23 December 2002 10:36:05 pm - 6 replies

Hi all,

I've now got my 3.0 rc1 up & running splendidly, exactly as it should, with one very important exception.

I won't be able to install a single copy without having translated the system into my native tongue, which is German (but might as well be anything other than English or Norwegian).

(1) Would you recommend to begin the translation process right away? Or should I rather wait for the Release 3.0?

(2) HOW should I approach the task? Any helpful URL you can point me towards?

Thanks,
--Michael

Thursday 26 December 2002 9:56:25 pm

> Hi all,
>
> I've now got my 3.0 rc1 up & running splendidly, exactly as
> it should, with one very important exception.
>
> I won't be able to install a single copy without having
> translated the system into my native tongue, which is German
> (but might as well be anything other than English or
> Norwegian).
>
> (1) Would you recommend to begin the translation process
> right away? Or should I rather wait for the Release 3.0?
>
> (2) HOW should I approach the task? Any helpful URL you can
> point me towards?
>
> Thanks,
> --Michael

2) http://ez.no/article/articlestatic/218/1/45/

See http://ez.no/article/articlestatic/216/1/42/

The translation process is the same in 3.0.

Friday 27 December 2002 12:35:06 am

Hello! You may start translate the codes into your own language. just go to yourhost.com/index.php/sdk and klick on the "translate" link.
There you'll find what to do.

Yours
Arash
> Hi all,
>
> I've now got my 3.0 rc1 up & running splendidly, exactly as
> it should, with one very important exception.
>
> I won't be able to install a single copy without having
> translated the system into my native tongue, which is German
> (but might as well be anything other than English or
> Norwegian).
>
> (1) Would you recommend to begin the translation process
> right away? Or should I rather wait for the Release 3.0?
>
> (2) HOW should I approach the task? Any helpful URL you can
> point me towards?
>
> Thanks,
> --Michael

Friday 27 December 2002 2:20:48 pm

Thanks a lot, Arash, but your clue almost immediatele rose the next questions.

Arash, Gunnar, Jan -- can you please help me. I am feeling lost.

The first problem was where to find ezlupdate and ezlinguist because the SDK would not tell me. It took me a while but finally I got 'em.

Now, the current problem is that ezlupdate does not work.

The lupdate version number, by the way, is 3.0.4 with ez publish patch 3.0.4-1.

It seems to me that this version was made with ez Publish 2.x in mind, not 3.x, because it searches for a classes/.. directory which does not exist any more in 3.x

However, I cannot check if the 3.0.5 patch would amend this problem since I am using Windows and so I cannot recompile.

I am unable to find a .ZIP download with the Win32 versions of ezlupdate and ezlinguist, for ez Publish 3.0.

Can you please tell me where to find them, or what else should I do. Thank you.

--Michael

> Hello! You may start translate the codes into your own
> language. just go to yourhost.com/index.php/sdk and klick on
> the "translate" link.
> There you'll find what to do.
>
> Yours
> Arash
> > Hi all,
> >
> > I've now got my 3.0 rc1 up & running splendidly, exactly
> as
> > it should, with one very important exception.
> >
> > I won't be able to install a single copy without having
> > translated the system into my native tongue, which is
> German
> > (but might as well be anything other than English or
> > Norwegian).
> >
> > (1) Would you recommend to begin the translation process
> > right away? Or should I rather wait for the Release
> 3.0?
> >
> > (2) HOW should I approach the task? Any helpful URL you
> can
> > point me towards?
> >
> > Thanks,
> > --Michael

Friday 27 December 2002 5:11:34 pm

Thanks a lot, Arash, but your clue almost immediatele rose the next questions.

Arash, Gunnar, Jan -- can you please help me. I am feeling lost.

The first problem was where to find ezlupdate and ezlinguist because the SDK would not tell me. It took me a while but finally I got 'em.

Now, the current problem is that ezlupdate does not work.

The lupdate version number, by the way, is 3.0.4 with ez publish patch 3.0.4-1.

It seems to me that this version was made with ez Publish 2.x in mind, not 3.x, because it searches for a classes/.. directory which does not exist any more in 3.x

However, I cannot check if the 3.0.5 patch would amend this problem since I am using Windows and so I cannot recompile.

I am unable to find a .ZIP download with the Win32 versions of ezlupdate and ezlinguist, for ez Publish 3.0.

Can you please tell me where to find them, or what else should I do. Thank you.

--Michael

> Hello! You may start translate the codes into your own
> language. just go to yourhost.com/index.php/sdk and klick on
> the "translate" link.
> There you'll find what to do.
>
> Yours
> Arash
> > Hi all,
> >
> > I've now got my 3.0 rc1 up & running splendidly, exactly
> as
> > it should, with one very important exception.
> >
> > I won't be able to install a single copy without having
> > translated the system into my native tongue, which is
> German
> > (but might as well be anything other than English or
> > Norwegian).
> >
> > (1) Would you recommend to begin the translation process
> > right away? Or should I rather wait for the Release
> 3.0?
> >
> > (2) HOW should I approach the task? Any helpful URL you
> can
> > point me towards?
> >
> > Thanks,
> > --Michael

Friday 27 December 2002 8:11:35 pm

Copy the norweigan folder and rename to your country-code. Then you open translation.ts with:
http://www.ez.no/filemanager/fileview/514/
and start translate! When you're finished you have to add the country into settings/site.ini.

If that doesn't work, I donno what to do:S

//Arash

>
> > Hello! You may start translate the codes into your
> own
> > language. just go to yourhost.com/index.php/sdk and
> klick on
> > the "translate" link.
> > There you'll find what to do.
> >
> > Yours
> > Arash
> > > Hi all,
> > >
> > > I've now got my 3.0 rc1 up & running
> splendidly, exactly
> > as
> > > it should, with one very important exception.
> > >
> > > I won't be able to install a single copy without
> having
> > > translated the system into my native tongue, which
> is
> > German
> > > (but might as well be anything other than English
> or
> > > Norwegian).
> > >
> > > (1) Would you recommend to begin the translation
> process
> > > right away? Or should I rather wait for the
> Release
> > 3.0?
> > >
> > > (2) HOW should I approach the task? Any helpful
> URL you
> > can
> > > point me towards?
> > >
> > > Thanks,
> > > --Michael

Monday 30 December 2002 12:39:04 pm

get ger-DE-translation here: http://developer.ez.no/filemanager/list/94/

> ..did you finish Your translation work to german, and could
> You provide the files to me?

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from