This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » 4.1 alpha setup wizard doesnt finish
expandshrink

4.1 alpha setup wizard doesnt finish

4.1 alpha setup wizard doesnt finish

Sunday 21 December 2008 6:32:34 pm - 7 replies

I wanted to try running the setup wizard in the 4.1 alpha1 release. It goes fine until I selects extension among plain, website interface or ez flow. The preferences I have set before this stage is language=uk, MySQL improved, default anguage support=english/uk and no additional, site package = website interfce (1.4)

The summary:
Systemomg.gif EmoticonK
Image system:ImageMagick
Mail:sendmail
Database:MySQL Improved
Language:eng-GB
Site:

Fatal error: Class 'ezcArchiveOptions' not found in /Library/WebServer/Documents/ez41alpha1/kernel/classes/ezpackage.php on line 1137

Sunday 21 December 2008 6:57:59 pm

The error leads me to think it couldn't find something in eZ Components. Have you installed eZ Components?

Sunday 21 December 2008 10:15:12 pm

Installing eZ componants should solve this

pear channel-discover components.ez.no
pear install -a ezc/eZComponents

or the tutorial for Debian Etch http://www.open-net.ch/fre/CMS-eZ...nstall-eZ-publish-4.1-on-Debian-Etch

Monday 22 December 2008 12:44:10 am

ez components are not installed. Its a untouched folder from the downloaded zip. Thanks, I will try with components installed.

Wednesday 07 January 2009 10:01:52 pm

I have installed EZ Objects, but the installer stills stops with:

Fatal error: Class 'ezcArchiveOptions' not found in /Library/WebServer/Documents/ez41alpha1/kernel/classes/ezpackage.php on line 1137

I have installed PEAR according to the description at http://clickontyler.com/blog/2008...to-install-pear-in-mac-os-x-leopard/

Is there any config in pear I have to other than

;;;;;;;;;;;;;;;;;;;;;;;;;
; Paths and Directories ;
;;;;;;;;;;;;;;;;;;;;;;;;;

; UNIX: "/path1:/path2"
include_path = ".:/usr/share/pear"
;
; Windows: "\path1;\path2"
;include_path = ".:/usr/share/pear"

I just did an upgrade with: "pear upgrade ezc/eZComponents" So I guess all the ez objects are present.

I have
/usr/local/PEAR/ezc/
and
/usr/local/PEAR/docs/ andalotofthings

Wednesday 07 January 2009 10:21:55 pm

oops. Discovered right now that the include path from the instructions differs from very the "pears are". changed the include path in php.ini to go in folder "local". setupwiz runs again happy.gif Emoticon

Friday 24 July 2009 6:13:13 pm

I'm getting the same error

Fatal error: Class 'ezcArchiveOptions' not found in /home/fmekweb/public_html/ez/kernel/classes/ezpackage.php on line 1139
Fatal error: eZ Publish did not finish its request

The execution of eZ Publish was abruptly ended, the debug output is present below

but I have no idea how to fix it. Trying to update anything gives me these responses:

Failed to download ezc/MvcTools (version >= 1.1RC1, version <= 1.1RC1), latest release is version 1.1, stability "stable", use "channel://components.ez.no/MvcTools-1.1" to install
ezc/eZComponents requires package "ezc/MvcTools" (version >= 1.1RC1, version <= 1.1RC1), downloaded version is 1.1
ezc/ezcomponents requires package "ezc/Authentication" (version >= 1.2.3, version <= 1.2.3), downloaded version is 1.3
ezc/Authentication cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/Base" (version >= 1.6.1, version <= 1.6.1), downloaded version is 1.7
ezc/Base cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/ConsoleTools" (version >= 1.5.1, version <= 1.5.1), downloaded version is 1.5.2
ezc/ConsoleTools cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/Document" (version >= 1.1.2, version <= 1.1.2), downloaded version is 1.2
ezc/Document cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/EventLog" (version >= 1.3, version <= 1.3), downloaded version is 1.4
ezc/EventLog cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/Graph" (version >= 1.4.2, version <= 1.4.2), downloaded version is 1.4.3
ezc/Graph cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/ImageConversion" (version >= 1.3.6, version <= 1.3.6), downloaded version is 1.3.7
ezc/ImageConversion cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/Mail" (version >= 1.6.2, version <= 1.6.2), downloaded version is 1.6.3
ezc/Mail cannot be installed, conflicts with installed packages
ezc/MvcAuthenticationTiein requires package "ezc/Base" (version >= 1.7), installed version is 1.6.1
ezc/MvcFeedTiein requires package "ezc/Base" (version >= 1.7), installed version is 1.6.1
ezc/ezcomponents requires package "ezc/PersistentObject" (version >= 1.5.2, version <= 1.5.2), downloaded version is 1.6
ezc/PersistentObject cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/PersistentObjectDatabaseSchemaTiein" (version >= 1.2.1, version <= 1.2.1), downloaded version is 1.3
ezc/PersistentObjectDatabaseSchemaTiein cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/Search" (version >= 1.0.4, version <= 1.0.4), downloaded version is 1.0.5
ezc/Search cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/Template" (version >= 1.3.2, version <= 1.3.2), downloaded version is 1.4
ezc/Template cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/TemplateTranslationTiein" (version >= 1.0, version <= 1.0), downloaded version is 1.1
ezc/TemplateTranslationTiein cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/Translation" (version >= 1.2, version <= 1.2), downloaded version is 1.3
ezc/Translation cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/Tree" (version >= 1.1.2, version <= 1.1.2), downloaded version is 1.1.3
ezc/Tree cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/Webdav" (version >= 1.1, version <= 1.1), downloaded version is 1.1.1
ezc/Webdav cannot be installed, conflicts with installed packages
ezc/ezcomponents requires package "ezc/MvcTools" (version >= 1.0, version <= 1.0), downloaded version is 1.1
ezc/MvcTools cannot be installed, conflicts with installed packages
No valid packages found
upgrade failed

And trying to rectify any of that by reinstalling components or whatever seems to mess up the whole system so bad I have to reinstall the whole thing entirely...

Any solutions?

Saturday 25 July 2009 10:44:56 am

Download the bundled package "With eZ Components 2008.2.3":
http://ez.no/download/ez_publish/ez_publish_4_stable_releases/4_1

And make sure you have PHP 5.2.1 or higher (but not 5.2.9 since its flawed), and that you have Pear 1.7.x (type "pear version" to get both php and pear version).

If you don't have PHP 5.2.1 or higher, and can't update / compile to a newer version, then use eZ Publish 4.0.x witch requires 5.1.2 and an older eZ Components version witch works on 5.1.2 and higher.

As in:
http://ez.no/download/ez_publish/ez_publish_4_stable_releases/4_0

And eZ Components "2007.2.1" in your include path so its accessible with "Base/src/base.php":
http://www.ezcomponents.org/download/dl_components

Modified on Saturday 25 July 2009 10:53:06 am by André R

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from