eZ Community » Forums » Install & configuration » 404 error after installing
expandshrink

404 error after installing

404 error after installing

Friday 03 October 2014 12:16:34 am - 6 replies

Hi, after many days I finally managed to go through the wizard and install ez publish, problem is it is not recognizing what should be my 'user site' I get the following message:

 

Oops! An Error OccurredThe server returned a "404 Not Found".Something is broken. Please e-mail us at [email] and let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.

And when trying to see my 'admin site' there are no styles or jquerys. For some reason they aren't loading. I have done every step in the user guide, I ran this code:

php ezpublish/console ezpublish:legacy:assets_install --symlink web
 
php ezpublish/console assetic:dump --env=prod web
 
cd /php ezpublish/console assets:install --symlink web

I also configured phpini, set high memory limit, set high max_execution_time (300). 

I don't know what I did wrong sad.gif Emoticon This is the file I downloaded:

ezpublish5_community_project-2014.07.0-gpl-full.tar.bz2

I'm trying to install it on xampp in windows xp, I used URL and doing no redirects or anything, just trying out files fresh out of install.

Thanks for your time!

Modified on Friday 03 October 2014 12:21:25 am by Ant Low

Friday 03 October 2014 4:50:20 am

Hello Ant,

Sorry your having trouble. You picked one of the hardest platforms to install eZ on :\ So I'm not surprised your running into problems. There are a -whole lot- of problems with running eZ Publish on Windows.

I don't think anyone can help with your 404 problem without more information on exactly what you did to get that error message.

As for the admin not having any styles or jquery ... again more information on the errors your getting (404s? what are the css / js urls not loading, check browser inspector network tab) would really help us help you.

Offhand, (it's late for me) I seem to remember hearing about a windows specific problem with Symfony where symlinks are not supported (at all) and you must use copies of the assets instead. I know that this was recently solved in Symfony 2.6 which is still in heavy review and testing.

Re: http://ezecosystem.org/Mirror/Symfony-Blog/New-in-Symfony-2.6-Smarter-assets-install-command

It will be quite some time before eZ uses Symfony 2.6 so you may need to solve this problem by hand.

One last thought, admin is part of legacy so the above problem I describe may not be the true problem in this situation so please do provide more information.

I hope this helps.

Cheers,
Heaht 

Modified on Friday 03 October 2014 4:51:35 am by // Heath

Friday 03 October 2014 5:16:38 pm

Hi Heath! 

Thank you for your reply. What I did was, after the install wizard completed, I got the "finished" page, where two URLS showed, one was "user site" and the other "admin site". The only thing I did was click "user site" and after a few seconds waiting, it loaded the 404 page.

I installed first the demo site with demo content, and then deleted and started over to install the demo site without demo content. In both cases I got the same error. 

I remember now I couldn't use "symlink" when running the command, so I used "relative" instead.

The data I filled was:

  • After clicking finetuning, I fixed a couple things, the only thing I left and didn't fix was installing PostgreSQL, but this is because I'm not planning on using it in the near future.
  • In smtp I am using xampp's mercury, so as server name I just typed localhost. Since it was optional I didn't type a username or password.
  • Database I used mysql, and filled with my db configuration (correct password, port, username and servername).
  • I selected Spanish (Spain) for language, and then when I got a message saying that package language didn't match provided language, I chose "create language".
  • In site access configuration I picked URL. And in site details the only thing I changed was choosing the right database.
  • For site security I typed a valid email and password. And that was it! Then I got the "finished" page.

About the 'admin' site, this is the error in my inspector:

Failed to load resource: the server responded with a status of 404 (Not Found)

It is trying to access the following directory:

http://localhost/ez/web/var/ezdem...4df2d993106fe6e80998dd47d345_all.css

but when checking the localhost/ez/web/var directory, I don't see a ezdemo_site folder, so my guess is this wasn't installed. But I don't know how to fix it, is it somewhere else so I can copy it?

Again thank you for your help and time!

Friday 03 October 2014 10:29:26 pm

Hello Ant,

What is the url to the user siteaccess that is generating a 404? (please be specific).

Are you going to use the symfony stack or the legacy only stack?

I don't think that the setup wizard installed the required var/ezdemo_site folder in your web/var directory... I think it installs it into ezpublish_legacy/var/ instead but I've not tried that setup so I don't know for certain.

What is your apache virtual host configuration's DocumentRoot variable set to exactly? From what you have said I think you may have set this incorrectly. Have you installed the apache virtualhost mod_rewrite rules?

I think you need to re-read and follow these instructions more closely:  https://doc.ez.no/display/EZP/Virtual+host+setup

https://doc.ez.no/display/EZP/Installing+eZ+Publish+on+Windows

And finally, have you tried to re-run the ezpublish:legacy:assets_install command after setup wizard is complete? Since they are only making copies and not symbolic links I would imagine you have to re-run this command again and again .. but to be honest I've not installed eZ5 on windows .. yet.

Have a great weekend!

 

Cheers,
Heath 

Friday 03 October 2014 11:57:01 pm

The url with the 404 is this: http://localhost/ez/web/index.php/esl

I'm not sure about the stacks, I suppose legacy only stack. Where do I choose this?

I'm not using a virtualhost, instead I decided to go with the .htaccess option. Do you think this could be the issue?

I have just found a .htaccess example here:

https://doc.ez.no/display/EZP/htaccess+example

Should I replaced that with the one currently in localhost/ez/ezpublish_legacy ? or should I create a new one in localhost/ez/web?

Rerunning the commands fixed the jquery and css problem. I now have the admin with styles happy.gif Emoticon What I keep getting is the 404 page on the user site.

Thanks a lot for your time! Have a great weekend too!

Sunday 05 October 2014 3:48:43 am

Hello Ant,

It seems your 404 error would indicate that your missing the correct .htaccess in the web folder.

It also seems like your trying to use both stacks (which is fine) so you should use the .htaccess example from: https://doc.ez.no/display/EZP/htaccess+example  into the web directory (this is the important part) also be certain your web server virtual host is configured to allow .htaccess file configurations.

You should not need to use or even mess with the ezpublish_legacy .htaccess_root example file. It is only for legacy only installations (not what your trying to setup).

I hope this helps!

Cheers,
Heath 

Sunday 05 October 2014 8:12:43 pm

Hello I had same problem (windows 8 and xampp...) I install ez just today and I have some experience in Symfony. After read all of topic i believe i found solution.

Go to Your admin page then get your landing page content, and add translation propor to Your default language. My home page content shows, still another sublinks no.

I'm running other problems like some content not display proper and other stuff but that solution might help You. I get back when i get better solution or i just remove that platform it's very frustrating on start what next ?

Modified on Sunday 05 October 2014 8:14:57 pm by felek felek

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from