eZ Community » Forums » Install & configuration » 500 Internal Server Error
expandshrink

500 Internal Server Error

500 Internal Server Error

Monday 13 March 2006 10:21:49 pm - 18 replies

Hi, this is my problem:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@domain.it and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

If i change the permission on: "index.php" i see the first installation page but at the end of the setup (92% after "Send Email"blunk.gif Emoticon i see the same error...

Can you help me??

Thanks

Tuesday 14 March 2006 9:41:23 am

i had a similar problem.

do you use the ".htaccess_root" provided by ezpublish which you renamed to
".htaccess" ?

if yes, try to comment the line "php_value allow_call_time_pass_reference" in it. this works for me.

Tuesday 14 March 2006 4:12:24 pm

It doesn't work... but if i delete .htaccess file, i see index.php, i do all the installation but at the end (92%) i have the same error...

Can you help me??

Tuesday 14 March 2006 9:39:01 pm

I am having the exact same problem. After the installation fails, I can go back to the index.php and I see the installation script that I just went through.

I have deleted the .htaccess file, and was going to follow the manual instructions for setting up the system, but in 3.7.4 the settings/override/site.ini.append.php does not exist. Do I have to create that from scratch?

It looks like the script will get as far as creating the database, so I was wondering if I could modify a setting somewhere so that the syste thinks that it has been setup, or am I better off trying the manual installation?

Wednesday 15 March 2006 9:10:16 am

@Silvio: try to change access permission to the whole ezp folder including all subfolders and files as you did it for index.php and see if this changes anything. i cant help you more because im also new here happy.gif Emoticon
try to check your server's error logs to get more information about the error.
cu

Wednesday 15 March 2006 2:55:09 pm

it doesn' t work....

Thursday 06 April 2006 7:24:54 pm

I have the same problem. I am trying to install eZ Pub 3.7.5 on 1and1.com. I get up to the final stage of the install (sometimes doenst get this far) and then when I click the link to either the user or admin site, I get the Error 500 page.

I cant check the server error logs since 1and1 does not allow this "for technical reasons". Im not about to start jumping to other ISPs since it seems others are getting the same problems. Id rather solve the issue on 1and1, or find another CMS (although I do want to try my best to get eZ running first)

I considered looking for alternate hosting providers. Ive checked the eZPublish ISP list here:

http://ez.no/partner/worldwide_ez_publish_partners/(profile)/hosting

and there is no links to hosting providers in the US. Just descriptions. You have to Google search on their name to even get the link to the websites but most of them dont really even have sites, just one pagers. This was the extent of all the options in the USA:

www.firebright.com - > they dont even mention EZ on their website anymore. so that is not an option

www.thinkcreative.com -> a one page form, useless

www.commonplaces.com -> seems like small scale designa nd development service more so than an ISP

I have yet to see a solution here that actaully fixes the problem. Ive tried all the suggestions and searched ad nauseum on this issue. Very frusterating.

 

Thursday 06 April 2006 7:34:46 pm

I also note that I changed the memory size in php.ini (my local version, since there is no access to the one in /usr/local) to 64 MB, as suggested in the eZ install docs. Do you need to restart Apache for this to take affect? Hope not, since this wont be possible unless the folks at 1and1 do it, and I have a feeling they wouldnt just grant me more memory.

After changing this I did see the new memory size allotment show up in php_info(), but I have a feeling its just reading it from the local php.ini file, without it actaully being changed. I would not imagine doing this is really possible, since allowing users on shared hosting to increase the memory to php would be performance risk? Another clue that would indicate that my changes in php.ini are being read but not "loaded" is that I also turned off magic quotes (per the finetuning suggestion in setup wizard) in my local version of php.ini, however, after I did a clean re-install of Ez, it kept saying I had magic quotes On, which would inidcate that all php_info is doing is reading the local php.ini file rather than showing what the settings really are. Oddly, there is also no warning message in the finetuning step that says the memory limitation (40MB) could be an issue, when the docs clearly say you need 64MB.

Also, copying the .htaccess_root to .htaccess results in an Error 500 immediately afterwards, even when commenting out these lines as suggested in previous posts about this same error:

#php_value allow_call_time_pass_reference 0

#<FilesMatch ".">
#order allow,deny
#deny from all
#</FilesMatch>

Im also including the following info i the hope that someone that knows could shed some light on another solution:

PHP Version 4.4.2
Web Server/Platform: Apache/1.3.33 (Unix)
Server API: CGI
memory_limit: 64M (default at 1and1 is 40MB)

Modified on Thursday 06 April 2006 8:17:14 pm by Michael Judkins

Monday 24 April 2006 6:41:47 am

Was a solution found for this issue? I confirm everything noted in Michael's post.

1. Changing .htaccess_root to .htaccess results in an immediate error 500

2. Commenting out #php_value allow_call_time_pass_reference 0 as noted previously generates a "Forbidden" error

3. Subsequently, also commenting out the following (as noted in the .htaccess file as a fix for the "Forbidden" error) allows the installation to run, but results at 92% in the error 500 Internal Server Error

# <Files "ezpublish-3.6.0">
# order allow,deny
# allow from all
# </Files>

4. System is running Php as CGI but this supposedly fixed according to:
http://ez.no/products/ez_publish/...lish_running_on_a_cgi_version_of_php

Any help would be GREATLY APPRECIATED. I've been working on this since 5am, its now 12.30am

Thanks mucho
Aisha

ez Publish version: 3.7.5
PHP Version 4.4.1
Web Server/Platform: Apache/1.3.33 (Unix)
Server API: CGI
memory_limit: 64M

Functionality - contact_us, contacts, files, gallery, links, media, news, products

Critical tests

directory_permissions - Success
phpversion - Success
database_extensions - Success
image_conversion - Success
open_basedir - Success
safe_mode - Success
memory_limit - Success
execution_time - Success
magic_quotes_runtime - Success
allow_url_fopen - Success
php_session - Success
file_upload - Success

Other tests:

php_magicquotes - Failure
zlib_extension - Success
mbstring_extension - Success
imagegd_extension - Success
imagemagick_program - Success
database_all_extensions - Failure
php_register_globals - Success
texttoimage_functions - Success

Monday 15 May 2006 3:56:00 am

I seem to be having the same problem as everyone else. I get through almost the entire installation, then things go haywire. After renaming .htaccess_root to .htaccess, I get the 500 internal serve error. I also have a 1and1.com account like some of the other users. I don't know if this is like a host provider problem (1and1.com), or what.

PLEASE help! I really want to use EZ Publish!

Monday 15 May 2006 12:01:46 pm

It's possible that your ISP doesn't allow you to use mod_rewrite, or doesn't allow you to use .htaccess files. The permissions for .htaccess are set in the apache configuration by the directive AllowOverride.
A 500 Internal Server Error is usually the result of invalid directives in .htaccess.
See also:
http://httpd.apache.org/docs/2.0/howto/htaccess.html

Monday 15 May 2006 10:49:23 pm

Marc,

Just did a little research and found that my host provider (1and1.com) does indeed support .htaccess files. So, my next conclusion is that it's something in the EZ Publish scripts or perhaps a chmod permission issue somewhere. Any ideas?

- Joe

Thursday 29 June 2006 12:42:05 am

Hi,

Sorry if this has already been resolved, but.. has this problem been resolved? I've been scratching my head over this for quite some time. I use 1&1 for webhosting.

Perhaps its an encoding thing? Are the PHP files in Unicode? .... I'm going to check this out actually.

Has anyone tried setting permissions of the whole site to 777? Of course this would just be for testing, but it would rule out file and directory permissions as the cause of the problem.

If the encoding is right, and the permissions don't effect this error, the only thing I could think of is some function that is not supported by 1&1 that Ez uses. I currently have a Joomla install fully functional on my hosting package, so whatever is causing this problem is not used in Mambo or Joomla... something that Ez uses and is not very common.

I think I'm going to check the phpinfo(INFO_MODULES) and the used functions...or perhaps its a PHP executable permission problem? (try saying that when you're drunk!) ^_^

Anyway, let me know if there's been any progress on this problem!
Thanks!

Thursday 06 July 2006 11:31:30 pm

Does the site work ok if you delete the content from the .htaccess file?

If it does then it is a problem with the .htaccess file - which I had in the past.
First thing to check is if your host has PHP installed as a CGI or Apache module. If it's installed as a CGI (you will know by ?s being in your urls) then I doubt this solution will work, but if it's an Apache module it should work ok.

This is what I have in my .htaccess - try this although do check the security of it yourself on your server. It works for me, but I'm no expert at rewrite rules.

php_value magic_quotes_gpc 0
php_value register_globals 0

DirectoryIndex index.php


RewriteEngine On

RewriteRule !\.(gif|jpe?g|png|css|js|jar|html)|var(.+)storage.pdf(.+)\.pdf?$ - [C]

RewriteCond %{HTTP_HOST} ^webdav\..*
RewriteRule ^(.*) webdav.php [L]
RewriteCond %{HTTP_HOST} ^soap\..*
RewriteRule ^(.*) soap.php [L]
RewriteRule ^var/cache/debug.html.* - [L]
RewriteRule ^var/[^/]+/cache/debug.html.* - [L]
Rewriterule ^var/storage/.* - [L]
Rewriterule ^var/[^/]+/storage/.* - [L]
RewriteRule ^var/cache/texttoimage/.* - [L]
RewriteRule ^var/[^/]+/cache/texttoimage/.* - [L]
Rewriterule ^design/[^/]+/(stylesheets|images|javascript)/.* - [L]
Rewriterule ^share/icons/.* - [L]
Rewriterule ^extension/[^/]+/design/[^/]+/(stylesheets|images|javascripts?)/.* - [L]
Rewriterule ^packages/styles/.+/(stylesheets|images|javascript)/[^/]+/.* - [L]
RewriteRule .* index.php [L]

Regards,

Tim

Saturday 02 December 2006 2:46:15 pm

Hi

I refresh this topic because I have this same problem and nothing what you wrote here doesn't work.

My site is on server in catalog /kacperix

I have domain on this server, and this domain is set to this catalog.

My .htaccess file is:

# Copy this file to a new file called .htaccess in your eZ publish root
# to make the site more secure in non-virtualhost mode (index.php used in urls).
#

php_value allow_call_time_pass_reference 0
php_flag magic_quotes_gpc off
php_flag register_globals off
php_value memory_limit 64M

<FilesMatch ".">
order allow,deny
deny from all
</FilesMatch>

<FilesMatch "(index\.php|\.(gif|jpe?g|png|css|js|html)|var(.+)storage.pdf(.+)\.pdf)$">
order allow,deny
allow from all
</FilesMatch>

# If you see "Forbidden" when trying to access root page of your site
# without 'index.php' appended, uncomment the following "Files" section.
# NOTE: replace "ezpublish-3.6.0" with base name of the directory
# where your eZ publish intallation resides.
# e.g. base name of "/sites/ezpublish/ezpublish-3.6.0" is "ezpublish-3.6.0".

<Files "kacperix">
order allow,deny
allow from all
</Files>

RewriteEngine On
RewriteRule !\.(gif|jpe?g|png|css|js|html)|var(.+)storage.pdf(.+)\.pdf$ index.php

DirectoryIndex index.php

When I request adress www.mydomain.com I've got 500 Internal Server Error.

When I change line:

RewriteRule !\.(gif|jpe?g|png|css|js|html)|var(.+)storage.pdf(.+)\.pdf$ index.php

to:

#RewriteRule !\.(gif|jpe?g|png|css|js|html)|var(.+)storage.pdf(.+)\.pdf$ index.php

and then request adress www.mydomain.com then all it's OK.

Is this line very important for site?? Could it stay commented or must be uncommented??

Please help.

Saturday 23 December 2006 9:04:13 pm

I am losing the fight over this.
My host 1and1 says they support mode rewrite and there is something wrong with my script.

I simply want to change:
www.mysite.com/system/listingview.php?listingcode=1234
www.mysite.com/system/listingview.php?listingcode=1235

to something more seo friendly. It's the /system folder files that i want to rewrite.

I used this code:

RewriteEngine on
RewriteBase /
RewriteRule ^system/listingView.php?listingCode=$1 /system/listing/([0-9+])/$

also tried this and many other ways....

RewriteEngine on
RewriteBase /
RewriteRule ^system/listingView.php?listingCode=$1 /system/listingcode/([0-9+])/$

I am getting errors.
If mode rewrite worked for you with 1and1, can you please share the code you used....

Thanks,

Modified on Saturday 23 December 2006 9:05:50 pm by Fahim Jan

Saturday 23 December 2006 9:22:58 pm

Hi Fahim Jan

This does not look like an question that has to do with eZpublish, so you should go to a forum dealing with whatever CMS you use or to a forum dealing with mod_rewrite questions.

Just a small tip: Your rewrite rule is the wrong way around. What you want is that a user (or google) can use a url like example.com/foo/bar/123 and that your script sees example.com/foo/bar?bla=123. So you need to rewrite example.com/foo/bar/123 to the other url. For more info please ask in the correct forum.

Claudia

Saturday 10 March 2007 8:17:00 am

Hi there.

Has anyone found a solution for this already? I'm new to using PHP that's why I really dont have any idea why we get this 500 Internal Server Error.

Friday 04 May 2007 10:25:40 pm

I had the same 500 error- tried all the solutions- I finally contacted my host's support.

I hope this helps those of you that spent wayyy too much time on this error!
Here is my conversation:
_ _ _ _ _ _ _ _ _ _ _

I just went through the install of ezpublish.
All went well

Summary=>
System: OK
Image system: ImageMagick
Mail: sendmail
Database: MySQL
Language: eng-US
Site: ezwebin_site
100% completed

I just can't access the page. I get a 500 error.
I have gone to their forums, and tried everything suggested, still 500.

Is there a way I can get access to some sort of log file that would tell me where it hangs up?

Most of the time it is a permissions thing. I think I got all the folders set to 775.

Thanks,

Norm

_ _ _ _ _ _

May 04 2007 16:08
A: Support37 Hello,

The 500 error was caused by the following flags in the .htaccess file in the "ezpub" folder:

php_value magic_quotes_gpc = 0
php_value allow_call_time_pass_reference 0

Please note that PHP directives in the .htaccess file are not supported on our servers, as we are running PHP in CGI mode with SuExec.

PHP directives should be placed in php.ini files instead. Please create an empty file named php.ini and add the following lines to it:

magic_quotes_gpc = off
allow_call_time_pass_reference = off
register_globals = on
post_max_size = 20M
memory_limit = 80M
upload_max_filesize = 20M
max_execution_time = 120
expose_php=off

Please note that php.ini files do not work recursively as .htaccess files, if you see this error in any of the subdirectories, just copy the php.ini file there as well.

Let us know if you need any additional information or assistance.

Best Regards,
Support
May 04 2007 19:09

_ _ _ _ _ _ _ _

Q: Hi, Thanks for your help.
I created a php.ini file.
I deleted (re-named) the .httaccess file to test.php to see if it would work without an .httaccess file.
No such luck. Still 500 Error!
I will go back to the Forum Page and see what else I can find.

I just love a challenge!

Norm
May 04 2007 20:02

A: Support37 Hello,

The problem is that your application hits the memory limit for your hosting account.

Our System Administrators raised the memory limit to 95 MB and your application loads fine now.

Please test it and let us know if you experience further problems.

Best Regards,
Support

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from