This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » AcceptPathInfo disabled or running in...
expandshrink

AcceptPathInfo disabled or running in CGI mode (again)

AcceptPathInfo disabled or running in CGI mode (again)

Thursday 25 November 2010 12:02:58 pm - 1 reply

Anyone

I am new to EzPublish, trying to install, during System Check I get:

AcceptPathInfo disabled or running in CGI mode

Installing on ubuntu server 10.10, with LAMP, do not beleive I run php in CGI mode (whatever that is), how do I find out?

Apache is sett to use Virtual Hosts. Tried to add:

<Files "mypaths.shtml">
Options +Includes
SetOutputFilter INCLUDES
AcceptPathInfo On
</Files>

Replacing mypaths.shtm with "ezpublis" home directory.

in apache2.conf (ubuntu use this not httpd.conf. No effect. Tried in the Virtual Host file, no effect. Also tried in .htaccess, no effect.

Anyone, what do I do?

Thursday 25 November 2010 10:28:51 pm

To find out if you run in CGI mode, put a phpinfo(); page on your web server, look at its output, in the line where it says "Server API" near the top. You should see "Apache 2.0 Handler" or something similar (ie. you're running php as an apache 2 module).

If you're running php as apache 2 module, you do not need to add AcceptPathInfo to your server config, and can ignore that warning (apache will accept path info added to php files anyway, which means the eZ Publish urls like http://my.server/ezp/index.php/path/info will work)

Modified on Thursday 25 November 2010 10:29:39 pm by Gaetano Giunta

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from