eZ Community » Forums » Install & configuration » Admin freezes when doing certain tasks
expandshrink

Admin freezes when doing certain tasks

Admin freezes when doing certain tasks

Thursday 27 October 2011 11:51:55 am - 4 replies

I've recently been having trouble with admin freezing when doing certain tasks.

My system:
eZ Publish 4.4
PHP 5.2.14
APC 3.1.6

  • Adding a new content class.

Because admin freezes the class isn't added. But is found in the DB with version=1.
Is it sufficient to just alter the version (version=0)  in the DB (in the various ezcontentclass-tables) to activate the class?

  • Adding a role to a user

The role gets added but as admin is "waiting for  admin.example.com.." I have to use another browser or any of my other urls to admin (e.g admin.example2.com).
Other issues:
"Content structure" , "Media library", "User accounts"
The treemenu at the left doesn't show anything.
(Sub items shows just fine)
Firebug gives me:

 this.classes[item.class_id] is undefined
var classIdentifier = this.classes[item.class_id].identifier;

Searching for this gives me: http://issues.ez.no/IssueView.php?Id=14808&activeItem=2

But this is fixed for 4.4..

My contentstructuremenu.ini hasn't been changed from when it worked.
PS: On "Dashboard" the "site structure"-treemenu shows just fine.
I believe that the issues with admin freezing and the lack of treemenu is related. But haven't found a solution. Any ideas?

Friday 28 October 2011 1:07:05 pm

This could be a problem with your php.ini values... are your max_execution_time, max_input_time and  memory_limit values correct?  If you are running sohusin also make sure your settings for that are correct.  See http://share.ez.no/blogs/steven-e.-bailey/protip-suhosin

Monday 31 October 2011 9:21:28 am

Thanks for suggestions Steven!

max_execution_time, max_input_time and  memory_limit values are set correct and shouldn't be the reason. I'm not running Sohusin so we can eliminate that as well.

I'm trying to remember how it started and actually I did clear some cache that took forever. I forgot to add "-s siteaccess" and my 8-sites-installation didn't like that.I did this to solve the freezing-issue. But instead it gave me the missing treemenu-issue...

Have tried "php bin/php/ezcache.php --clear-id=content_tree_menu -s admin" without success.

Tuesday 01 November 2011 1:27:15 pm

I got some suggestions via IRC that I will try when my hosting-man is back from vacation. Will report back when I know more.

  • sounds like a simple mod_rewrite problem
  • Have you tried disabling APC? See if it helps
  • du u use ForceVirtualHost=true ?
    • I have ForceVirtualHost=false
  • try to use it, set it to true and use this rewrites: http://doc.ez.no/eZ-Publish/Techn.../4.4/Installation/Virtual-host-setup after this clear complete
  • in the 4.4 should be a correct htaccess, rename .htaccess_root to .htaccess

Monday 28 November 2011 11:53:25 am

The reply has been removed because of violation of forum rules.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from