eZ Community » Forums » Install & configuration » apache segfault(11)
expandshrink

apache segfault(11)

apache segfault(11)

Monday 17 July 2006 5:48:04 pm - 8 replies

On a new webserver installing ezpublish 3.8.1 and following the installationscript and changing the accessright according to the set up script I get a apache segfault(11).

This works:
drwxrwxr-x 2 www-data www-data 4096 2006-06-17 14:54 ini
drwxrwxrwx 3 nobody nogroup 4096 2006-06-17 14:21 packages

But if I change this to
drwxrwxr-x 2 nobody nogroup 4096 2006-06-17 14:54 ini
drwxrwxrwx 3 nobody nogroup 4096 2006-06-17 14:21 packages

I got the segfault.

I did run modfix.sh and it is apache 1.3 and php 4.4 on a ubuntu server.

How can I debug this error and more important how can I solve this.

Cheers.

Hapee

Modified on Monday 17 July 2006 5:54:59 pm by Hapee de Groot

Monday 17 July 2006 7:11:51 pm

Hi

The first thing I normally do when I get apache segfault(11) is to check my memory with memtest86. A simple change in the file system like different permissions on directories can also change memory areas are addressed.

At least a simple first check in a debug process.

Egil Fujikawa Nes

Tuesday 18 July 2006 11:00:07 am

Thanks Egil,

I did de memtest and no errors whatsoever, anybody else a suggestion, because the error remains.

I ran some more tests: I installed 3.7.6 without problem and it is working great, so I did a test with 3.8.1 again, the install script says:

The affected directories are: var/cache/ini
These shell commands will give proper permission to the webserver.

cd /var/www/demeter.hivos.nl
chmod -R ug+rwx var/cache/ini
chown -R nobody:nogroup var/cache/ini

Alternative shell commands

If you don't have permissions to change the ownership you can try these commands.

cd /var/www/demeter.hivos.nl
chmod -R a+rwx var/cache/ini

Whatever I change to var/cache/ini, whether I change the user, the group or the write permissions it is wrong and I get the segfault (11).

Should I file a bug? I will try 3.8.0 later today.

Hapee

Modified on Tuesday 18 July 2006 12:59:02 pm by Hapee de Groot

Wednesday 19 July 2006 9:13:41 pm

I tried the new 3.8.2 today and it is giving me exactly the same error, so these errors are consequent but nevertheless very irritating.

To repeat, every single file belongs to nobody:nogroup (conform httpd.conf) except var/cache/ini, if I turn this to nobody:nogroup apache segfaults, when I leave it to root:root for example and turn the group worldreadable again a segfault, so what is in there that makes apache crash?

Please anyone, who can help me a step further?

Thursday 20 July 2006 5:07:48 am

Hi

Let my try to help again. I'm not a Ubuntu expert and I'm not 100% updated on what user Apache run with as standard in Ubuntu, but I found something strange in your configuration.

In your first post you write: <i>On a new webserver installing ezpublish 3.8.1 and following the installationscript and changing the accessright according to the set up script </i>

I guess the access rights settings you refer to is the one form the output of modfix.sh:

*** WARNING WARNING WARNING WARNING ***
This script sets 777 as permissions in var/
THIS IS NOT SECURE!
Find the user and group for your web server and make them owner of all files in var/
You should be able to find this information in the configuration file for your web server.

For example:
If your web server user is apache and the group is apache, then run the following commands:
# chown -R apache.apache var/
# chmod -R 770 var/

As far as I can see from Ubuntu forums the Apche user and group is www-data:www-data and not nobody:nogroup, isn't that correct for your installation as well ?

If your Apache user and group is www-data:www-data, your should run this commands to get correct access according to modfix.sh

cd /var/www/demeter.hivos.nl
chown -R www-data:www-data var/
chmod -R 770 var/

I'm sorry if I miss understood something, but as fare as I can understand based on Ubuntu forums and the output of modfix.sh your have wrong owner of your var folder.

I also get segfault from my Apache with eZ publish 3.8.0 if I remove the apache user's right to write data in var/cache/ini. For me this seems to be logical since eZ publish will try to write data cache files that he don't have access to write.

Best regards
Egil Fujikawa Nes

Modified on Thursday 20 July 2006 5:08:49 am by Egil Fujikawa Nes

Thursday 20 July 2006 9:26:24 am

Thanks again Egil,

I really apreciate your helpfull remarks. The truth is a little stranger tough.

Ubuntu is not really stranger than debian for example and the apache user is just wat you put in the httpd.conf, it was www-data and I changed it to nobody, for the sake of transparency I put it back to www-data, so this is the contents of var:

drwxrwx---  6 www-data www-data 4096 2006-06-19 21:54 .
drwxr-xr-x 15 www-data www-data 4096 2006-06-19 21:54 ..
drwxrwx---  9 www-data www-data 4096 2006-06-19 21:54 cache
drwxrwx---  2 www-data www-data 4096 2006-06-19 20:53 log
drwxrwx---  4 www-data www-data 4096 2006-06-19 21:54 news_site
drwxrwx---  4 www-data www-data 4096 2006-06-19 21:54 storage

and I get the segfault.

if I change:

chown -R root:root var/cache/ini

any only this, the site is back on but produces the obvious errors in the logfiles:

Couldn't create cache file 'var/cache/ini/a98c36dfb5d4436ec289cdace371d710.php', perhaps wrong permissions

Than again if I make this directory worldwriteable it segfaults again. So I am really stuck and wonder if this is ubuntu specific or ezpublish 3.8 specific, can anybody of eZ show some light here?

Thanks in advance.

Hapee

Sunday 23 July 2006 2:59:20 pm

EZ Publish 3.8 works very well with Ubuntu. Are you using any PHP accelerators/caches?

Does the apache error logs give any more information other than segfault?

Sunday 23 July 2006 11:38:56 pm

Just a wild guess: after Stian mentioned PHP accelerators, it crossed my mind that there are some unresolved bugs with eAccelerator 0.9.5 release candidates which can cause apache segfault(11)...
http://eaccelerator.net/ticket/16

Tuesday 25 July 2006 9:28:22 pm

Thanks so far, it was not the accelerator, I use Turck MMCache but I tried without and with, no difference. I also took of apache 1.3 and installed apache 2 no difference. I will install Debian on the server again and install everything again. I hope this will lead to no segfault, if so you will find me here.

Hapee

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from