This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Cache clear issues in WIMP setup
expandshrink

Cache clear issues in WIMP setup

Cache clear issues in WIMP setup

Thursday 22 March 2012 4:06:01 pm - 8 replies

Working in a WIMP setting, Win2008 32bit, PHP 5.3.10 (FastCGI), IIS7 (client insisted).

Everything seems to be mostly the same as Linux version, except for one thing: After a cache clear, the next page request (and all subsequent ones) start eating up all of PHP's memory until PHP dies. The only cure is changing php.ini which somehow restarts the PHP process (different thread or something).

Any thoughts as to how to get this to go away?

Note: clearing the cache itself is not a problem, that part finishes just fine (running it from command line to verify this). It's any page hits after the clear that are the problem.

Thursday 22 March 2012 4:24:00 pm

Hi Miro, 

How much memory is allocated to php ? (memory_limit in php.ini)

Cheers,

Thursday 22 March 2012 10:20:58 pm

It doesn't seem to matter. I started out with 128MB, then went all the way up to almost 400MB in increments of about 50, then back down into 64MB range. The behavior is always the same: that next page hit after cache refresh uses all the memory given, then wrecks.

Thursday 22 March 2012 11:03:03 pm

I'd recommend not to go under 128MB of memory, though.
Anything relevant in error.log under var/log/ ?

Thursday 22 March 2012 11:50:42 pm

Are there any miss-matched cache-blocks or foreach loops? Or even a hanging {} tag?  I've seen timeouts after clearing cache because of that.

But, if it's working fine with the exact same setup in linux then that probably wouldn't be it.

Friday 23 March 2012 3:52:47 pm

So I noticed a bunch of these on cache clear:

No path specified for cache item '***', can not clear cache.

Applied the patch listed here(http://issues.ez.no/IssueView.php?Id=18207&activeItem=2), that error disappeared. Then ran the cache clear command line, as a windows administrator, that finished without errors. Tried it through the admin interface, back to the same memory/timeout issue. 

This time, I see this in the log:

[ Mar 23 2012 10:40:17 ] [10.130.190.61] eZINI::saveCache:Couldn't create cache directory var/cache/ini/, perhaps wrong permissions.

In windows, as Administrator, I can't even see anything in this folder. Under security tab, it says that "To conitnue, you must be an administrative user... etc.". I click "Continue", and I get to Advanced Security Settings tab. Current owner is: "Unable to display current owner." I am offered to change the owner to Administrator, but when I try to apply, "Windows Security" popup informs me that it's "Unable to set new owner on ini. Access is denied".

What is ez doing with this folder to get it in this state? The entire var directory is fully readable/writeable by Everyone. All the other cache folders seem ok.

Tuesday 27 March 2012 6:08:20 pm

Hi Miro, 

Is var/cache existing at all ? 

I am no Windows expert, but what system user does the web server or PHP process use ? It must have read/write access to the var/cache folder...and maybe "Everyone" is not 100% everyone... ?

Cheers,

Tuesday 10 July 2012 4:17:34 pm

Further investigation has shown that this may be a php-cgi.exe locking the directory problem.

Changing the php.ini or using a windows 'unlocker' will reset the /var/cache/ini directory permissions to being accessible by windows.

Can someone explain the php clear cache steps and if that would spawn a php subprocess that locks the directory?

Tuesday 10 July 2012 9:24:36 pm

@David I use eZ on windows every single day, and I've never had this problem. Are you running php in cgi mode? Which webserver are you using?

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from