eZ Community » Forums » Install & configuration » Composer dependencies conflict
expandshrink

Composer dependencies conflict

Composer dependencies conflict

Friday 25 July 2014 4:17:42 pm - 5 replies

Since a few days, whenever I'm trying to composer update my vendors (ezcommunity project), I get the following error : 

Your requirements could not be resolved to an installable set of packages.
  Problem 1    - Conclusion: remove ezsystems/ezpublish-legacy v2014.05.1    - Installation request for ezsystems/ezpublish-legacy 2014.05.1 -> satisfiable by ezsystems/ezpublish-legacy[v2014.05.1].    - ezsystems/ezpublish-legacy v2014.05.1 requires zetacomponents/signal-slot dev-master#74deb41 -> satisfiable by zetacomponents/signal-slot[dev-master].    - zetacomponents/signal-slot dev-master requires zetacomponents/base 1.8.* -> satisfiable by zetacomponents/base[1.8].    - zetacomponents/signal-slot dev-master requires zetacomponents/base 1.8.* -> satisfiable by zetacomponents/base[1.8].    - Conclusion: don't install zetacomponents/base 1.8

Any one has informations about this issue ?

Thanks ! blunk.gif Emoticon

Saturday 26 July 2014 2:41:09 pm

Same issue here...Did you find a solution Pierre?Gabriele

Sunday 27 July 2014 2:09:10 pm

I tried tweaking versions of the bundles to make it work, but I haven't succeeded to make it work sad.gif Emoticon

For the moment, I took the packaged version instead of the composer install =/

Friday 01 August 2014 3:28:43 pm

Solved thanks to Jerome's fix on the composer.json file ! Thanks ! happy.gif Emoticon

Friday 01 August 2014 3:34:19 pm

Ciao Pierre,

where can I find the needed changes?

Gabriele

Friday 01 August 2014 4:54:28 pm

The up-to-date composer.json file is available here : https://github.com/ezsystems/ezpu...-community/blob/master/composer.json

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from