This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Install & configuration » Cronjobs kills Apache

Cronjobs kills Apache

Cronjobs kills Apache

Saturday 30 April 2011 2:22:01 pm - 4 replies

The site is a local installation on XAMPP 1.7.3 on Windows XP SP3, eZ 4.4 ezflow with Demo Content
The project is installed on a vhost (name based and IP-based)

Everything on the page works. Only the debug report shows errors in the translation. The main language is German and second language English.

Debugreport eZ 4.4

 Error: eZTSTranslator:: handleMessageNode Apr 29 21:05:36 2011
 No source name found, skipping message
 Warning: PHP: E_WARNING Apr 29 21:05:36 2011
 strpos () expects parameter 1 to be string, array given in E: \ proj \ www \ ez44test \ htdocs \ lib \ eztemplate \ classes \ eztemplate.php on line 1746
 Debug: ezpI18n:: translate text Apr 29 21:05:37 2011
 Missing translation for message in context: 'design / standard / parts / website_toolbar'. The untranslated message is: 'Remove node RSS / ATOM feed'
 Debug: ezpI18n:: translate text Apr 29 21:05:37 2011
 Missing translation for message in context: 'design / standard / parts / website_toolbar'. The untranslated message is: 'Create node RSS / ATOM feed'  

The messages likely to be based on incomplete ts files. I will translate this in the coming days.

The cronjobs run manually via a batch file.

E: \
 cd proj \ www \ ez44test \ htdocs \
 php.exe runcronjobs.php

After this skript, when I load a dynamic page (I only eZ test installations) crashes Apache. Static pages are without errors. eZ provides no error message, only the Apache. Unfortunately, I understand this message not, because I am not a developer.

PHP error

[Fri Apr 29 21:24:05 2011] [apc-error] apc_fcntl_lock failed errno: 1

1. Where can I find the error?
2. Is there a danger of crashing on a real (Linux) Web server?

In hope of help

Modified on Sunday 01 May 2011 2:20:39 pm by Falkmar Fischer

Sunday 01 May 2011 11:19:12 am

Seem like you have issues with APC, the php accelerator, try disabling it in your php.ini settings or if there is a controll panel for xampp, do it there. If that fixes it, try getting a more stable version of APC from the xampp project (either upgrade or downgrade).

Modified on Sunday 01 May 2011 11:20:25 am by André R

Sunday 01 May 2011 2:18:47 pm

Thanks Andre,
No idea, how I install the latest stable version of the PECL in XAMPP. Xampp 1.7.4 I've tried. There was too many problems.
Without APC, I have no problems (yetblunk.gif Emoticon). Thanks again, the cronjobs does working .
For all other below the parts of the PHP info and php.ini

APC-Info aus phpinfo.php

Version     3.1.3p1
MMAP Support     Disabled
Locking type     File Locks
Revision     $Revision: 289940 $
Build Date     Dec 13 2009 15:27:59

[PECL] aus php.ini

;APC switch off, becouse Problems with cronjobs
;    extension=php_dbase.dll
;    extension=php_fbsql.dll
;    extension=php_msql.dll
;    extension=php_pdo_oci.dll
;    extension=php_rar.dll

Monday 02 May 2011 11:39:12 am

Note: you are usually better served using 2 separate php.ini file: one for the web version and one for the cli version. This way you can usually enable the opcode cache such as APC for Apache and not for the cli version.

When running php on the cli, use the "-c" to specify an alternative ini file.

Tuesday 03 May 2011 12:22:28 am

Yesterday I read after Andres tip through the Internet. An interesting journey. Xampp is 1.7.3 with PHP 5.3.3 and APC 3.1.3p1. This package seems APC Official suitable only for PHP 5.1 and 5.2. The problems with PHP 5.3 I can confirm. The dynamic web pages within one hour sleep (alone in the development).

Since I do not get any further with ACP under Xampp I was looking for alternatives on Windows. I have found only WinCache (with additional installation platform) and eAccelerator. For research on the problems with eAcceletor I then met with memcached.

win32 binary

php_memcache.dll =

The caching works. An accelerator for a local testing environment is memcached not really . But I have been too many problems with my page and can not real say, what is fact.

The idea with two php.inis is interesting, because eZ does memcached not recognize. Thanks for this tip.

Modified on Tuesday 03 May 2011 12:25:07 am by Falkmar Fischer


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from