eZ Community » Forums » Install & configuration » DB problem
expandshrink

DB problem

DB problem

Friday 05 August 2005 4:17:34 pm - 11 replies

Dear EZ team,
the EZ CMS is great , not me who will say it , but all of the world. but i face a problem that is really killing my project

I need the search engine to work
I built my project on version 3.3-3 and somethign wrong happend to the Db in the begining, specially with the search index table.
when i tried to rebuild the index at the begining , it didn't work.
Recently i upgraded from 3.3-3 to 3.4.0 passing by 3.3-4 and 3.3-5
And still my search box searches and returing 0 results.
i was wondering if you can help me , and i am sure you can do that. URgently please
Thanks
John Mina

Saturday 06 August 2005 9:00:43 am

Hi JOhn,

How did you rebuild the search table? There is a command to rebuild that normally works.
http://ez.no/products/ez_publish_...supplied_scripts/update_search_index

If this does not work, try the search via the admin interface. If that works then you know the problem is with the front end.

Let me know

tony

Saturday 06 August 2005 3:04:55 pm

hi john,

please check if the database user can create temporally tables (CREATE TEMPORARY TABLE XX). if this function is not enabled for the user you cannot search and find items in ez.

frank

Sunday 07 August 2005 9:31:11 am

Hi Tony, Hi Frank.
First of all , thanks a lot for your effort and advice.
Second, the user is able to create tables in the db , i tried that through the phpMyAdmin interface and it wworked.

Mr Tony,
I have 2 running versions, on 2 different data bases. one for v 3.3-5 and the other one for 3.4
When i runned the command
<i>php -C update/common/scripts/updatesearchindex.php</i>

at the 3.4.0 version , i recieved

Content-type: text/html
X-Powered-By: PHP/4.3.6

PHP is currently using the 'cgi' interface. Make sure it is using the 'cli' interface.

and when i runned that command at the 3.3-5 version i recieved :

Content-type: text/html
X-Powered-By: PHP/4.3.6
Set-Cookie: eZSESSIDelwa7a=06b2e2cd51caad13ea2426c8ae992ba8; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache

Starting object re-indexing
Number of objects to index: 2173 
...........................................................sh: line 1: pstotext: command not found
sh: line 1: pstotext: command not found

it just freezed after that , i don't know if it continued or not ?
and what should i do to enable the CLI interface ?
Note: the search mechanism is already not working from the admin interface.
Looking forward to hearing from you
Thanks again
John

Sunday 07 August 2005 10:13:09 am

Hi,

I think the problem with the php -C update/common/scripts/updatesearchindex.php command is that you need the php command line interface installed. This will enable you to run the command.
If you run the box this is installable by installing php-cli. Once this is installed the command will run.
This is probbly useful as you need to run cronjobs too.

Sunday 07 August 2005 10:26:45 am

Hi ,
Where can i get the php-CLI from ?
hwo to install it ?
will it affect in a bad way any other php site ? as i have many sites hosted at that server.

knowing that , I have a root access the server .

Thanks a lot for help
john

Wednesday 10 August 2005 10:22:02 am

Hello,
I really need that to be solved ,
can you help me how to install the CLI to my dedicated server ?
Thanks
J

Wednesday 10 August 2005 10:41:39 am

Hi

What distribution are you running? Redhat Fedora, ES? Debian?

Tony

Wednesday 10 August 2005 12:29:10 pm

Hi Tony,
I am running on fedora, and my PHP: Version 4.3.6
Other information as the ez-publish system information show me :
<i>
Extensions

yp, xml, wddx, tokenizer, sysvshm, sysvsem, standard, sockets, shmop, session, pspell, posix, pcre, overload, mbstring, iconv, gmp, gettext, gd, ftp, exif, dio, dbx, dba, curl, ctype, calendar, bz2, bcmath, zlib, openssl, apache2handler, domxml, imap, ldap, mysql, odbc, pgsql, snmp, xmlrpc

Safe mode is off.
Basedir restriction is off.
Global variable registration is off.
File uploading is enabled.
Maximum size of post data (text and files) is 8M.
Script memory limit is 26M.
Maximum execution time is 60 seconds.
</i>

Thanks for your welling to help
J

Thursday 11 August 2005 10:47:45 pm

Hi John,

I tend to compile PHP, but if you look for an RPM something like phpcli then install that should do the trick

Good luck

Tony

Thursday 11 August 2005 11:32:17 pm

Hi Tony,
Thanks for the valuable advice,
but i was losthappy.gif Emoticon
I have a windows background , i'm new to linux, how would i recompile php, or how where is the RPM to find the phpcli ?

sorry for asking to many questions.
thanks
John

Modified on Thursday 11 August 2005 11:35:06 pm by John Mina

Friday 12 August 2005 12:23:22 am

You can find RPMs at www.rpmseek.com (among other places). For most things you want, you can download the RPM and use whatever package management tool Red Hat is supplying these days to install it.

If you can't find what you're looking for, you'll have to download and build it yourself. (I've had problems doing this when I built something that installed new versions of libraries the RPM manager thinks it's controlling. I'm not a big fan of the RPM system, so I usually just took this route anyway, back when I was doing Red Hat. Then again, I'm fairly comfortable installing everything from scratch every few months).

Building it yourself can be a little intimidating the first few times you do it. Especially if you're not comfortable using a command line (if you're switching to Linux, you really should get comfortable with the command line. It's really much nicer and more powerful than using a mouse. It just takes more effort to learn). I won't go into great detail here, but this is the way it usually works:

You almost always find a "tarball" to download. A lot of times you can go to www.sourceforge.net (where a *lot* of software projects are hosted) and search for whatever interests you. Fiddle around there until you find the project you want, then go to their download page and pick out a server that's close to you.

You'll wind up with some file named something like "php.4.1.2.tar.gz" The numbers are usually version numbers. gz means it was compressed using the gzip program (kind of like winzip). tar means it's a bunch of files mashed into one big file (using a program called tar). That's why it's called a tarball.

You can "unzip" it by changing into the directory it's in and typing "gzip -d whatever.gz<RET>" (where <RET> means the return key). The computer will chug away for a little bit, then it should take you back to the command prompt as if nothing happened. While you weren't looking, though, it transformed whatever.tar.gz into whatever.tar.

Now you can "unpack" the tar file using tar xvf whatever.tar. It'll print out a list of all the files it's extracting as it does them. When it finishes, you can changed into whatever directory it created. (Usually, if you're extracting whatever.1.1.tar, it'll create the directory whatever.1.1).

Now you get to the actual build phase. There should be a README file with the instructions. Usually, you'll run 3 commands:
configure (this lets it figure out how to work with your system. A lot of times you'll give specific directions to this command, like to tell it you want PHP's CLI as well as the part that works with your web server).
make (this actually builds the software. If you thought configure was slow, it'll blow your mind how long this takes).
make install (this copies the files out to wherever they belong).

Like I said, it kind of sounds scary. It's not. After you've done it a few times, you won't think twice about it any more.

HTH,
James

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from