eZ Community » Forums » Install & configuration » Error when upgrading from 3.8.6 to 3.9.0
expandshrink

Error when upgrading from 3.8.6 to 3.9.0

Error when upgrading from 3.8.6 to 3.9.0

Tuesday 19 December 2006 1:07:42 am - 9 replies

I've upgraded my site from 3.8.6 to 3.9.0 following the upgrade documentation and have only had one problem when running this script:

# php update/common/scripts/3.9/correctxmltext.php --global

Fatal error: Call to a member function on a non-object in /var/www/flaubris.no/update/common/scripts/3.9/correctxmltext.php on line 278

Fatal error: eZ publish did not finish its request
The execution of eZ publish was abruptly ended, the debug output is present below.

It will run flawless if I run the command vith the --skip-objects option.

Classes look like this now:
a:2:{s:6:"nor-NO";s:11:"Forum reply";s:16:"always-available";s:6:"nor-NO";}
a:2:{s:6:"nor-NO";s:11:"Styremedlem";s:16:"always-available";s:6:"nor-NO";}
a:2:{s:6:"nor-NO";s:7:"Spiller";s:16:"always-available";s:6:"nor-NO";}
...

Does anyone have suggestions how I should fix this problem?

Modified on Tuesday 19 December 2006 1:32:11 am by

Friday 22 December 2006 9:50:07 pm

Could the strange class problem be due to this bug:
a:2:{s:6:"nor-NO";s:11:"Forum reply";s:16:"always-available";s:6:"nor-NO";}

I tried the script several times, but with different options...

Modified on Friday 22 December 2006 9:50:36 pm by

Saturday 23 December 2006 7:44:46 am

Hi Hans-Henry

I had the same issue. I'll post a script to fix the problem this afternoon.

Saturday 23 December 2006 9:10:29 pm

OK, thanks.
I'm looking forward to test it.

Sunday 24 December 2006 11:27:17 am

With a small delay, I've uploaded the script as a contribution on ez.no:
http://ez.no/community/contribs/hacks/fix_class_translations

Let me know if it works for you.

K.

Thursday 28 December 2006 6:05:16 am

Hi
I've also experienced trouble with this script. If I include the --skip-objects option then it also runs okay. Any ideas as to why this is happening, I definitely did not run the script more than once.

root@mybox:/var/www/mysite# php update/common/scripts/3.9/correctxmltext.php --global

Fatal error: Call to a member function on a non-object in /data/www/mysite/update/common/scripts/3.9/correctxmltext.php on line 278

Fatal error: eZ publish did not finish its request

Modified on Thursday 28 December 2006 6:05:54 am by Brendan Pike

Thursday 28 December 2006 10:32:48 am

To avoid confusion: the serialized PHP array as a class name is caused by running updateclasstranslations.php more than once. The correctxmltext.php script has nothing to do with that problem.

Thursday 28 December 2006 11:00:04 am

Thanks for the clarification Kristof

Hans-Henry original post described the exact error I also got thus my post. It might be best if I report it as a bug. I was hesitant to do that initially because I don't have much information to offer about it. I've pretty much ignore the bug and moved on to 3.9 as it doesn't seem to have been very crucial to the upgrade.

Cheers

Friday 29 December 2006 1:35:10 am

I have the same problem, that Brendan describes. It seems, that error occures when script tries to convert <object > tag.

I've changed script to show article ID. Then loaded "problem" article into OE and saved back (OE normalise <object > to <embed >blunk.gif Emoticon. After that, script pass that article without problems (and crash on the next one).

But I don't wish to convert every article manually sad.gif Emoticon

Modified on Friday 29 December 2006 3:45:43 am by Vitaly Puzrin

Friday 05 January 2007 11:54:11 am

Hi guys

I found the problem in the correctxmltext script, replace

$doc =& $xml->domTree( $text, array( "TrimWhiteSpace" => false ) );

with:

$doc =& $xml->domTree( $text, array( "TrimWhiteSpace" => false, "SetParentNode" => true ) );

Bug report: http://issues.ez.no/9952

Modified on Friday 05 January 2007 12:00:08 pm by Kristof Coomans

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from