eZ Community » Forums » Install & configuration » Exception when installing
expandshrink

Exception when installing

Exception when installing

Thursday 06 August 2015 2:40:41 am - 3 replies

Hi.

 

I am having a problem when installing newest Community Edition using Git following these instructions:

https://github.com/ezsystems/ezpublish-community/blob/master/INSTALL.md

 

After running the install command from Composer, it seems to install all the libraries, then asks about mailer settings, then comes up with the following:

Creating the "ezpublish/config/parameters.yml" file
Some parameters are missing. Please provide them.
secret (ThisTokenIsNotSoSecretChangeIt):
locale_fallback (en):
mailer_transport (smtp):
mailer_host (127.0.0.1):
mailer_user (null):
mailer_password (null):
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache
  [Symfony\Component\DependencyInjection\Exception\InactiveScopeException]
  You cannot create a service ("request"blunk.gif Emoticon of an inactive scope ("request"blunk.gif Emoticon.
Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache handling the post-install-cmd event terminated with an exception
  [RuntimeException]
  An error occurred when executing the "'cache:clear --no-warmup'" command.
install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [--ignore-platform-reqs] [packages1] ... [packagesN]

 

 

 

I have read suggestion of problems with Scopes, but all the problems I have found have solutions for after a bundle has been generating, and add code to this newly generated bundle. However, I have only installed the community edition and for this project have not got as far even as the setup wizard, never mind adding a custom bundle!

 

Surely there shouldn't be a problem with a CLI install?

 

Thanks in advance

 

Barry

Tuesday 18 August 2015 12:29:05 pm

Hi Barry,

maybe my question is a bit stupid, but have you tried to manually clearing cache before running the install command ? (delete all in <root>/ezpublish/cache/)

Friday 21 August 2015 11:10:33 am

Hi,

yesterday i falling in the same trap blunk.gif Emoticon ... in two various basic systems:

  • first: osx with home-brew setup (php 5.4)
  • second: ezsc2015 vagrant setup with ubuntu (php 5.6) 

my suggestion or work-a-round at the moment:

> git clone https://github.com/ezsystems/ezpublish-community.git
> git checkout v2014.11.1
and then you will "be ready to continue"

Greetings from the baltic sea,
Dirk
 

Sunday 23 August 2015 9:42:16 pm

Hi,
it's a know issue with master when using legacy bridge (which ezpublish-community does), you can see discussion and misc attempts to find a fix here:

https://github.com/ezsystems/LegacyBridge/pull/30

 

ezplatform is not affected as long as legacy bridge is not installed. 

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from