This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Install & configuration » ez 4.1, online editor doesn't work
expandshrink

ez 4.1, online editor doesn't work

ez 4.1, online editor doesn't work

Sunday 22 March 2009 2:06:34 pm - 5 replies

After installing ez 4.1 I can't launch online editor.

All I get is standard text editor and following error:

Class 'eZOEXMLInput' does not exists, defined in setting ezxml.ini [InputSettings] HandlerClass 

I can see that file:

extension/ezoe/ezxmltext/handlers/input/ezoeinputparser.php

exists but I've no idea why it says that it's missing and I'm not sure whether this is a reason for why OE doesn't work.

I doublechecked that ezoe extension is enabled and tried setting up various rewrite rules as described in ezoe FAQ but no luck.

Does anyone have any suggestions?

Sunday 22 March 2009 2:22:01 pm

Hi,

You must to go in the Setup Tabs and in the left menu Extension.
Here, you must to re-generate the autoload arrays for active extensions. There is a new button for that.

++

Sunday 22 March 2009 6:08:55 pm

Thank you, this solved the problem.

Is this step always necessary on fresh install?

Sunday 22 March 2009 7:01:16 pm

I don't think for a fresh install.

I must do this for 3 upgrade, but I don't remember for a fresh install.

++

Sunday 22 March 2009 7:48:27 pm

You could expect that a fresh installation would have the autoloads pregenerated, but the fact is that you should consider autoload regeneration a basic step of every system PHP modification, upgrade or extension. It would be wise to check it on installation as well.

Tuesday 01 September 2009 3:28:58 pm

I have the same problem on ez 4.1.3 upgrade from 4.0.3. I have downloaded the version with ezc bundle.
I have run the command: php bin/php/ezpgenerateautoloads.php -e

the output is:

Scanning for PHP-files.

Scan complete. Found 117 PHP files.

Searching for classes (tokenizing).

Found 40 classes, added 40 of them to the autoload array.

But the online editor dosn't works. I think I have a ezc installation problem.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from