This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » eZ 5.0 without APC? Or does managed...
expandshrink

eZ 5.0 without APC? Or does managed hosting lock us into eZ 4.X?

eZ 5.0 without APC? Or does managed hosting lock us into eZ 4.X?

Thursday 16 May 2013 4:58:59 pm - 2 replies

Does anyone know if it is possible to run eZ 5.0 without "APC 3.1.9"?

Yes, the documentation indicates that eZ 5.0 requires "APC 3.1.9 (external pecl extension)". However various sources indicate this is incompatible with suPHP. And my client's (managed and shared) server has suPHP for security reasons.

This suggests upgrading them to eZ 5 means:

- Getting another server or hosting (costly),

- Taking over the technical management of the server themselves (very unlikely),

... or, alternatively, staying with eZ 4.X and forgetting about eZ 5.0 for the foreseeable future (a pity).

Has anyone struck this problem, or found a solution?

Thanks

Thursday 16 May 2013 8:16:59 pm

Yes, it can ran perfectly however it's advised to use apc.

Modified on Thursday 16 May 2013 8:17:18 pm by Pedro Resende

Sunday 19 May 2013 10:51:50 am

It does indeed work, but take care: suphp relies on executing php in cgi mode: slow, and not suited for large-traffic sites, really.

Also, when you are on shared hosting, you might find out that you have other limitations which make the usage of eZ a bit more tricky, such as the inability to raise memory limits and script execution timeout (useful for editorial interface) or to run cronjobs...

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from