eZ Community » Forums » Install & configuration » eZ Publish 2011.11: wizard setup does...
expandshrink

eZ Publish 2011.11: wizard setup does not check the system

eZ Publish 2011.11: wizard setup does not check the system

Saturday 10 December 2011 4:19:58 pm - 2 replies

Hi,

I'm trying to install eZP 2011.11 as usually but the setup wizard does not check my system (I get a blank page with "finetune"blunk.gif Emoticon.
Here is 2 screenshots (on the same machine of course):
1/ with ezp 2011.4: System_check_eZ-Publish_2011.4.png
2/ and now with ezp 2011.11: System_check_eZ-Publish_2011.11.png

Regards

Pascal

Saturday 10 December 2011 10:58:43 pm

Hello Pascal,

 

It sure seems like your PHP/Webserver configuration does not (as currently configured) support the base eZ Publish requirements. You may want to validate and confirm your PHP/Webserver configuration meets eZ Publish setup requirements.

http://doc.ez.no/eZ-Publish/Technical-manual/4.x/Installation/Normal-installation/Requirements-for-doing-a-normal-installation

http://doc.ez.no/eZ-Publish/Technical-manual/4.x/Installation/Troubleshooting

 

Also I notice that in your screenshots the 'skip test' check boxes *(which let you skip these tests)* are missing, I honestly have never seen that occur before and I'm not certain just why that would happen offhand. Though I wonder if the severity of the first failed test may be preventing the checkboxes from being used (i'm not certain offhand).

Here is an example screenshot with the 'skip test' checkbox included,

http://doc.ez.no/eZ-Publish/Technical-manual/4.x/Installation/The-setup-wizard#eztoc86337_2

 

Also I wonder if your using some kind of PHP security feature or default configuration of PHP which is preventing the normal use of $_ENV (normally available for use by eZ). I would prolly disable any such features before using with eZ Publish.

Update: Edit your php.ini and set, variables_order = "GPCS" to, variables_order = "EGPCS" and restart your webserver (to re-read the changed php.ini content), then re-setup eZ Publish.

It seems in the most recent svn of PHP's php.ini,  now by default excludes the expected configuration variable content! 

From: http://www.php.net/manual/en/configuration.file.php

Which links to svn: http://svn.php.net/viewvc/php/php-src/trunk/php.ini-production?view=co

About feature setting: http://www.php.net/manual/en/ini.core.php#ini.variables-order

 

The above described change should solve the first test error during setup. After that you should be able to 'skip' the second optional 'postgres db test' (if you use another db for example).

 

Pascal, I'd focus on fixing the php installation/configuration problems first before trying to install and setup eZ Publish again.

 

I hope this helps ...

 

Cheers,

Heath

 

http://svn.php.net/viewvc/php/php-src/trunk/php.ini-production?view=co

Modified on Saturday 10 December 2011 11:06:56 pm by // Heath

Monday 12 December 2011 1:36:20 pm

Thanks a lot Heat.

The problem was effectively a misconfiguration of variables_order

Now, the setup wizard works fine.

Pascal

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from