eZ Community » Forums » Install & configuration » eZ publish 5 installation on legacy...
expandshrink

eZ publish 5 installation on legacy stack

eZ publish 5 installation on legacy stack

Saturday 11 October 2014 6:57:30 pm - 4 replies

Hi everybody,

It has been a very long time (almost two years..) but now we are finally ready to commit to step further to the new eZ 5. Well, for now, just to take one step at a time, starting with the legacy stack.

But soon encountered some difficulties during installation.

As I used to refer to this (lucky for me) forum, which has always helped me figure things out in the past, here I come to better clarify the yet obscure concepts and ride over those parts I am not able to make it go smoothly the way they should.

I followed the guidance as well documented in "Installing eZ Publish on a Linux-UNIX based system".

Working on a OS CentOS 6.x 64bit, DB (mysql 5.1.73), ez 5.3 2014.07.

Set up folder permission:

# find {ezpublish/{cache,logs,config,sessions},ezpublish_legacy/{design,extension,settings,var},web} -type d | xargs chmod -R 777
# find {ezpublish/{cache,logs,config,sessions},ezpublish_legacy/{design,extension,settings,var},web} -type f | xargs chmod -R 666

In order to succesfully install composer, had to update ioncube.

As when launched the composer installation, at first, got the following error:

 Your ionCube Loader extension (4.0) is incompatible with Phar files.
 
Upgrade to ionCube 4.0.9 or higher or remove this line (path may be different) from your `php.ini` to disable it:
    zend_extension = /usr/lib/php5/20090626+lfs/ioncube_loader_lin_5.3.so

Got the updated ioncube version:

# cd /tmp
# wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz -O ioncube_loaders_lin_x86-64.tar.gz
# tar vxzf ioncube_loaders_lin_x86-64.tar.gz -C /etc

in order to find and replace the older ioncube with the new, run the following:

# php -i | grep extension_dir
extension_dir => /usr/lib64/php/modules => /usr/lib64/php/modules

 

# cp /etc/ioncube/ioncube_loader_lin_5.3.so /usr/lib64/php/modules/

then moved to the root of eZ publish and run the composer installation command

# curl -s https://getcomposer.org/installer | php
Downloading...
 
Composer successfully installed to: /var/www/vhosts/xxx.it/httpdocs/composer.phar
Use it: php composer.phar

At this poin, I start encountering problems; when I run the install or update command I get the following issues:

# php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
 
  Problem 1
    - The requested package php could not be found in any version, there may be a typo in the package name.
  Problem 2
    - The requested package php could not be found in any version, there may be a typo in the package name.
  Problem 3
    - symfony/symfony v2.3.18 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.9 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.8 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.7 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.6 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.5 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.4 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.3 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.20 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.2 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.19 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.18 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.17 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.16 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.15 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.14 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.13 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.12 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.11 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.10 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.1 requires php >=5.3.3 -> no matching package found.
    - symfony/symfony v2.3.0 requires php >=5.3.3 -> no matching package found.
    - Installation request for symfony/symfony 2.3.* -> satisfiable by symfony/symfony[v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.3, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9].
 
Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.
 
Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

 

# php -d memory_limit=-1 composer.phar install --no-dev --prefer-dist
Loading composer repositories with package information
Installing dependencies from lock file
Your requirements could not be resolved to an installable set of packages.
 
  Problem 1
    - The requested package php could not be found in any version, there may be a typo in the package name.
  Problem 2
    - The requested package php could not be found in any version, there may be a typo in the package name.
  Problem 3
    - twig/twig v1.16.0 requires php >=5.2.4 -> no matching package found.
    - twig/twig v1.16.0 requires php >=5.2.4 -> no matching package found.
    - Installation request for twig/twig v1.16.0 -> satisfiable by twig/twig[v1.16.0].
 
Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <<a href="https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion">https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion</a>> for more details.
 
Read <<a href="http://getcomposer.org/doc/articles/troubleshooting.md">http://getcomposer.org/doc/articles/troubleshooting.md</a>> for further common problems.

And when run the following to diagnose composer

# php composer.phar diagnose

got the following:

Checking composer.json: FAIL
require.ezsystems/ezpublish-kernel : unbound version constraints (>=2014.07) should be avoided
require.ezsystems/ezpublish-legacy : unbound version constraints (>=2014.07) should be avoided
require.ezsystems/demobundle : unbound version constraints (>=2014.07) should be avoided
require.ezsystems/comments-bundle : unbound version constraints (>=2014.07) should be avoided
require.zetacomponents/archive : unbound version constraints (dev-master#d0caff8) should be avoided
require.zetacomponents/authentication : unbound version constraints (dev-master#c422670) should be avoided
require.zetacomponents/authentication-database-tiein : unbound version constraints (dev-master#56d1e0a) should be avoided
require.zetacomponents/base : unbound version constraints (dev-master#642f63a as 1.8.0) should be avoided
require.zetacomponents/cache : unbound version constraints (dev-master#34fa794) should be avoided
require.zetacomponents/configuration : unbound version constraints (dev-master#10ae09f) should be avoided
require.zetacomponents/console-tools : unbound version constraints (dev-master#90156ab) should be avoided
require.zetacomponents/database : unbound version constraints (dev-master#0e8ddef) should be avoided
require.zetacomponents/debug : unbound version constraints (dev-master#0d8cc8f) should be avoided
require.zetacomponents/event-log : unbound version constraints (dev-master#eee54a1) should be avoided
require.zetacomponents/feed : unbound version constraints (dev-master#e0190e9) should be avoided
require.zetacomponents/image-conversion : unbound version constraints (dev-master#36f34c8) should be avoided
require.zetacomponents/mvc-tools : unbound version constraints (dev-master#6f2c1eb) should be avoided
require.zetacomponents/mvc-authentication-tiein : unbound version constraints (dev-master#9bae3a7) should be avoided
require.zetacomponents/persistent-object : unbound version constraints (dev-master#a4c8b95) should be avoided
require.zetacomponents/php-generator : unbound version constraints (dev-master#b51935e) should be avoided
require.zetacomponents/signal-slot : unbound version constraints (dev-master#74deb41) should be avoided
require.zetacomponents/system-information : unbound version constraints (dev-master#6743362) should be avoided
Checking platform settings: FAIL
 
Your PHP (5.3.3) is quite old, upgrading to PHP 5.3.4 or higher is recommended.
Composer works with 5.3.2+ for most people, but there might be edge case issues.
Checking git settings: OK
Checking http connectivity: OK
Checking disk free space: OK
Checking composer version: OK

Is it due to PHP version indeed? Am I required to update php despite the fact that it meets the minimum requirement? Or what else could the problem be here?

This is something to be fixed before the installation may eventually begin, right?

Our purpose is, for now, to make the legacy stack run (to build a website the old way) but even if I install composer inside ezpublish_legacy folder I got the exact same output.

Then I would like to better understand this thing. We aim to have the installation start from http://www.domain.it/ezsetup. But at this point I can make the installation start from here http://www.domain.it/ezpublish_legacy/index.php/ezsetup.

It says that for v. 5.3 there's no need to link assets but what should I do to make it point that way?

Really appreciated any help you guys can give me!

Thanks, indeed blunk.gif Emoticon

Modified on Saturday 11 October 2014 7:19:19 pm by Lo' F.

Saturday 11 October 2014 9:15:00 pm

Can you try running composer while disabling ioncube? Perhaps renaming the .so file?

Sunday 12 October 2014 12:17:51 pm

Hi Betsy and thanks for your replay.

By trying to rename the .so file I get the following when I run the composer command

# php composer.phar diagnose
Failed loading /usr/lib64/php/modules/ioncube_loader_lin_5.3.so:  /usr/lib64/php/modules/ioncube_loader_lin_5.3.so: cannot open shared object file: No such file or directory
Checking composer.json: FAIL
require.ezsystems/ezpublish-kernel : unbound version constraints (>=2014.07) should be avoided
...
Checking platform settings: FAIL
 
Your PHP (5.3.3) is quite old, upgrading to PHP 5.3.4 or higher is recommended.
Composer works with 5.3.2+ for most people, but there might be edge case issues.
Checking git settings: OK
Checking http connectivity: OK
Checking disk free space: OK
Checking composer version: OK

and the thing is inside the php.ini there is nothing such

[Zend]
zend_extension=/usr/lib64/php/modules/ioncube_loader_lin_5.3.so

to be commented, and I don't know where else the loader can be called to actually disable it.

...

Now, one thing came in my head that before updating the ioncube version the error said:

 Your ionCube Loader extension (4.0) is incompatible with Phar files. 
Upgrade to ionCube 4.0.9 or higher

and after the update I got the latest version 4.6.1

# php -v
PHP 5.3.3 (cli) (built: Sep 30 2014 05:55:00) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.6.1, Copyright (c) 2002-2014, by ionCube Ltd.

might that be a ....too high version?!

Modified on Sunday 12 October 2014 12:20:37 pm by Lo' F.

Sunday 12 October 2014 12:32:58 pm

..one more try.

By launching the command setting the default_socket_timeout to -1, got more...lines, in case those could be of help to..help me out

# php -d default_socket_timeout=-1 composer.phar diagnose 
Checking composer.json: FAIL
require.ezsystems/ezpublish-kernel : unbound version constraints (>=2014.07) should be avoided
...
require.zetacomponents/system-information : unbound version constraints (dev-master#6743362) should be avoided
Checking platform settings: FAIL
 
Your PHP (5.3.3) is quite old, upgrading to PHP 5.3.4 or higher is recommended.
Composer works with 5.3.2+ for most people, but there might be edge case issues.
Checking git settings: OK
Checking http connectivity: FAIL
[Composer\Downloader\TransportException] The "https://packagist.org/packages.json" file could not be downloaded: SSL: connection timeout
Failed to enable crypto
failed to open stream: operation failed
Checking disk free space: OK
Checking composer version: 
                                                                               
  [Composer\Downloader\TransportException]                                     
  The "https://getcomposer.org/version" file could not be downloaded: SSL: connection timeout                                                             
  Failed to enable crypto                                                      
  failed to open stream: operation failed                                      
                                                                             
diagnose

...

Monday 13 October 2014 12:41:29 am

Do you need to have ioncube on the server?

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from