This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Install & configuration » ez publish "migration"

ez publish "migration"

ez publish "migration"

Sunday 27 March 2011 7:43:55 pm - 6 replies

Hello everyone,

I need some of your help to "migrate" (somehow) on ez site to another machine. It looks simple I know.

The problem is that the only think I have is the directory of the site without any other information. And I don't think I will get any other information because the man in charge of the website has left the compagny, so I'm in a bit of trouble.

Is there any "standard" way to "migrate" an ez site or something like that?

Thanks for you help

Monday 28 March 2011 10:19:09 am

Hi Eric,

Generally you'd have to move a folder with the site and database on the new machine and configure (location: settings/override and settings/siteaccess) (important file site.ini.append.php - section DatabaseSettings and SiteSettings).

If you had still a problem with migration give more details.

I will try to help

Monday 28 March 2011 5:44:42 pm


Thanks for your help.

I already import the database and move the directory.

I have the home page of the site, but when I try to login, all I have is


Not Found


The requested URL /user/login was not found on this server.


and the error.log says:

[ Mar 28 2011 15:37:24 ] [] error/view.php:
Error ocurred using URI: /

What should I do?

Tuesday 29 March 2011 8:30:35 am

Probably don't have set RewriteRule

May try to add the /index.php/user/login

Wednesday 30 March 2011 11:24:32 am


I tried calling the site by appending /index.php/user/login to the url, and I got that:

Erreur / kernel 20

Module non trouvé


Le module demandé index.php n'a pas été trouvé.


Les raisons possibles pour cela sont:

  • Le nom du module a été mal orthographié. Essayez de changer l'URL.
  • Le module n'existe pas sur ce site.
  • This site uses siteaccess matching in the URL and you did not supply one, try inserting a siteaccess name before the module in the URL .

Sorry for the french log.

What is the RewriteRule? How can I set it?

Thanks a lot for your help.

Thursday 31 March 2011 11:26:53 am


Try add the name of your siteaccess (<name_your_site>/user/login). You'll find it in settings/siteaccess/<name_your_site>

RewriteRule are configuration directives Apache module "mod_rewrite". This module provides a rule-based rewriting engine to rewrite requested URLs on the fly.

Tell me if you have the root of the project .htaccess file?

If you don't have, you can try copy file .htaccess_root to .htaccess

You can also check RewriteRule the setting in the configuration of Apache Server (virtual host).

What operating system you use?

What version eZ Publish you have?

Thursday 31 March 2011 11:55:07 am

Ok, I found my problem: The rewrite modules was not loaded in the apache conf, so it messed up pretty much everything.

Thanks a lot for your help!


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from