This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Ezfind Solr indexing is not working...
expandshrink

Ezfind Solr indexing is not working from shell cmd

Ezfind Solr indexing is not working from shell cmd

Wednesday 06 June 2012 6:52:00 am - 2 replies

Hi All

 I am facing problem  in ezfind, iam using the ezfind  2.2 when i try to run from  shell cmd ,i got the

Following error

 

Jun 6, 2012 9:56:31 AM org.apache.solr.core.QuerySenderListener newSearcher

INFO: QuerySenderListener sending requests to Searcher@c8769b main

Jun 6, 2012 9:56:31 AM org.apache.solr.core.CoreContainer register

INFO: registering core:

Jun 6, 2012 9:56:31 AM org.apache.solr.servlet.SolrDispatchFilter init

INFO: user.dir=/web/merckmedicusdev/extension/ezfind/java

Jun 6, 2012 9:56:31 AM org.apache.solr.servlet.SolrDispatchFilter init

INFO: SolrDispatchFilter.init() done

Jun 6, 2012 9:56:31 AM org.apache.solr.core.SolrCore execute

INFO: [] webapp=null path=null params={start=0&event=firstSearcher&q=solr+rocks&rows=10} hits=0 status=0 QTime=90

Jun 6, 2012 9:56:31 AM org.apache.solr.servlet.SolrServlet init

INFO: SolrServlet.init()

Jun 6, 2012 9:56:31 AM org.apache.solr.core.SolrResourceLoader locateSolrHome

INFO: JNDI not configured for solr (NoInitialContextEx)

Jun 6, 2012 9:56:31 AM org.apache.solr.core.SolrResourceLoader locateSolrHome

INFO: solr home defaulted to 'solr/' (could not find system property or JNDI)

Jun 6, 2012 9:56:31 AM org.apache.solr.servlet.SolrServlet init

INFO: SolrServlet.init() done

Jun 6, 2012 9:56:31 AM org.apache.solr.core.SolrResourceLoader locateSolrHome

INFO: JNDI not configured for solr (NoInitialContextEx)

Jun 6, 2012 9:56:31 AM org.apache.solr.core.SolrResourceLoader locateSolrHome

INFO: solr home defaulted to 'solr/' (could not find system property or JNDI)

Jun 6, 2012 9:56:31 AM org.apache.solr.servlet.SolrUpdateServlet init

INFO: SolrUpdateServlet.init() done

Jun 6, 2012 9:56:31 AM org.apache.solr.core.SolrCore execute

INFO: [] webapp=null path=null params=event=firstSearcher&q=static+firstSearcher+warming+query+from+solrconfig.xml} hits=151 status=0 QTime=222

Jun 6, 2012 9:56:31 AM org.apache.solr.core.QuerySenderListener newSearcher

INFO: QuerySenderListener done.

Jun 6, 2012 9:56:31 AM org.apache.solr.handler.component.SpellCheckComponent$SpellCheckerListener newSearcher

INFO: Loading spell index for spellchecker: default

Jun 6, 2012 9:56:31 AM org.apache.solr.core.SolrCore registerSearcher

INFO: [] Registered new searcher Searcher@c8769b main2012-06-06 09:56:31.543::

INFO:  Started SocketConnector @ 0.0.0.0:9090

 

befor this error i am getting the error  Socket connection fail error ,for this i change the port 8983 to 9090 in  jetty.xml  on the path "java/etc" so the connection error is gone but now i am getting the above error please help me out , i am in urgent need. 

Modified on Wednesday 06 June 2012 7:22:48 am by Jignesh Sailor

Wednesday 06 June 2012 9:17:04 am

I see no error in your output trace...

Wednesday 06 June 2012 9:52:28 am

Solr looks to be running..
So, the above looks like solr is happily listening on port 9090
Confirm:

You can confirm this by pointing a browser at:
http://ip.address.of.server:9090 - and unless a firewall is blocking it, you should see the solr web interface.

ezFind Port needs to match:

If you change the port that solr is listening on, then you also have to tell ezFind the same thing or it will be knocking at the wrong door..

Look for this line (or similiar) in extension/ezfind/settings/solr.ini:
solr.ini:SearchServerURI=http://localhost:8983/solr

and change the port to match what you have solr listening on..

Regards,

David

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from