This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Install & configuration » Ezpublish 4.6 and Debian 7 ?
expandshrink

Ezpublish 4.6 and Debian 7 ?

Ezpublish 4.6 and Debian 7 ?

Tuesday 13 January 2015 6:27:36 pm - 3 replies

Hello, 

 

It seems that ezpublish 4.6 is only supported on debian 6 and not on debian 7. (https://doc.ez.no/eZ-Publish/Technical-manual/4.6/Installation/Requirements-4.6 ), however debian 6 is going to be deprecated.

Do you know if it's possible to install ezpublish 4.x on debian 7? 

What kind of problems may we encounter ?

Thanks for your help.

Modified on Tuesday 13 January 2015 6:35:06 pm by Le Franck

Tuesday 13 January 2015 7:53:37 pm

Hello Le Franck,

The key here is the older versions of ezpublish depends on specific php version support.

Which version of php would you use with Debian 7?

Debian 7 seems to provide php with version 5.4.36-0+deb7u3

Re: https://packages.debian.org/wheezy/php5

You will probably need to upgrade ezpublish (to the latest community release) when you upgrade to Debian 7.

After that you should have no problems.

I hope this helps!

Cheers,
Heath 

Modified on Tuesday 13 January 2015 7:53:52 pm by // Heath

Tuesday 13 January 2015 8:51:11 pm

Thanks for your answer.

 

The version of php in debian 7 is :5.4.36-0+deb7u3

in debian 6 :5.3.3-7+squeeze19

Ezpublish 4.6 requires php 5.3.x 

Does that mean that ezpublish 4.6 won't work in debian 7 because of php' version ?

Is there someone who has checked if it works or not in debian 7 ?

 

Thanks in advance for your help

 

Wednesday 14 January 2015 4:47:14 am

Let me turn it up for you and make it absolutely clear.

You absolutely must upgrade to the latest community release.

Without question, hesitation or doubt. blunk.gif Emoticon

Hint: It has nothing to do with what version of debian you use. It is specifically a php version support issue and eZ Publish 4.6 just can not handle php 5.4. If you do not upgrade ezpublish ... the admin will not work at all and user siteaccess will also break in key areas. The php support for 5.4 is simply missing in 'core' of eZ Publish 4.6 and most of eZ Publish breaks when you ignore the upgrade and the site just won't work.

My 10 years of eZ Publish experience backs this warning. You should listen to Heath he knew what he was talking about when he replied.

//kracker

THEME: Lil Dicky - White Dude (Official Video)

https://www.youtube.com/watch?v=3rnFlQAvk8U

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from