eZ Community » Forums » Install & configuration » eZpublish5 Installation : Error 404 :...
expandshrink

eZpublish5 Installation : Error 404 : http://packages.ez.no/ezpublish/5.0/5.0.0alpha1/

eZpublish5 Installation : Error 404 : http://packages.ez.no/ezpublish/5.0/5.0.0alpha1/

Wednesday 11 July 2012 5:18:09 pm - 18 replies

Hi,

I have this Error when trying to install eZpublish5 : 

Error

Retrieving remote site packages list failed. You may upload packages manually.

Remote repository URL: http://packages.ez.no/ezpublish/5.0/5.0.0alpha1/

 

Thanks!

Wednesday 11 July 2012 5:40:37 pm

Hi Sadok,

you should first install eZ Publish 4.7 and apply last modification as write on doc file : 

https://github.com/ezsystems/ezpublish5/blob/master/INSTALL.md

Cheers,

Wednesday 11 July 2012 5:46:32 pm

eZ Publish Community Project 2012.5 works fine too as a base.

Modified on Wednesday 11 July 2012 5:47:08 pm by Nicolas Pastorino

Wednesday 11 July 2012 6:06:37 pm

Thanks it's work !

Wednesday 18 July 2012 11:16:43 am

Hi.

I have followed the instructions ,but still get the following message when i try to run the installations of ezpublish5 :

etrieving remote site packages list failed. You may upload packages manually.

Remote repository URL: http://packages.ez.no/ezpublish/5.0/5.0.0alpha1/

I have started with a clean db , installed the community version 5, merged the files from the integration branch and installed symfony and run app/composer with its instructions.

any idea on how to resolve this?

I see that there is no ezpublish5 repo at packages.ez.no when i browse, but i am not sure how to resolve this.

Wednesday 18 July 2012 11:32:29 am

Hi

This is probably because you didn't start for community project 2012.5 or higher, but most likely directly from github sources.

You can fix it by modifying settings/packages.ini :

[RepositorySettings]
RemotePackagesIndexURL=http://packages.ez.no/ezpublish/4.7/4.7.0

Modified on Wednesday 18 July 2012 11:32:59 am by Jérôme Vieilledent

Wednesday 18 July 2012 11:39:31 am

Just added a troubleshooting section in INSTALL.md to address this issue.

Wednesday 18 July 2012 11:41:59 am

That fixed it. I though that would be the fix as it was the latest release of the packages.

See reply from Jerome!

I did download the community version 20012.5 as well as 20012.6 which both have this bug as far as i can see.

Update:This is not a bug as clearly indicated by Jerome!

Thanks for helpinghappy.gif Emoticon

Modified on Wednesday 18 July 2012 11:48:35 am by Lars Eirik Roenning

Wednesday 18 July 2012 11:45:45 am

Quote from Lars Eirik Roenning :

That fixed it. I though that would be the fix as it was the latest release of the packages.

I did download the community version 20012.5 as well as 20012.6 which both have this bug as far as i can see.

Thanks for helpinghappy.gif Emoticon

No they don't have any bug, this is because you installed 2012.5/6 after upgrade to ezpublish5-integration (which replaces this INI file).

Actually, settings/package.ini is modified à build-time (check the difference between the file in the TAR archive and on GitHub).

Wednesday 18 July 2012 5:00:20 pm

I would suggest a few other modifications to the INSTALL.md document based on what I encountered on install:

As soon as I ran: php composer.phar install
I got this warning:

Your lock file is out of sync with your composer.json, run "composer.phar update" to update dependencies

I'm not sure if that means anything or what... but is it a good idea maybe to run the update before the install?  After running the update and the install again it just said everything was up to date.

I also got this as an error at the end of the install run:

   [UnexpectedValueException]                                                   
   RecursiveDirectoryIterator::__construct(app/ezpublish_legacy): failed to open dir: No such file or directory

Maybe people should copy their installation to the ezpublish_legacy before running the install - at the very least an empty directory should be created.

I kept getting database errors until I changed ezpublish.api.storage_engine.legacy.dsn: from mysql to mysqli in parameters.yml  - I don't know if that matters or what but maybe a note there would be useful.

My siteaccesses weren't showing up and an admin1 design was being used as the default - which I fixed by putting my site accesses in the parameters.yml replacing the "dummy configuration for tests" values.  This should be mentioned as a step in the INSTALL.md document because it isn't clear that those values should be modified.

I think maybe ezpublish5 should maybe get a dedicated forum.

Wednesday 18 July 2012 5:46:41 pm

Hi Steven

First, +1 for a dedicated forum.

Then, feel free to propose a pull request for this kind of modification happy.gif Emoticon

Quote from Steven E Bailey :

As soon as I ran: php composer.phar install
I got this warning:

Your lock file is out of sync with your composer.json, run "composer.phar update" to update dependencies

Mmm it seems that you installed it once first ?

Quote from Steven E Bailey :

Maybe people should copy their installation to the ezpublish_legacy before running the install - at the very least an empty directory should be created.

This issue is very new (from today) and from this commit which enforces to have eZ Publish legacy in app/ezpublish_legacy. For now you can workaround it by either creating an empty directory or symlinking your eZ Publish legacy installation here.

Quote from Steven E Bailey :

I kept getting database errors until I changed ezpublish.api.storage_engine.legacy.dsn: from mysql to mysqli in parameters.yml  - I don't know if that matters or what but maybe a note there would be useful.

This is probably because you only have the Mysqli PHP extension installed (and yes, we should use it by default).

Quote from Steven E Bailey :

My siteaccesses weren't showing up and an admin1 design was being used as the default - which I fixed by putting my site accesses in the parameters.yml replacing the "dummy configuration for tests" values.  This should be mentioned as a step in the INSTALL.md document because it isn't clear that those values should be modified.

I don't understand this. Can you develop a bit more please ?

Wednesday 18 July 2012 7:00:00 pm

Quote from Jérôme Vieilledent :

Mmm it seems that you installed it once first ?

This was a fresh install from git...  Actually since I was debugging I did this 3-4 times (with new clones) and got he same error message every time.  Unless this is modifying something outside the ezpublish5 directory it shouldn't have been affected by any previous install.

This issue is very new (from today) and from this commit which enforces to have eZ Publish legacy in app/ezpublish_legacy. For now you can workaround it by either creating an empty directory or symlinking your eZ Publish legacy installation here.

I guess I just got lucky... I'm thinking step 3 and 4 can just reverse order.

This is probably because you only have the Mysqli PHP extension installed (and yes, we should use it by default).

I've got both installed - and it worked when I changed the ezpublish setting to mysql too - but in the install file there is "only MySQL and PostgreSQL are supported at the moment" which made me think that mysqli wasn't supported.  I just gave it a shot to see if it would work.  I was just a bit surprised that it had to match what was in the ini file.

My siteaccesses weren't showing up and an admin1 design was being used as the default - which I fixed by putting my site accesses in the parameters.yml replacing the "dummy configuration for tests" values.  This should be mentioned as a step in the INSTALL.md document because it isn't clear that those values should be modified.

I don't understand this. Can you develop a bit more please ?

When ezpublish.siteaccess.default: in parameters.yml was not set to a valid siteaccess (it's set to ezdemo_site by default), I ended up getting /user/login using the design/admin templates. 

Actually, I just tried it out on an ez4 installation and it's the same thing that happens if you have your database information in the override/site.ini and you put a bogus DefaultAccess in SiteSettings.

Meaning it connects because it has a valid database connection but it has no design etc.

I guess really I just would have liked to have explicitly known that I had to edit those fields too.

Thursday 19 July 2012 9:20:08 am

Quote from Steven E Bailey :

I think maybe ezpublish5 should maybe get a dedicated forum.

Darn right. 

I just modified the initial "New PHP API" forum to better reflect that it is now part of the bigger picture : eZ Publish 5.

http://share.ez.no/forums/ez-publish-5-forum-formerly-known-as-new-php-api

Cheers !

Thursday 19 July 2012 9:21:16 am

@Steve : btw, thanks a lot for the feedback. Do you have other of bits of it related to the install process, so we can update the INSTALL doc ?

Cheers !

Thursday 19 July 2012 9:43:17 am

Quote from Steven E Bailey :

When ezpublish.siteaccess.default: in parameters.yml was not set to a valid siteaccess (it's set to ezdemo_site by default), I ended up getting /user/login using the design/admin templates. 

Documentation fixed in this commit thanks !

I also moved step 4 to 2 so you don't have the ezpublish_legacy folder error. 

Modified on Thursday 19 July 2012 9:44:22 am by Jérôme Vieilledent

Thursday 19 July 2012 10:22:59 am

@Jérôme - Great, that should make it easier for others in the future.

 

@Nicolas - Great, I guess the dedicated forum WAS there I just didn't see it - the name change makes it easier.

As far as any other things on the install - I wanted to do a lowest common denominator test so first i installed a plain_site version of 2012.6 and got that working, then I copied that to a different directory and copied files from the https://github.com/ezsystems/ezpublish/zipball/ezpublish5-integration except for "benchmarks|mydesign|tests|design|templates" that were different (there were a lot since I guess the tarball is based on 4.4).  But, I know this is wrong because I still have lib/ezc and that's now under symfony too.  But it works like this.

I had tried to just use the tarball the first time I did anything but then (d'oh) there were no extensions.  I guess the easiest would be to use the tarball and just replace the extensions, var, settings directories and make sure the plain_site (or any other) design directory is restored.  I guess this process will get easier as time goes on and there's a list of only the stuff that has to be replaced - I assume it's a lot shorter than, well, everything.

The next step, of course, is to try this with an existing complicated site and see what breaks.

The only other weirdness is that at the end of the ezpublish5 install I moved the root directory and that broke the symbolic links in /web (why aren't those relative?) but that was easy enough to fix by removing the old links and re-running:

php app/console assets:install --symlink web

php app/console ezpublish:legacy:assets_install

Also, at some point in the process - I don't remember when, the cache/dev directory was created on the fly as the user I was - which prevented the creation of http_cache - I just had to do a chown -R www-data:www-data at that point on the cache directory.

Thursday 19 July 2012 11:14:04 am

Quote from Steven E Bailey :

But, I know this is wrong because I still have lib/ezc and that's now under symfony too.  But it works like this.

It doesn't matter as they won't be used. lib/ezc will just eat disk space happy.gif Emoticon

Monday 12 November 2012 11:32:00 am

About  the probleme of "Retrieving remote site packages list failed. You may upload packages manuall" you must:

  1. downlod http://packages.ez.no/ezpublish/5.0/5.0.0alpha1/index.xml file and placed it in var/cache/packages.
  2. download others packages from http://packages.ez.no/ezpublish/5.0/5.0.0alpha1/
  3. if you don't have CURL installed this error "copy(http://packages.ez.no/ezpublish/5.0/5.0.0-alpha1/index.xml) [<a href='function.copy'>function.copy</a>]: failed to open stream:"appears, to fix it, you must edit "ezpublish_legacy\kernel\setup\steps\ezstep_site_types.php" file by deleting this condition "if ( !copy( $url, $fileName ) )"

finally continue your installation by uploading others packages downloaded in step 2

Modified on Monday 12 November 2012 11:33:57 am by Mohamed Ben henda

Monday 12 November 2012 12:15:50 pm

Or you can follow what's said in the INSTALL.md file (and probably on the online doc): https://github.com/ezsystems/ezpublish5/blob/master/INSTALL.md#troubleshooting-during-setup-wizard.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from