This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit

eZ Community » Forums » Install & configuration » ezteamroom



Tuesday 13 December 2011 12:46:16 am - 7 replies


i have installed ezteamroom & it is giving error when i see any object with ezteamroom siteaccess:

Object is unavailable

The object you requested is not currently available.

Possible reasons for this are:

  • The id or name of the object was misspelled, try changing it.
  • The object is no longer available on the site.

Error: error/view.php


I am not able to find out what the problem is with URL. Probably some configuration..

The same i get when click My Teamrooms or Sitemap.
My Profile link is fine.

Please help.

Modified on Tuesday 13 December 2011 1:28:42 am by Vali Faria

Tuesday 13 December 2011 2:19:52 am

Hello Vashra,


It seems that you still have some installation configuration remaining to be completed with your ezteamroom solution.


A helpful first step would be for you to enable template and module debug output so you can see additional execution details.


I seem to remember the error your getting giving debug messages which are related and very helpful.


More specifically it seems that the content objects which the system is trying to access do not exist (or are otherwise unavailable).


The ezteamroom extension comes with some fairly involved installation and configuration requirements, some of which I think you skipped over or overlooked...

I would suggest re-reading the INSTALL documentation in greater detail.


Sorry I'm not that familiar with this specific solution off hand to give much more specific suggestions. Best wishes ..




Tuesday 13 December 2011 7:01:19 pm

Hello Heath,

i always had debug activated, and that is why i could see that error:

Error: error/view.php Dec 13 2011 19:45:25
Error ocurred using URI

Still i am not able to solve it. I have read that install.txt file many times & tried to make changes but it didnt help, so then i came here to ask for help. I checked it one more time today, as u suggested.

In administration i am able to preview the teamrooms objects with ezteamroom siteaccess! But in user side i still get 'Object is unavailable' for My teamrooms and Sitemap links!

Error.log shows:  Error ocurred using URI: /site/index.php/ezteamroom/content/view/teamrooms/83

Anyway.. thanks for the help.

Tuesday 13 December 2011 7:23:54 pm

Hello Vashra,


As I stated previously your trying to load an object which may not exist in the system (or you do not have permissions to access it).

RE: '/site/index.php/ezteamroom/content/view/teamrooms/83' aka '/site/index.php/ezteamroom/content/view/teamrooms/(object_id)'

This url will always fail to load correctly as the object_id your trying to view does not exist in the system (or you do not have permissions to access it).

I suggest again re-viewing the installation and configuration for ezteamroom as your installation configuration is not accurate. Otherwise you would be able to view this page (as it would use an object_id which does exist in the system).

Alternatively you could try replacing this object with another copy of the same class which does exist, though I do not know offhand how to specify a different object_id  (I suggest reviewing templates related to see where this ID is fetched from (ini setting vs db content))


You should check that your user role policy permissions allow the user to access this object. This also may cause this issue.


I hope this helps ...




Modified on Tuesday 13 December 2011 7:24:57 pm by // Heath

Wednesday 14 December 2011 8:23:13 am

Morning Heath!

I am so sorry to waste our both time! It was just the translation!!! Cant believe this took me 3 days to find out! The object only existed in English (American) and no translation to English (United Kingdom).

I got this settings:


So the only thing i did is creating the translation of same object in English (United Kingdom)

Thank u so muuuch!

Have a great day!

Wednesday 14 December 2011 9:31:01 am

Hello Vashra,

Thank you very much for your update. I understand these things take time to sort out. I've been there ...

But boy was I way off ... missing translation, I didn't even think of that as a possible factor!

I don't think you wasted anyone's time. I'm happy to have done my best to try to guide you towards possible solutions as best as I can. I am sorry you had this trouble but then some things are unavoidable in a way.

Thank you also for sharing your solution to the problem. I can't express enough how much this helps others trying to solve the very same problems you encountered recently both today and in the distant future.

Enjoy your day in the Sunlight! You earned it Vashra!


PS. Please feel free to ask questions here again in the future or join us in #ezpublish irc chat we are here to help you reach your goals.




Friday 08 November 2013 10:22:42 am

Although quite old, this one just saved me a lot of time blunk.gif Emoticon

Friday 08 November 2013 12:03:24 pm

Quote from Matthias Krieft :

Although quite old, this one just saved me a lot of time blunk.gif Emoticon

Great to hear and thanks for posting Matthias!


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from