This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » First install: Access denied, no...
expandshrink

First install: Access denied, no database connection, failed to open/write file

First install: Access denied, no database connection, failed to open/write file

Saturday 12 July 2003 1:58:05 am - 4 replies

Hi.

I downloaded Ez-p 3.1 install package for WinXP and ran install as admin user, install dir "E:/Program files".

First time starting the site I got an error about "Security alert, trying to run php as cgi-bin" or something like that.

After restarting computer, cgi-message is gone, but I get a bunch of error messages included below instead.

MySQL does not seem to be running, but there are two Apache-processes in task manager.

Previously I have installed php for IIS on my system, but IIS service is stopped. I also have run MySQL occasionally, but I don't think it's installed/registered in the system.

Error messages at index.php:

"Access denied, You don't have permission to access this area."

Warning: Unknown(): open
(/tmp\sess_1b798c17650f45e734ed6b65c31c148e, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

Under index.php/admin I get this error:

kernel (50)
No database connection could be made, the system might not behave properly.

Anyone know how to get this working as it was supposed? What may be the reason that MySQL does start?

Thanks
/Johs

Saturday 12 July 2003 8:32:12 pm

> "Access denied, You don't have permission to access this area."
>

this is a missconfiguration in your php.ini file which should be in your windows installation folder. the folder in which php will store its temp. data is configured in the [session] part of php.ini

in your mysql folder there will be an application: /bin/winmysqladmin.exe
start it and you will have a small traffic light in your system tray showing its status.

within the mysql folder under /data/ there is a file: mysql.err which should give some hints why mysql does not want to work.

good luck happy.gif Emoticon

Monday 14 July 2003 11:58:14 pm

josh,
If you did downloaded eZ publish 3.1 "Installer" package for the Windows platform, you may not be able to use Microsoft Windows' built-in Web server (IIS). In fact, you will have to disable IIS in the services control panel or provide a different port number (other than 80) to IIS.
The installer provided here includes: The Apache Web server software, PHP, mySQL server, ImageMagick and eZ publish 3.1, all in one package.

If you need/have/ or want to use IIS then you will to download this packages from their developers and install them one by one in order.

1. PHP (required) http://www.php.net/
2. MySQL (required) http://www.mysql.com/
3. ImageMagick (optional) http://www.imagemagick.org/
You can use PHP's built-in GD library for image conversion.
See php.ini file to enable the GD library.
4. eZ publish 3.1 (uhhhh... required) http://www.ez.no/

For more information on this, please check this address: http://www.ez.no/manual/

josh, I hope this helps you with your eZ publish installation. Let us know if you have more problems.

Regards,

geo

Modified on Tuesday 15 July 2003 12:02:28 am by geovanni rosetto

Tuesday 15 July 2003 11:31:33 pm

This really is a royal pain. Check out the thread here [http://mysql-mirror.free.fr/doc/N/T/NT_start.html]

I read it tried it and still can't get it to run mysql.
Previous version 'ezpublish-3.0_2-winnt.exe' seemed fine.

Any further ideas?

alan

Thursday 17 July 2003 2:02:03 am

Thanks for the help.

The site works after starting MySQL.

In WinMysqlAdmin the Start check message indicates that the path key was empty, but has now been fixed.
Found: E:/Program Files/eZ systems/mysql/bin/mysqld-nt.exe

As a matter of fact after installing MySQL at previous occasions I have never been able to start it without manually adding the --basedir parameter. The WinMysqlAdmin app seems to have fixed this automatically, which is nice.

A problem is that the site runs very slow. It takes about 6-7 seconds to serve a page. Ok my computer is from -99 but should it really take that long?

I've checked mysql.err and found some mystic information also.

MySql: ready for connections
Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
If you do not want to use transactional InnoDB tables, add a line
skip-innodb
to the [mysqld] section of init parameters in your my.cnf
or my.ini. If you want to use InnoDB tables, add to the [mysqld]
section, for example,
innodb_data_file_path = ibdata1:10M:autoextend
But to get good performance you should adjust for your hardware
the InnoDB startup options listed in section 2 at
http://www.innodb.com/ibman.html

/Josh

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from