eZ Community » Forums » Install & configuration » Forum & approve workflow problem
expandshrink

Forum & approve workflow problem

Forum & approve workflow problem

Friday 12 January 2007 8:17:19 pm - 8 replies

We have a forum with 35000 posts and about 5000 forum users (from 3 different user groups). Forum was migrated from Phorum script to eZ publish few months ago. Every post has to be approved by editor before publishing using standard approve workflow shipped with eZ publish installation.

Recently we have encountered odd problems with approval procedure. Some posts were returned to workflow after being approved, with more and more posts failing and going back to the workflow (workflow status was always re-set to EZ_WORKFLOW_STATUS_DEFFERED_TO_CRON). The odd thing about the problem is that there is no consistency in it's occurrence (user sometimes posts the message and it gets approved without problems, and sometimes the problem occurs )

At the moment runnig runcronjobs.php from the shell produces this error:

[cgi] ~/public_html/ez-386> /usr/local/bin/php-cli -C -d memory_limit=300M runcronjobs.php
PHP Fatal error:  Call to a member function on a non-object in /home/users/cm/public_html/ez-386/kernel/classes/workflowtypes/event/ezapprove/ezapprovetype.php on line 611
Running cronjobs/workflow.php
Checking for workflow processes

Fatal error: eZ publish did not finish its request
The execution of eZ publish was abruptly ended, the debug output is present below.

The site is currenty running on 3.8.6, but same happened with 3.7.0.

<b>Any help or advice really appreciated!</b>

Modified on Friday 12 January 2007 8:18:01 pm by Vjeran Vlahovic

Monday 15 January 2007 9:06:12 am

There might be some database inconsistency. Did you compare data for approved and returned posts in database? Database base is good start point also do some debugging around line 611 kernel/classes/workflowtypes/event/ezapprove/ezapprovetype.php.

If still no luck then I suggests contact support[at]ez.no

Modified on Monday 15 January 2007 9:07:13 am by Ɓukasz Serwatka

Monday 22 January 2007 11:18:53 am

Hi Vjeran

Have you been able to solve the problem?

Cheers

Saturday 27 January 2007 3:10:23 am

Hi Kristof & Lukasz,
thanks for your replies. I (kinda) solved this problem, with the help of Konrad, polish eZ superhero happy.gif Emoticon

Workflow.php execution was failing because the ezcollab_item.data_int2 pointed to non-existent object version (it contained value 1, but for that object [forum topic] only version 2 and 3 existed). ezcontentobject.current_version of that object also contained 1. So I changed data_int2 to 3, run the workflow.php again and it worked happy.gif Emoticon

I still don't know what caused this inconsistency sad.gif Emoticon

Wednesday 21 November 2007 11:04:00 am

Hi, I've got the same problem, but unfortunately I don't understand the solution of Vjeran:

- where is "ezcollab_item.data_int2"?
- how can I change it?

Thanks a lot in advance!
Dario

Wednesday 21 November 2007 6:55:34 pm

Hi Dario,
data_int2 is an attribute of ezcollab_item table in eZ publish database. There are several tools you can use to connect to a database and alter data, for instance phpMyAdmin, which is probably allready installed on your web server.

Good luck!
Vjeran

Thursday 22 November 2007 12:31:47 am

Hi Vjeran,

thanks a lot for your quick answer.

Tomorrow I'll try to inspect and if necessary change the data_int2 value!

Tuesday 27 November 2007 9:31:17 am

Hi Vjeran,

my "ezcollab_item" table is made of 519 rows... how I could understand which rows have wrong version number? Do I have to compare with "ezcontentobjectcurrent_version" table? But you said in ezforum this last table reports too wrong data?

Or I could delete all rows in the ezcollab_item table?

Thanks a lot in advance,
Dario

Friday 30 November 2007 4:40:25 pm

Finally I solved my issue deleting all the rows in the following tables:

- ezapprove_items
- ezcollab_item
- ezworkflow_process

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from