eZ Community » Forums » Install & configuration » Getting rid of index.php
expandshrink

Getting rid of index.php

Getting rid of index.php

Tuesday 14 November 2006 8:31:16 am - 5 replies

I have setup a new eZ Publish (3.8) on a LAMP stack. I have configured mod_rewrite and everything, I'm still getting index.php in the URLs. How can I get rid of it?

Tuesday 14 November 2006 4:05:33 pm

Hi Ibrahim,

Have you configured your ezpublish installation to run in virtual host mode ?

http://ez.no/doc/ez_publish/techn..._basics/configuration/access_methods

happy.gif Emoticon

Wednesday 15 November 2006 1:36:16 pm

yes happy.gif Emoticon

I have two URLs, e.g:

user.example.com for the user side
admin.example.com for the admin side

Modified on Wednesday 15 November 2006 1:36:22 pm by Ammar Ibrahim

Wednesday 15 November 2006 1:52:49 pm

If your rewrite rules are OK, you might need to add:

ForceVirtualHost=true

underneath

[SiteAccessSettings]

in settings/override/site.ini.append.php. After clearing the caches the URLs will be generated without index.php.

Modified on Wednesday 15 November 2006 1:53:10 pm by Michael Maclean

Wednesday 15 November 2006 3:05:45 pm

Thanks, it worked

Saturday 18 November 2006 12:44:55 pm

If your rewrite rules are OK, you might need to add:
ForceVirtualHost=true

underneath

[SiteAccessSettings]

in settings/override/site.ini.append.php. After clearing the caches the URLs will be generated without index.php.

Thanks for this usefull tips ! I've now the site running without "index.php?". But now I have a new trouble: all external links (google, etc) to the site have "index.php?" on the URL and following tis links the site show "index.php module not not found".

How can I trick the .htaccess to accept and "clean" the urls ?

thanks

Modified on Saturday 18 November 2006 8:23:09 pm by Alexandre Cunha

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from