This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Help please - images, hosting,...
expandshrink

Help please - images, hosting, convert, permissions

Help please - images, hosting, convert, permissions

Thursday 09 January 2003 10:14:39 pm - 1 reply

On my hosted site I can display existing images but not upload them. When I press store in the article admin view it says input stored succesfully but the image doesn't display, only a box with an 'x' in it. The image files are not created in variation folders either.

I figured this meant Imagemagick convert isn't working, but it is installed (in /usr/local/bin). I've set the path in image.ini to /usr/local/bin and I've even had the convert.exe file copied into my own bin directory and tried setting the path to there.

Still no joy, and I want to go live this weekend. An old forum post with a similiar problem was overcome by identifying a permissions problem in php.ini but my host has said they've looked in php.ini and can't see anything untowards.

Can anyone help with suggestions or questions I can fire at my host or think of any other things I could be getting wrong.

The site works fine on my home PC under the windows install.
Richard.

Saturday 11 January 2003 11:32:10 pm

> > On my hosted site I can display existing images but not
> > upload them. When I press store in the article admin view
> it
> > says input stored succesfully but the image doesn't
> display,
> > only a box with an 'x' in it. The image files are not
> > created in variation folders either.
> >
> > I figured this meant Imagemagick convert isn't working,
> but
> > it is installed (in /usr/local/bin). I've set the path
> in
> > image.ini to /usr/local/bin and I've even had the
> > convert.exe file copied into my own bin directory and
> tried
> > setting the path to there.
> >
> > Still no joy, and I want to go live this weekend. An old
> > forum post with a similiar problem was overcome by
> > identifying a permissions problem in php.ini but my host
> has
> > said they've looked in php.ini and can't see anything
> > untowards.
> >
> > Can anyone help with suggestions or questions I can fire
> at
> > my host or think of any other things I could be getting
> > wrong.
> >
> > The site works fine on my home PC under the windows
> > install.
> > Richard.
>
> I would check the premissions of the var folder, I have
> found that modfix does quite work right. It seems that this
> folder needs to have (as least under unix) the same user and
> group as the web service (NOT your account).
>
> I would also check if you are in safe_mode, which will not
> work.
>
> I hope this gives you a clue or two.
>
> Michael

I wouldn't be surprised if you're right and I've passed this onto my hosting service support.
Because I simply copied my files up from a Windows install to the host, I'd never come across modfix. Now I'm trying to find out how to achieve what it does at my host. The file manager they provide doesn't let me change world permissions.
Otherwise I wouldn't know where to start to find out about 'safemode'.
Any further help on what safemode is would be appreciated.
Regards
Richard

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from