This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Host access method not working
expandshrink

Host access method not working

Host access method not working

Thursday 07 September 2006 11:10:43 pm - 2 replies

Hi,

I have a web site hosted on Lunarpages servers with ezPublish installed on it. It is working (alsmost) fine in URI mode.

I wanted to move to HOST mode and I did the following changes:
- update the .htaccess file with the appropriate rewrite rules
- update the override/site.ini.append.php
- clear the cache

When I try to access my website with http://www.mysite.com, it works fine. But, the URLs generated using ezurl() are still formatted in URI mode such as http://www.mysite.com/index.php?/mypage (and this URL is working, I have access to "mypage"...)

While if I try to access http://www.mysite.com/whatsoever/anything it always return the homepage with the following error in the debug:

<i>Error: eZSys::serverVariable
Server variable 'QUERY_STRING' does not exist</i>

It seems like ezPublish does not want to activate the HOST mode, but why ?

Another clue is that on Lunarpages, in URI mode I always have to use the "?" after index.htm, otherwise it does not work. Could my problem related to this limitation ?

Thanks in advance for any help,
Hakim

My .htaccess file only contains:

RewriteEngine On
RewriteRule !\.(js|gif|css|jpg|png)$ /home/salsa6/public_html/salsacaliente/index.php

My site.ini.append.php file contains the following section:

[SiteAccessSettings]
CheckValidity=false
AvailableSiteAccessList[]
AvailableSiteAccessList[]=cam
AvailableSiteAccessList[]=cam_admin
MatchOrder=host
HostMatchMapItems[]
HostMatchMapItems[]=www.mysite.com;cam
HostMatchMapItems[]=admin.mysite.com;cam_admin
DebugExtraAccess=enabled
DebugAccess=enabled

Modified on Thursday 07 September 2006 11:12:07 pm by Hakim Bouras

Friday 08 September 2006 8:45:17 am

Try setting

[SiteAccessSettings]
ForceVirtualHost=true

in settings/override/site.ini.append.php

And don't forget to clear all caches.

Friday 08 September 2006 10:25:36 am

Thanks Norman, it is now working fine.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from