This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » How to disable all caches in...
expandshrink

How to disable all caches in eZPublish 5.1 ?

How to disable all caches in eZPublish 5.1 ?

Monday 18 March 2013 1:52:36 pm - 2 replies

Hi! I have the 5.1 community version of eZPublish and I have problems with the cache.

Even if I remove all the Symfony cache with the rm command in ezpublish/cache/dev and ezpublishe/cache/prod folders, I stil have some templates that are cached.

So how can I disable all the caches ?

 

Thanks a lot

Monday 18 March 2013 3:06:56 pm

Hi Claire!

You have to add some parameters in ezpublish_dev.yml in order to disable view cache.

Here is an example:

 imports:   
    -
        resource: ezpublish.yml
  ezpublish:
    system:
        <your_siteaccess>:
            content:
                view_cache: false

Cheers.

Modified on Monday 18 March 2013 3:08:57 pm by Sylvain Guittard

Thursday 02 May 2013 8:27:30 am

If you want to disable Symfony reverse proxy (where the cache is located) you can also comment the following line in your web/index(_dev).php :

 $kernel = new EzPublishCache( $kernel );

You can also disable the SPI cache with this setting : 

 stash:    
    caches:
        default:
            handlers:
                - BlackHole
                inMemory: false

Cheers

Modified on Thursday 02 May 2013 8:40:22 am by Nicolas Pastorino

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from