eZ Community » Forums » Install & configuration » I can't see my .flv video on my site
expandshrink

I can't see my .flv video on my site

I can't see my .flv video on my site

Saturday 07 November 2009 8:18:09 am - 7 replies

Hallo!
I use eZ Publish 4.2.0 with "plain site" package on Windows XP, Apache, MySQL.
I want to make video gallery.
I have installed eZFlow package without content classes on my "plain site", because i need "Video/Flash Player" content class only.
I have exported "Video/Flash Player" content class from other full eZ Flow site, and then i have imported "Video/Flash Player" package into my "plain site".
Then i have copied flash_player.swf into \design\plain_site\flash\
and flash_player.tpl into \design\plain_site\override\templates\full\ from other full eZ Flow site.

I have added this block

[full_flash_player]
 Source=node/view/full.tpl
 MatchFile=full/flash_player.tpl
 Subdir=templates
 Match[class_identifier]=flash_player

into \settings\siteaccess\ncom\override.ini.append.php

Now I'm trying to watch my .flv video, but I can't see as the clip and the flash video player.
Where is my bug and how can i add flash video player on my site?

This is source code from loaded page:

 <script type="text/javascript">

    <!--
 insertMedia(
'<object type="application/x-shockwave-flash"
data="/design/plain_site/flash/flash_player.swf" width="448"
height="354"> ');

        insertMedia( '<param name="movie" value="/design/plain_site/flash/flash_player.swf"  /> ');
        insertMedia( '<param name="scale" value="exactfit" /> ');
        insertMedia( '<param name="allowScriptAccess" value="sameDomain" />');
        insertMedia( '<param name="allowFullScreen" value="true" />');
        insertMedia( '<param name="flashvars" value="moviepath=/index.php/ncom/content/download/73/268&amp;embedurl=<a href="http://nc.local/flash/embed/73&amp;embedlink=http://nc.local/index.php/ncom/Novosti/Video-rolik%22" title="http://nc.local/flash/embed/73&amp;embedlink=http://nc.local/index.php/ncom/Novosti/Video-rolik"">http://nc.local/flash/embed/73&am...x.php/ncom/Novosti/Video-rolik"</a> />');
        insertMedia( '<p>No <a href="<a href="http://www.macromedia.com/go/getflashplayer%22%3EFlash" title="http://www.macromedia.com/go/getflashplayer">Flash">http://www.macromedia.com/go/getflashplayer">Flash</a> player<\/a> avaliable!<\/p>');
        insertMedia( '<\/object>' );

    //-->

    </script>



    <noscript>
 <object
type="application/x-shockwave-flash"
data="/design/plain_site/flash/flash_player.swf" width="448"
height="354">

        <param name="movie" value="/design/plain_site/flash/flash_player.swf" />
        <param name="scale" value="exactfit" />
        <param name="allowScriptAccess" value="sameDomain" />
        <param name="allowFullScreen" value="true" />
        <param name="flashvars" value="moviepath=/index.php/ncom/content/download/73/268&amp;embedurl=<a href="http://nc.local/flash/embed/73&amp;embedlink=http://nc.local/index.php/ncom/Novosti/Video-rolik%22" title="http://nc.local/flash/embed/73&amp;embedlink=http://nc.local/index.php/ncom/Novosti/Video-rolik"">http://nc.local/flash/embed/73&am...x.php/ncom/Novosti/Video-rolik"</a> />
        <p>No <a href="<a href="http://www.macromedia.com/go/getflashplayer%22%3EFlash" title="http://www.macromedia.com/go/getflashplayer">Flash">http://www.macromedia.com/go/getflashplayer">Flash</a> player</a> avaliable!</p>

    </object>

Modified on Tuesday 10 November 2009 10:44:39 pm by Maxim Kopytov

Tuesday 10 November 2009 5:26:54 pm

Hello !

Try to type your swf url directly on your browser and look at if you can see it.

Tuesday 10 November 2009 10:41:16 pm

Hello !

Try to type your swf url directly on your browser and look at if you can see it.

You are very clever, but Your answer is useless...
I have tried it!
This direct link shown me video clip.

http://nc.local/var/plain_site/storage/original/video/06c1ba70708b4a81e1a88dcd5ad40350.flv

But I need in flash video player + flv clip
And this link

http://nc.local/design/plain_site/flash/flash_player.swf

shown me flash video player.
But I need in flash video player with uploaded clip from storage.
FireBug report me:

 insertMedia is not defined 

<a href="http://nc.local/ncom/Novosti/Video-rolik" title="http://nc.local/ncom/Novosti/Video-rolik">http://nc.local/ncom/Novosti/Video-rolik</a>    Line 298

*insertMedia( '<object type="application/x-shockwave-flash"
data="/design/plain_site/flash/flash_player.swf" width="448"
height="354"> ');

Where is my bug? Help me please.

Wednesday 11 November 2009 1:09:07 am

Maxim,

calling Yannick's answer's "useless" is a bit rude. He was trying to help you determine where the error is, and checking first if the flash item can be accessed is a good first step.

insertMedia is a JS function right ? Is it defined ?

Wednesday 11 November 2009 6:39:43 am

Maxim,
calling Yannick's answer's "useless" is a bit rude. He was trying to help you determine where the error is, and checking first if the flash item can be accessed is a good first step.

Hallo, Bertrand!
Hallo, Yannick!
Yannick, I'm sorry for my rudeness!
But I'm think that You answer for me with a jeer.
I'm take back my words.
What do You think about my problem with eZFlow and flash player?
I'm novice in eZ Publish.

Modified on Wednesday 11 November 2009 6:42:16 am by Maxim Kopytov

Wednesday 11 November 2009 11:48:59 am

you are missing a .js file

check in ezflow/ if you have insertmedia.js and if it is declared in ezflow/settings/design.ini.append.php

Friday 13 November 2009 8:11:46 pm

Hallo guys!
Thank you very much for your regard!

And I'm very sorry for my English and rudeness!

Realy it was a problem with insertMedia function as Bertrand said.

I had no insertmedia.js file and match setting in design.ini.append.php as Sylvain said.

I have copied insertmedia.js into \www\design\plain_site\javascript\
and have inserted this block

[JavaScriptSettings]
JavaScriptList[]=insertmedia.js

into \www\settings\siteaccess\<site>\design.ini.append.php

After that I have seen video player with my .flv clip!
It's great!

Yannick, Bertrand and Sylvain, thank you very much!

Saturday 14 November 2009 11:04:33 am

No offense taken, and don't worry about your english happy.gif Emoticon

Glad your issue was fixed.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from