This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit

eZ Community » Forums » Install & configuration » Images missing

Images missing

Images missing

Sunday 11 January 2015 9:00:26 am - 22 replies


we have encountered a strange problem. When editing an article and want to insert an image in the XML block, a popup window appears. So ar so good. But when we start browsing almost all images are gone. They exist in the media archive, but not in this popup.

However, when we do upload new iages in this popup all is fine, and we also find them later.

The config directive RootMediaNode is correctly set to 43.

Quite clueless... any ideas? We are running 2012.8.

Sunday 11 January 2015 3:16:55 pm

Are there any obvious errors in the debug output or log files?

Is this front-end editing?  If the place where you see the images is a different siteaccess than where they are missing - then there is a good chance that it's just a missing alias configuration in the image.ini.

Can you go directly to the image path?  Can you go the image path after removing the image alias suffix (i.e. _small _medium _large)?

If you can go to the original image but not the alias, that's a good indication that there is something wrong with the alias.

Monday 12 January 2015 6:49:21 am

No, there are no errors logged in the log files regarding this matter.

All pictures can be seen in both the public site and the admin interface. Just not in the popup, there we only see listed newly uploaded pictures.

Since we can access the pictures via the media library I cannot see how this can be related to the aliases...?

Monday 12 January 2015 7:15:38 am

Looks like I totally misunderstood what you were saying.  I understood that you couldn't see the actual image - but you can't see the line listing in the content/browse popup template....  And, no, that would have nothing to do with the image aliases.

If you clear the cache do the images appear in the listing?

Monday 12 January 2015 8:54:58 am

No, clearing the cache both from UI and filesystem does not help. That is the first thing I allways do when something appears wrong happy.gif Emoticon

Monday 12 January 2015 9:28:05 am

Can it be a permissions thing?  The user is admin?  If not, is it different for admin?

Just to be sure, this is the "Upload new Image" popup, under the "browse" tab - and the following the directory tree structure under "Media"?

Are there any template overrides in play?

Are there any javascript errors while loading the page?

Do you get any output going to:


Monday 12 January 2015 11:00:39 am

Permissions are ok, have checked them. Yes, it's that popup, but the tab "Look for", third tab. Upload works as I wrote fine.

No override templates are in use for this - or any other thing in admin.

No Javascript errors.

Output from suggested URL:



Monday 12 January 2015 1:40:41 pm

What happens when you substitute the parent node id for the 43 in the above url?



Tuesday 13 January 2015 1:02:23 am

Modified on Tuesday 13 January 2015 1:03:12 am by Leif Arne Storset

Tuesday 13 January 2015 1:05:24 am

(I'm assisting Atle with this problem on his site.)

(Strange times: posts an empty comment instead of what I wanted to say. Maybe it's the quoted text. I'll omit it in this attempt.)

@Steven: Trying your suggestion on the node where we expect to find images, I get either a jumbled CSV file or HTTP 200 headers with an empty body. On a functioning node I get a well-formed JSON file. The CSV file has jumbled control characters mixed in with apparently good data. There are no line breaks between entries.

[Sample omitted, in case it's preventing this comment from being posted.]

It looks a bit like the file browser's server script is choking on something. I thought it might be a bad EXIF field, but it happens for so many pictures in a certain family of folders that I think it must be something more general.

Tuesday 13 January 2015 1:07:03 am

Tuesday 13 January 2015 7:25:59 am

It is possible that a non-standard utf8 (assuming you are using utf8) character in a filename is messing up the JSON?

That shouldn't be a problem, but maybe some encoding is off somewhere... although, I would think that it would break in other places before you get to the browse template code in the popup.

Are you using Internet Explorer - if so, try using a different browser and see if that makes a difference.

Tuesday 13 January 2015 12:26:15 pm

Hello Guys!

I can't help but still wonder what you are seeing in the popup exactly. Would you consider posting a screenshot of the popup so we can truly see what you are seeing?

If not I understand.

Sorry I could not be of more help.

Best wishes,


Wednesday 14 January 2015 6:59:50 am

I have uploaded a screenshot here - it's in norwegian I'm afraid, but I think you get the picture(?). Let me know if any more screenshots are needed.

Wednesday 14 January 2015 12:31:11 pm

If it helps; this is just a test instance made yesterday from the live site so really anyone could log in and have a look if they want... We have no sensitive data in there.

Wednesday 14 January 2015 6:47:32 pm

You've tried different browsers?

Have you tried to move some of the images out of the folder (especially the ones with names that include the Norwegian specific letters)?

Thursday 15 January 2015 6:25:28 am

Yes, have tried all browsers; Firefox/Chrome/Explorer.

If you take a look at you will see the popup (Mappe = Folder, Bilde = Picture - standard classes).

The picture "Blueline" is newly uploaded, it works.

Furter on there you see a Neste >> (Next >>blunk.gif Emoticon. This tells us that there are more pictures, actually one more, but when we hit next no image appears. That image was moved up one level from a folder named "Bilder Aust-Agder". The image is named "NSB". No change.

The "Blueline"-image has also been moved around, no changes on that on either; it works anywhere.

As I wrote yesterday, this is just a complete carbon copy (inclusive the database) of the live instance. Hence we can do all madness on it as we wish. It runs on the same servers as the live production site. If anyone want to log in and poke around that is quite possible, there are no sensitive data there, just public news and publications.

Address for the live production site are btw.

If anyone want to log in, drop me a private message here and I will hand out more info on how to login.

Thursday 15 January 2015 8:19:02 pm

Just a quick update...

Heath dug into the site and did some findings that pointed in the direction of crumbled exif info in the image files. It was not a problem in all files.

There are indication that this problem was fixed in 2013 so I will do a test upgrade to 2014.11 and see if the problem is solved.

We do not know what caused the problem though, just the result of it.

Friday 16 January 2015 5:42:12 pm

Ok, i wrote a long reply and it just vanished suspicious.gif Emoticon

Short; we did the upgrade 2012.8 => 2014.11 and all seems to be working properly again. The findings Heath did pointing to crumbled exif in the image files was the problem. Or, the problem was eZ not handling it properly.

We will continue testing some more days before we do the actual live upgrade. I will report back in this thread if something surfaces...

Friday 16 January 2015 5:49:35 pm

Hello Everyone!

I'm so pleased that Atle and I were able to solve this issue so quickly.

I can't take all the credit here as Steven and Leif really helped point my research in the right direction.

In the end searching for related exif issues was key to finding that the problem had already been properly solved in more recent releases after researching to confirm it was an exif encoding issue.

Best wishes!


Friday 16 January 2015 10:04:02 pm


Could you point out the JIRA ticket(s) that helped you?


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from