This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » install Ezpublish 5: PHP Fatal error:...
expandshrink

install Ezpublish 5: PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 32 bytes)

install Ezpublish 5: PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 32 bytes)

Sunday 11 May 2014 5:37:12 pm - 2 replies

Hi ,

I tried to install the last  Ezpublish community : but, there are these kind of errors : PHP Fatal error:  Allowed memory size of YYYYYYY bytes exhausted (tried to allocate XXX bytes)  ...

I increased the memory_limit value in php.ini. But, no result.

i used the two manuals for installation :

1- https://github.com/ezsystems/ezpublish-community/blob/master/INSTALL.md

when i launch this command:

" php -d memory_limit=-1 composer.phar install --prefer-dist "

,the error result is :

"PHP Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 32 bytes) in /var/www/vhosts/ns235158.ip-192-99-20.net/chatom/ezssha/ezpublish-community/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ContainerBuilder.php on line 852Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache handling the post-install-cmd event terminated with an exception  [RuntimeException]  An error occurred when executing the "'cache:clear --no-warmup'" command."

2- https://confluence.ez.no/display/EZP52/Installing+eZ+Publish+on+a+Linux-UNIX+based+system

when i launch this command: " php ezpublish/console assets:install --symlink web",

the result is :

"PHP Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 153 bytes) in /var/www/vhosts/ns235158.ip-192-99-20.net/chatom/ezftpb/main/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/ServiceReferenceGraph.php on line 120 "

Thanks to explain me how to solve theses problems of installation.

Kind regards

Monday 12 May 2014 11:14:32 pm

It seems not to accept the memory_limit parameter passed, the 33554432 bytes is the 32MB php default value.

Just set in your php.ini the value to 128M or 256M for cli and/or apache if you have seperate ones and you're fine blunk.gif Emoticon

I have tested the command via "#php -d memory_limit=256M --info | grep memory_limit" and it says 256M happy.gif Emoticon

Wednesday 14 May 2014 12:26:28 pm

make sure you have it changed in both: Apache2 and CLI

that was my problem too

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from