This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » install on server
expandshrink

install on server

install on server

Saturday 13 October 2012 11:23:28 pm - 14 replies

hello i just downloaded the ezpublish5_community_project-2012.9-gpl-full.tar file and unzip it to my server

When i try to enter the contents i dont see any instalation scripts displaying..

the structure of the unpack .tar is: ezpublish5_community_project-2012.9-gpl-full/vendor inside vendor i have this folders: ezsystems,qafoo,sensio

How i continue and setup ez publish?

Modified on Saturday 13 October 2012 11:26:32 pm by giannis veronis

Sunday 14 October 2012 9:24:23 am

Take a look at the INSTALL.md and GETTING_STARTED.md - all the .md files in the root of what you downloaded and follow the instructions. 

But, if you are doing this in conjunction with your other posts, here - http://share.ez.no/forums/developer/web-site-remake I suggest you pay particular attention to the line:

"eZ Publish 5 development is still at an early stage (*pre-beta*)"

Don't even think about doing a production site using ezpublish5 for at least a year (IMHO).  What you want to do is extract the app/ezpublish_legacy directory and use that.   Or use 2012.8.

I would also suggest you take Paul Bolger's advice in the other thread.

Monday 15 October 2012 9:38:38 am

Quote from Steven E Bailey :

Take a look at the INSTALL.md and GETTING_STARTED.md - all the .md files in the root of what you downloaded and follow the instructions. 

But, if you are doing this in conjunction with your other posts, here - http://share.ez.no/forums/developer/web-site-remake I suggest you pay particular attention to the line:

"eZ Publish 5 development is still at an early stage (*pre-beta*)"

Don't even think about doing a production site using ezpublish5 for at least a year (IMHO).  What you want to do is extract the app/ezpublish_legacy directory and use that.   Or use 2012.8.

I would also suggest you take Paul Bolger's advice in the other thread.

i see thanks so much for this input, i am neebie and i would have gone into trouble, so can you provide me the link to download app/ezpublish_legacy ? Where i find this? I have read the instructions on  setting up ez publish (.md files) but none of them says what script to execute or in  what page..so if you kindly can assist me on that i would be grateful

Monday 15 October 2012 9:44:39 am

Quote from giannis veronis :
Quote from Steven E Bailey :

Take a look at the INSTALL.md and GETTING_STARTED.md - all the .md files in the root of what you downloaded and follow the instructions. 

But, if you are doing this in conjunction with your other posts, here - http://share.ez.no/forums/developer/web-site-remake I suggest you pay particular attention to the line:

"eZ Publish 5 development is still at an early stage (*pre-beta*)"

Don't even think about doing a production site using ezpublish5 for at least a year (IMHO).  What you want to do is extract the app/ezpublish_legacy directory and use that.   Or use 2012.8.

I would also suggest you take Paul Bolger's advice in the other thread.

i see thanks so much for this input, i am neebie and i would have gone into trouble, so can you provide me the link to download app/ezpublish_legacy ? Where i find this? I have read the instructions on  setting up ez publish (.md files) but none of them says what script to execute or in  what page..so if you kindly can assist me on that i would be grateful

Ok i find the 2012.8 here http://share.ez.no/downloads/downloads/ez-publish-community-project-2012.8 is that the version you where talking about?

Monday 15 October 2012 10:13:02 am

Hi Giannis, 

Steve also mentioned that you can extract the 4.x stack embedded in the latest Community Project build: 2012.9: it is more recent than 2012.8. You can find it, in the 2012.9 archive, under app/ezpublish_legacy.

Cheers,

Monday 15 October 2012 10:49:16 am

Quote from Nicolas Pastorino :

Hi Giannis, 

Steve also mentioned that you can extract the 4.x stack embedded in the latest Community Project build: 2012.9: it is more recent than 2012.8. You can find it, in the 2012.9 archive, under app/ezpublish_legacy.

Cheers,

But this is the version i downloaded from start and Steven told me not to use..so i will stick to the one i send in the previous post thriugh the link thanks

Monday 15 October 2012 11:13:50 am

Sorry if I wasn't clear.  Actually, it isn't clear unless you've been following it... but, anyway 2012.9 is the ezpublish4 community release wrapped in the symfony stuff that will the ezpublish5 release.

Meaning, if you extract the tarball (or zipfile), what you get in apps/ezpublish_legacy is an updated version of what you get in the 2012.8 tarball (or zipfile).

But I think you just want to download this and get a feel for what eZPublish is, so either one is fine... when you actually start developing you may want to get the latest version, otherwise you might find yourself doing a lot of upgrades (which are actually at this point relatively easy).

I just wouldn't touch the ezpublish5 release at this point for production and/or as a newbie, it's pre-beta, will probably change in fundamental ways to break whatever you develop, the online documentation will be incorrect and people here won't know what edge-case problems are either.

To answer the question on how to install:

http://doc.ez.no/eZ-Publish/Technical-manual/4.7/Installation

This is what you want to  look at.  Actually the technical manual that this is a part of.  The community " legacy" releases at this point most match up to the 4.7 enterprise release.

 

Monday 15 October 2012 11:27:02 am

Quote from Steven E Bailey :

Sorry if I wasn't clear.  Actually, it isn't clear unless you've been following it... but, anyway 2012.9 is the ezpublish4 community release wrapped in the symfony stuff that will the ezpublish5 release.

Meaning, if you extract the tarball (or zipfile), what you get in apps/ezpublish_legacy is an updated version of what you get in the 2012.8 tarball (or zipfile).

But I think you just want to download this and get a feel for what eZPublish is, so either one is fine... when you actually start developing you may want to get the latest version, otherwise you might find yourself doing a lot of upgrades (which are actually at this point relatively easy).

I just wouldn't touch the ezpublish5 release at this point for production and/or as a newbie, it's pre-beta, will probably change in fundamental ways to break whatever you develop, the online documentation will be incorrect and people here won't know what edge-case problems are either.

To answer the question on how to install:

http://doc.ez.no/eZ-Publish/Technical-manual/4.7/Installation

This is what you want to  look at.  Actually the technical manual that this is a part of.  The community " legacy" releases at this point most match up to the 4.7 enterprise release.

 

So steven to wrap up i will download this version: http://share.ez.no/downloads/downloads and then use the app/ezpublish_legacy folder to do the install from the instalation script that it is in there? Or if not provide me please with the latest more stable version of ez publish for new site development.

Thanks so much for your help so far and excuse my ignorance as a newbie

Monday 15 October 2012 12:16:47 pm

Note that installation through eZ Publish 5 itself is now fixed in GIT. It was unfortunately too late to make it into 2012.9, but it wil be in 2012.10.

Monday 15 October 2012 12:52:36 pm

Quote from giannis veronis :

So steven to wrap up i will download this version: http://share.ez.no/downloads/downloads and then use the app/ezpublish_legacy folder to do the install from the instalation script that it is in there? Or if not provide me please with the latest more stable version of ez publish for new site development.

Thanks so much for your help so far and excuse my ignorance as a newbie

Yes, you can download that release, extract just the app/ezpublish_legacy directory, copy that directory to your web root (i.e. /var/www) and follow the instructions in the technical manual.

Monday 15 October 2012 5:40:24 pm

Quote from Steven E Bailey :
Quote from giannis veronis :

So steven to wrap up i will download this version: http://share.ez.no/downloads/downloads and then use the app/ezpublish_legacy folder to do the install from the instalation script that it is in there? Or if not provide me please with the latest more stable version of ez publish for new site development.

Thanks so much for your help so far and excuse my ignorance as a newbie

Yes, you can download that release, extract just the app/ezpublish_legacy directory, copy that directory to your web root (i.e. /var/www) and follow the instructions in the technical manual.

You save me big time, i would i appreciate to let me know if you have any problems in php or other so i can help you in the same way..many thanks!

Monday 15 October 2012 10:43:16 pm

So Steven i did what you told after i read the instructions and i get the following errors:

Notice: Use of undefined constant __DIR__ - assumed '__DIR__' in /home/...../public_html/ezpublish_legacy/autoload.php on line 17

Notice: Use of undefined constant __DIR__ - assumed '__DIR__' in /home/...../public_html/ezpublish_legacy/autoload.php on line 24

Notice: Use of undefined constant __DIR__ - assumed '__DIR__' in /home/...../public_html/ezpublish_legacy/autoload.php on line 61

Warning: require(__DIR__/autoload/ezp_kernel.php) [function.require]: failed to open stream: No such file or directory in /home/...../public_html/ezpublish_legacy/autoload.php on line 61

Warning: require(__DIR__/autoload/ezp_kernel.php) [function.require]: failed to open stream: No such file or directory in /home/...../public_html/ezpublish_legacy/autoload.php on line 61

Fatal error: require() [function.require]: Failed opening required '__DIR__/autoload/ezp_kernel.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/...../public_html/ezpublish_legacy/autoload.php on line 61

 

any ideas?

Monday 15 October 2012 11:42:20 pm

Hi Giannis, 

Which version of PHP are you using?
5.2 or below? If so, __DIR__ is not existing and would explain these errors. The solution would be to upgrade to 5.3, which might be a good idea anyways.

Cheers 

Tuesday 16 October 2012 8:33:08 am

yes you are right, i use this version now regarding the other requirments:PostgreSQL >= 8 if my server doesnt support PostgreSQL will i have problem instaling?

Friday 19 October 2012 4:07:50 pm

Quote from giannis veronis :

yes you are right, i use this version now regarding the other requirments:PostgreSQL >= 8 if my server doesnt support PostgreSQL will i have problem instaling?

Hi, 

You'd need to upgrade to PHP 5.3.3. And MySQL will work fine, no worries.

Cheers,

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from