This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Invalid checksum during installation
expandshrink

Invalid checksum during installation

Invalid checksum during installation

Saturday 17 September 2011 4:59:31 am - 4 replies

Hello eZ community!

I'm having an issue installing (or rather reinstalling) eZ. About a month back I started developing on eZ, made an install on my server to have a mess around and learn. This went fine, installed 2011.7, had a poke around, no problems. Last week I decided to wipe everything and start fresh. I deleted everything, including the database, uploaded the new 2011.8 community build and tried to install. Everything goes fine up until selecting a package to install. Once a package has been selected and I hit next I receive a page that states 'An unexpected error has occurred. Please contact the webmaster.'

Upon doing a little research I found the following in the log file:

The checksum of the file 'compress.zlib://var/cache/packages/ezflow_site_clean.ezpkg' is invalid. in /home/path/public_html/lib/ezc/Archive/src/tar/headers/v7.php on line 198

I've tried reinstalling the 2011.7 build that worked the first time round, messing around with file permissions, uploading a package manually (Being new to eZ I may have missed something with these steps, however).

I also stumbled across this post, but I don't really understand how to recreate what Jeroen is suggesting (or whether it's a good idea).

Any help would be greatly appreciated, as I really have no idea where to go from here.

tl;dr: Invalid checksum when installing eZ, any thoughts?

Modified on Saturday 17 September 2011 5:01:29 am by Screaming Beagle

Saturday 17 September 2011 6:35:42 am

Hello Screaming Beagle,

Welcome to the eZ Community! Thanks for stopping by the forums.

Well, my first thoughts are that it sure sounds like the packages were not downloaded or stored correctly.

Avoiding the setup error for a moment, you can avoid it from ever occurring by manually downloading the package files into the packages directory and re-running the setup wizard.

From: http://ezpedia.org/ez/package#eztoc32821_5

Tip: Avoiding package download errors within setup wizard

If you ever have trouble during the setup wizard downloading default eZ Publish packages like eZ Flow or eZ Webin you can download these packages yourself from http://packages.ez.no/ezpublish/ into the 'packages' directory. Make certain the web server can read and write to all the files in the package directory.

I could be wrong here but this is something I've done on certain lower power hosting servers in the past which have -only- ever had troubles running the setup wizard package installation after that all the basic features of eZ worked flawlessly. In short downloading the packages by hand for the webserver makes for a much smoother, faster installation of eZ.

I hope this helps happy.gif Emoticon

Cheers,

Heath

Modified on Saturday 17 September 2011 6:37:57 am by // Heath

Sunday 18 September 2011 12:34:18 pm

Hi Heath, thanks for the quick reply!

Your advice seems to have done the trick! I tried to upload the .ezpkg files, but the problem remained. So I grabbed a copy of var/storage/packages/eZ-systems from a previous successful install (which I'm assuming is just the extracted contents of the package files used at install?) and all worked fine.

Hopefully someone else finds this useful, I was truly out of ideas lol.

Thanks again! big-smile.gif Emoticon

Sunday 18 September 2011 7:53:54 pm

@ Screaming Beagle

Your very welcome. I'm happy to help.

I think it was quite clever of you to think of using a past copy of 'var/storage/packages/eZ-systems'.

I'm glad that worked for you. I also help this experience helps others.

 

Cheers,

Heath

 

eZ Publish is Great!

Monday 19 September 2011 9:34:17 am

That is what i call a quickly & cleanly solved case happy.gif Emoticon

Welcome aboard @Screaming Beagle and thanks @Heath.

Cheers,

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from