This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Invalid package Remote repository
expandshrink

Invalid package Remote repository

Invalid package Remote repository

Wednesday 19 August 2009 5:30:06 am - 4 replies

I am running the lastest version of PHP and MySQL and Apache. I get the following error, upon selecting Website Interface.
------------------------------------start error-------------------------------
Error

Invalid package

Remote repository URL: http://packages.ez.no/ezpublish/4.1/4.1.3/
------------------------------------end error--------------------------------------
When I tried to upload the ezwebin_site.ezpkg file it gives me the following error

------------------------------start error--------------------------------------------------------------
Error

Uploaded file is not an eZ Publish package

Remote repository URL: http://packages.ez.no/ezpublish/4.1/4.1.3/
------------------------------------------end error--------------------------------------------------------

I have zlib fully enabled in my PHP, and everythign looks ok. I also tried everythign recommended by Mr. Kristof in this thread:
http://ez.no/it/developer/forum/i...te_package_selection_invalid_package

and I still get the same 2 errors. Somebody please let me know what am I missing.

Wednesday 19 August 2009 9:54:19 am

Care to post some more details on your system?
php version, php extensions, eZ Components version, os..

Sunday 30 August 2009 10:20:15 pm

I was seeing the very same symptoms as Andy but was able to solve the problem.

In my case, the issue was caused by the fact that I had multibyte string function overloading enabled in php.ini (configuration directive mbstring.func_overload). As a result, ezcArchive became confused so that it could only see some of the files in the site package (and in any tarball, for that matter).

The "Site package selection" step during installation was failing because eZPackage was unable to find package.xml even though the file was there.

The bottom line: mbstring function overloading and ezcArchive do not seem to play well together.

//Kalle

Wednesday 27 April 2011 2:19:35 pm

I cannot install 4.5 beta1 due to this issue, and checking various symptoms posted here since 2006 (!), including those above, have yielded fruitless too. So, bump.

Edit: Oops, mbstring.func_overload = 0 was not in my dev php.ini. Fixed!

Modified on Wednesday 27 April 2011 4:02:43 pm by Scott Sanders

Wednesday 27 April 2011 7:07:58 pm

A good candidate for a feature request then: add checking for mbstring.func_overload in the setup wizard. Anybody wants to write this down in the issue tracker?

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from