This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Long waiting time to access
expandshrink

Long waiting time to access

Long waiting time to access

Monday 30 May 2011 5:17:01 pm - 5 replies

Hello,

When accessing the home page of our website we have a long waiting time.

With FireBug, we can see that :

0 - DNS resolution
0 - Connection
0 - Sending
5.89s - Pending
140ms - Reception

We have the following architecture :
2 web front-end servers with eZ Publish 4.4.0
1 database server - Oracle 10G RAC Cluster Mode

When we surf on the site, the times are no better, exemple :

0 - DNS resolution
0 - Connection
0 - Sending
3.63s - Pending
109ms - Reception

Debug mode has been activated, but we have not yet identified the problem;
Do you have any ideas?
Thank you

Christophe

Monday 30 May 2011 5:36:16 pm

Hello,

Have you followed all the necessary configuration to put an ezpublish website in production ?

PHP accelerator, ViewCaching, Template Caching, Template Compile...Etc

Monday 30 May 2011 6:01:12 pm

Hello,

All the modules mentioned were activated 

Christophe

Monday 30 May 2011 6:14:50 pm

What i can say is that a classical "blog" website with those configuration options enabled should perform well but if you have a "big" website (lot of contents, ezfind solr indexation, complex layouts) then extra settings must be applied depending on the performance problem.

To resume i'd need more information on the site setup if basic optimization isn't solving the problem.

Modified on Monday 30 May 2011 6:16:52 pm by H-Works Agency

Monday 30 May 2011 10:14:42 pm

Hi Christophe,

first, you have to make sure that most caches are enabled. If it's the case, then you should make sure that your pages are correctly optimized. The usual way of doing this in eZ Publish is too use the cache-block template function to put some parts of the page in cache to decrease the number of SQL queries needed to generate a page. This function has to be used in the pagelayout.tpl or the templates included in it because by default, there's no cache strategy for those templates. You can see the number of SQL queries in debug output table. it's commonly admitted that 10 SQL queries or less to generate a page already in cache (ie in a second hit) is a good result.

Cheers

Tuesday 31 May 2011 10:52:57 am

Hi,

After checking with my team, some settings were configured incorrectly.

We changed the following configuration file : var/www/html/settings/override/site.ini.append.php

  • ViewCaching=enabled
  • TemplateCompile=enabled
  • TemplateCache=enabled
  • DevelopmentMode=disabled

Now, we have a better response time when accessing the home page.

0 - DNS resolution
0 - Connection
0 - Sending
2.58s - Pending
157ms - Reception

Damien, we'll look at your recommendations and will keep you informed.

Thanks !

Christophe

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from