This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Migration & Upgrade at the same time.
expandshrink

Migration & Upgrade at the same time.

Migration & Upgrade at the same time.

Friday 14 December 2012 6:18:11 pm - 30 replies

Hi everyone would be very glad of some input here.

I have to migrate an eZ 3.5.1 on one Apache server running php 4.x to a new commercial Apache server which supports 4.7 and of course php 5.2

The site has many document pdf's that are made available on on payment for download.

What I need is a strategy of how to start and proceed!

Many thanks for any help here.

Keith

Wednesday 13 March 2013 2:40:04 pm

No idea.

Try and turn debug on, look in your log files to see if there is some error that would lead to this.

Take a look at your database to make sure you have content...

Are you able to log in to the admin siteaccess or is this what you see before login?

Thursday 21 March 2013 3:04:41 pm

Hi Steven,
Thanks for your help.
I have successfully updated the script up to 3.7.0 but when I have upgrade it from 3.7.0 to 3.8.0 then I get the error as below:
Fatal error: eZ publish did not finish its request
The execution of eZ publish was abruptly ended, the debug output is present below.
In error log file below error display.
error/view.php:
Error ocurred using URI: /
Can you please guide me an appropriate solution for that.
Thanks again for your help so far.

Friday 29 March 2013 7:28:40 am

Hi Steven,

Thanks for your help so far.

I have successfully updated the script up to 3.6.0 on php version PHP Version 4.3.7 but when I have upgrade it from 3.6.0 to 3.8.0 on PHP Version 4.4. then I get the error as below:

Fatal error: eZ publish did not finish its request The execution of eZ publish was abruptly ended, the debug output is present below.

In error log file below error display.

eZLocale:Could not load country settings for GB

eZLocale:Could not load language settings for eng

error/view.php:

Error ocurred using URI: /

I have download ezpublish3.8.0 form below URL.
https://github.com/ezsystems/ezpublish-legacy/tree/release-3.8.0

Can you please guide me an appropriate solution for that.

Thanks $ Regards,

Prashant

Friday 29 March 2013 9:21:05 am

Maybe try adding the Regional Settings as described here:

http://doc.ez.no/eZ-Publish/Upgra...-to-3.8/from-3.6.x-or-3.7.x-to-3.8.0

And run the

php update/common/scripts/updatemultilingual.php -s example

 

again.

You can find all the update documentation here:
http://doc.ez.no/eZ-Publish/

Modified on Friday 29 March 2013 9:25:37 am by Steven E Bailey

Monday 01 April 2013 1:29:11 pm

Hi Steven,
Thanks for your help so far.
I have added Regional setting as below URL.
http://doc.ez.no/eZ-Publish/Upgra...-to-3.8/from-3.6.x-or-3.7.x-to-3.8.0
When I run the below command on dos prompt on my local server (ezpublish380 is the site root folder and masonry is the siteaccess, ezpublish380\settings\siteaccess\masonry)
E:\xampp\php>php.exe -q E:\xampp\htdocs\ezpublish380\update\common\script\updatemultilingual.php -s masonry
Below error displayed.
Parse error: syntax error, unexpected T_CLONE, expecting T_STRING in E:\xampp\htdocs\ezpublish380\kernel\classes\ezcontentobjectversion.php on line 984
and on line 984, I have this function
function clone( $newVersionNumber, $userID, $contentObjectID = false, $status = EZ_VERSION_STATUS_DRAFT )   
{   
   $time = time();       
   $clonedVersion = $this;      
   $clonedVersion->setAttribute( 'id', null );       
   if ( $contentObjectID !== false )   
      $clonedVersion->setAttribute( 'contentobject_id', $contentObjectID );
   $clonedVersion->setAttribute( 'version', $newVersionNumber );   
   $clonedVersion->setAttribute( 'created', $time );    
   $clonedVersion->setAttribute( 'modified', $time );
   $clonedVersion->setAttribute( 'creator_id', $userID ); 
   if ( $status !== false )  
        $clonedVersion->setAttribute( 'status', $status ); 
   return $clonedVersion;  
 }
Can you please guide me an appropriate solution for that.
 
Thanks for your help so far.

Monday 01 April 2013 11:02:36 pm

Double-check that you are actually running php 4.4 - clone became a keyword with php5 - which would spit out this error message.

Tuesday 02 April 2013 11:54:12 am

Hi Steven,
Thanks for your help so far.
I have updated php version from php 4.4 to  php5.

When I run the script (php update/common/scripts/updatemultilingual.php -s example )

Same error message displayed.

 

 

Can you please guide me an appropriate solution for that.
 
Thanks for your help so far.

Tuesday 02 April 2013 3:42:50 pm

You should be using the php 4.4 - what I'm saying is make sure you are... because as far as I remember that error message could only be coming from php4 code being run under php5.

You can maybe make sure by adding "echo phpversion();" somewhere at the top of the updatemultilingual.php script.

If you are sure that you are using php4... then I have no idea.  Try renaming the clone function to something else (and of course where the function is being called). 

Thursday 04 April 2013 4:01:04 pm

Hi Steven,
Thanks for your help so far.
I have followed all the steps of upgrade ezpublish3.6.0 to expublish3.8.0
http://doc.ez.no/eZ-Publish/Upgra...-to-3.8/from-3.6.x-or-3.7.x-to-3.8.0
I have successfully run all php and mysql script on php4.4
When I run the site (ezpublish3.8.0) on browser no site content display. Below message display on browser.
The connection was reset
The connection to the server was reset while the page was loading.
The site could be temporarily unavailable or too busy. Try again in a few  moments.
If you are unable to load any pages, check your computer's network  connection.
If your computer or network is protected by a firewall or proxy, make sure  that Firefox is permitted to access the Web.
I have checked the error log file but there is no error message write.
When I try to dig out the error on index.php and stop execution by die in  " if ( $hasAccessToSite ) "  condition  . below error message display.
Fatal error: eZ publish did not finish its request
The execution of eZ publish was abruptly ended, the debug output is present below.

 if ( $hasAccessToSite )
            {
                $functionName = $runningFunctions[0];
                if ( $functionName )
                    $accessResult = $currentUser->hasAccessTo( $module->attribute( 'name' ), $functionName );
                else
                    $accessResult = $currentUser->hasAccessTo( $module->attribute( 'name' ), false );
                if ( $accessResult['accessWord'] == 'limited' )
                { die();
                    $moduleName = $module->attribute( 'name' );
                    $params['Limitation'] =& $accessResult['policies'];
                    $GLOBALS['ezpolicylimitation_list'][$moduleName][$functionName] =& $params['Limitation'];
                }
                if ( $accessResult['accessWord'] == 'no' )
                {
                    $accessList = $accessResult['accessList'];
                    $moduleAccessAllowed = false;
                }
            }
Can you please guide me an appropriate solution for that.
Thanks again for your help so far.

Thursday 04 April 2013 9:24:05 pm

The accessWord == limited is a role thing...  so, can you actually log into the backend?  If you can, make sure your Anonymous user login role has all of your siteaccesses in it.  I know it shouldn't happen and I've never been able to figure out how it could happen, but sometimes the siteaccesses are stripped out.

If you can't log into the backend then it probably means you have no database connection... for whatever reason.

If you use mysql/mysqldump/phpmyadmin can you see content in your database for 3.8?  Specifically in the ezcontentobject_attribute table.  that should have pretty much the same amount of data as pre upgrade.

If you have content in the database, make sure you are able to login with the values that are in your in files.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from