eZ Community » Forums » Install & configuration » Never getting logged out from admin site
expandshrink

Never getting logged out from admin site

Never getting logged out from admin site

Wednesday 05 February 2014 7:04:39 pm - 5 replies

Hello Everyone; 

I dont never get logged out from my admin site 

in my override.ini i have 

[Session]

ActivityTimeout=3600

Is there something that i am missing or i can add to fix it?

thanks on advance

Thursday 06 February 2014 2:02:20 pm

Is the session handler set to the eZ session handler?

Handler=ezpSessionHandlerDB

http://doc.ez.no/eZ-Publish/Technical-manual/4.x/Reference/Configuration-files/site.ini/Session

If not, the session duration is defined by the settings in /etc/php.ini

http://www.php.net/manual/en/session.configuration.php

Thursday 06 February 2014 6:25:48 pm

Yes , its empty which means ezpSessionHandlerDB

[Session]

RememberMeTimeout=
Handler=
SessionTimeout=259200

ActivityTimeout=3600

I change it to Handler=ezpSessionHandlerDB

no difference!

Do you have a suggestion?

Thursday 06 February 2014 11:54:32 pm

What OS/linux distro are you running?  Debian uses session.gc_maxlifetime and ignores the ezpublish settings.  Could this be it?

Friday 07 February 2014 9:54:32 am

PHP Version 5.4.4-14+deb7u3

Debian 3.2.41

I have another site on onther server , on the same version of Debian, which works well. and i have another copy of this site on one other server which has the same problem!

Sunday 09 February 2014 5:18:53 am

If you want the session to time out after the user has been inactive for an hour, you might want to try putting the SessionTimeout to the same value.

You may be able to see the active sessions under Setup > Sessions.

Don't forget to clear the caches.

Modified on Sunday 09 February 2014 5:19:12 am by Betsy Gamrat

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from