eZ Community » Forums » Install & configuration » No roles, no content, but you can...
expandshrink

No roles, no content, but you can login and node 2 works

No roles, no content, but you can login and node 2 works

Sunday 21 September 2014 3:15:20 pm - 2 replies

If you ever find yourself with an old legacy install that you have to move to a different machine... and for some reason everything looks somewhat o.k. but somewhat off and you login  to the backend and there are no roles, no users, no content under node 2 or 5... well, check your php version... because you probably installed it to a machine with php 5.4+ - dropping back down to 5.3 will fix everything.

Sunday 21 September 2014 8:01:39 pm

Hello Steven,

Thanks for sharing your experience here in the forums!

I would add you could also patch the kernel as well which is surprisingly simple to do...

http://share.ez.no/forums/install-configuration/php-5.4.1-no-call-method-defined-for-function

Patch for eZ Publish 4.6 : https://gist.github.com/brookinsconsulting/88d5f62082c70fdf3c91

Patch for eZ Publish 4.4 : https://gist.github.com/brookinsconsulting/7a9531b25a324ea2240f

 

I hope this helps others!

 

Cheers,
Heath

Modified on Sunday 21 September 2014 8:02:11 pm by // Heath

Monday 22 September 2014 7:34:55 pm

Hello,

I spoke recently (above) about patching ezpublish instead of recommending the preferred action of upgrading eZ Publish because ... my mind was stuck on some projects I have had to work with recently which I can not yet upgrade to the latest supported release and had to instead patch them temporarily to work in my php5.4 dev env.

Again the recommended course of action is to upgrade eZ Publish to eZ Publish 2012.01 at least. RE: http://share.ez.no/forums/ez-publish-5-platform/php-5.4-and-old-community-version

I hope this helps others!

Cheers,
Heath 

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from