eZ Community » Forums » Install & configuration » NOTE: Apache 2.0.43 and PATH_INFO
expandshrink

NOTE: Apache 2.0.43 and PATH_INFO

NOTE: Apache 2.0.43 and PATH_INFO

Monday 06 January 2003 6:02:28 pm - 2 replies

For those ppl running Apache 2.* there migth be a problem getting things to work. I noticed it at the login screen.

/index.php/user/login/ generated a 404. I tested with a CGI-script (Perl) and there the PATH_INFO (/user/login/) works fine, but not on any PPH-script.

The reason for this is that PATH_INFO must be turned on *explicitly* in Apache 2.*.

Two helphful URL's:

- http://httpd.apache.org/docs-2.0/mod/core.html#acceptpathinfo
- http://www.apacheweek.com/issues/02-07-12

\atle\
--

Saturday 24 May 2003 6:25:54 pm

Thank you *so* much for this fix, Atle. I've been running around like a headless chook trying to get ez Publish 3 working on Apache2 on Mac OS X. It finally works now! I've added an entry in the user contributed documentation to this thread.

Sunday 25 May 2003 4:56:05 pm

excellent, Patrick.
thanks for the URL's.

i got it working now. I can't confirm this solution for windows xp by experience, because i run freebsd 4-stable, php 4.3.1 and apache 2.0.44 at the moment.
the URL's Patrick gave are pretty interesting, so you might want to read them.
this is what i added to httpd.conf:
<Directory /<httpd-root>/ezpublish-x.x.x>
AcceptPathInfo On
</Directory>

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from