This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Old URL no longer working after...
expandshrink

Old URL no longer working after changing title of article

Old URL no longer working after changing title of article

Wednesday 14 July 2010 9:11:21 am - 11 replies

Good day,

When I change the title of an article on my website, the old URL no longer works. I was under the impression that EZPublish kept a history of URLs so that old links point to the changed article. Is there some configuration option that I have to switch on to get this to work?

I'm using EZP 4.1.3. Any help would be appreciated,

Vivienne

Wednesday 14 July 2010 11:35:19 am

It's mean that your URL alias name pattern is based on the title attribute, neither you can always refer to your article by content/view syntaxe (xx to be replaced by you node id):

{'content/view/full/xx'|ezurl}

Wednesday 14 July 2010 11:52:54 am

Hi Yannick,

I know you can always refer to the URL using the view/full/XX syntax, it's just that I'm using the nice URLs so that visitors can easily remember them. The problem now is that when I change the title ofthe page, the visitors to the old URL get the 'page not found' warning, while the EZPublish documentation mentions that the old URLs are saved and should still be working (pointing to the page with the new title).

Wednesday 14 July 2010 12:47:42 pm

can you look at "content/urlalias/<your node id>" from your admin site access and tell us what you see in the generated aliases window ?

Modified on Wednesday 14 July 2010 12:50:26 pm by Yannick Komotir

Wednesday 14 July 2010 2:03:22 pm

Under generated aliases I see the following entry:
/kennisbank/thema_s/over_arbo

When I change the title of the article this entry changes as well (there is always only one entry), and the old entry seems to be forgotten.

Thursday 15 July 2010 9:57:43 am

Isn't there an option I can switch on or off to enable the history of URLs to be saved? As it says in this article:

http://ez.no/doc/ez_publish/techn.../concepts_and_basics/url_translation

Quote:
"When the name of an object is changed, the system will take care of changing the virtual URLs for the involved nodes. In addition, an internal redirection will be created, which will make sure that the old URL still works. The old virtual URL will keep working until the exact same URL needs to be generated for a node. In this case, the old virtual URL will be deleted."

Friday 16 July 2010 5:56:36 am

Does anyone know how I enable the option to save a history of URL aliases pointing to the correct page, as it seems EZPublish doesn't do this automatically?

TIA,

Vivienne

Friday 16 July 2010 11:52:12 am

Hi Vivienne,

afaik eZ Publish automatically keeps old aliases in the alias table. Did you search issues.ez.no?

Monday 19 July 2010 10:49:17 am

Hi Sander,

I've searched issues.ez.no on your advice, and the only entry that came close was this one:

http://issues.ez.no/IssueView.php?Id=13490&activeItem=1

I've tried to reach the 'old' URL by setting it off from the root (as in the issue), but still the page was not found...

Wednesday 21 July 2010 8:58:13 am

Anyone? Maybe an obscure setting that I've missed somewhere? Could URLTranslator have someting to do with it? The settings for this option in my site.ini override are:

[URLTranslator]
Translation=enabled
WordSeparator=underscore
TransformationGroup=urlalias_compat

Any help would be appreciated.

Thursday 22 July 2010 10:10:54 am

Is there any way to solve this problem? It's quite important to get this to work, as we should be able to change the title of the page while the old URLs still point to the correct page (in stead of giving a 'page not found')...

Sunday 25 July 2010 10:57:06 pm

I don't know, but have you ever tried make a test update of your website to eZ publish 4.2.0 and see if this problem still happens? Because if this is a kernel bug it's very important to make your eZ publish installation up-to-date. I remember there was a problem with blank user registration with only a few installations that was fixed only in 4.1.0, after that, when a big problem appears on one of my websites, I make a test update, if it doesn't fixes, I try change the kernel by myself.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from