eZ Community » Forums » Install & configuration » override.ini in manual installation

override.ini in manual installation

override.ini in manual installation

Monday 08 January 2007 4:39:23 am - 15 replies

I have set up eZ Publish 3.9 manually... however, the instructions given don't include a default override.ini, so half the templates are missing.

Does anyone have the default override.ini for eZ Publish 3.9 w/ Website Interface?

Thanks in advance.

Monday 08 January 2007 9:17:34 am

Hi David

Here you go: http://ezpedia.org/wiki/en/ez/override_settings_website_interface

Wednesday 10 January 2007 3:39:14 am

in the text that you linked to, 'calendar' is misspelled 'calender'.

This breaks the functionality of the override.

Is this a bug on eZ systems part?

Modified on Wednesday 10 January 2007 5:44:24 am by David Hupp

Wednesday 10 January 2007 5:45:52 am

none of the toolbars are showing up, even though they should be enabled. Is this controlled by a template? If so, which one?

Thanks again.

Wednesday 10 January 2007 7:50:18 am

Hi David

The settings I put on eZpedia were extracted right from the ezwebin package, so this is probably an issue in the package. I'll have a look at it and report it as a bug.

I think the new Website Interface does not support the toolbar functionality you can configure through the admin interface.

Wednesday 10 January 2007 8:06:38 am

It was my fault, I used an older version of the ezwebin site package. I'll correct it on eZpedia. My apologies for the inconvenience.

Wednesday 10 January 2007 5:01:21 pm

I was more referring to the Website Interface editing toolbar.

I don't see any login anything either.

Wednesday 10 January 2007 10:21:16 pm

Do you have any idea how I could get the Website Interface toolbar to show? What template does the editing toolbar use?

Saturday 13 January 2007 7:41:11 am

Hi David

Did you install the classes from the ezwebin_classes package? ( you can download it from http://packages.ez.no/ezpublish/3.9/ )

The user group class has an additional checkbox attribute which you need to enable, the toolbar only shows up if that checkbox is enabled.

Saturday 13 January 2007 8:39:58 am

Where is this checkbox of which you speak?

Saturday 13 January 2007 11:22:43 am

Hi David, the attribute I'm talking about should be in the content class "User group". its identifier is website_toolbar_access and its datatype is "Checkbox". You can add it manually to the content class if it's not there already.

Saturday 13 January 2007 7:54:43 pm

I'm still missing this:

(from the eZ Publish Website Interface Installation Guide)

Do you know how I could enable that?

Sunday 14 January 2007 11:11:52 am

Apparently the object id of the used "Template look" object has been hardcoded in the ezwebin templates (see extension/ezwebin/design/ezwebin/templates/pagelayout.tpl ):

$pagedesign      = fetch( 'content', 'object', hash( 'object_id', '54' ) )

The object id in cleandata.sql (kernel/sql/common/cleandata.sql) is 55 instead of 54, this is a bug I think: http://issues.ez.no/10005.

The template look class doesn't seem to belong to any class groups anymore after an install with the setup wizard, but it should be in the Setup class group. Bug reported at http://issues.ez.no/10006

The ezwebin_site package extends the template look class with a couple of attributes, take a look in the file settings/addobjectattributes.php of the package, function expandClass to see which attributes you need to add.

Monday 15 January 2007 8:48:15 am

Actually I think 54 is the correct node; its name is whatever the name of your site is.

I added the fields to the template_look class, but they don't show up when i edit the template_look object... any ideas?

Monday 15 January 2007 9:19:45 am

could you just upload the proper template_look class as an ezpkg?

Wednesday 04 April 2007 10:10:54 am

You also need to add this to design.ini.append.php of your user site access:


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from