This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Install & configuration » PHP Notice when using Stale Cache

PHP Notice when using Stale Cache

PHP Notice when using Stale Cache

Friday 11 March 2011 10:04:00 am - 2 replies


I've been using eZ Publish for my personal website for a long time now, with first version being 4.0.

Since I upgraded to 4.1 and activated Stale Cache, my Apache error log is flogged with this line :

 PHP Notice:  Undefined index:   in kernel/private/classes/clusterfilehandlers/ezfs2filehandler.php on line 168

I'm now in 4.4 since yesterday, and I'm still having this line added over and over to my error log file.

Here's the extract of the file with the line highlighted :

// no stalecache file exists, what we do depends on settings 
    // generate the dynamic data without storage
>>> if ( $this->nonExistantStaleCacheHandling[ $this->cacheType ] == 'generate' )
        eZDebugSetting::writeDebug( 'kernel-clustering', $this->filePath, "Generation is being processed, generating own version", __METHOD__ );
    // wait for the generating process to be finished (or timedout)

Did I miss something in configuration during upgrade ?

Thanks in advance for your reply !


Modified on Friday 11 March 2011 3:21:11 pm by Hypolite Petovan

Friday 11 March 2011 1:55:42 pm

Could you also post the line from that file and 2 before and after it?

( In that case more people can help as they might be on a different version or running from git where line numbers are different either because of license headers changed by our build system or changes in between versions / updates in that file. )

Friday 11 March 2011 3:20:49 pm

Hello André,

thanks for the reply, I added the context to the subject and I tried to highlight the actual line.


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from