eZ Community » Forums » Install & configuration » Problem installing Ez publish 4 on...
expandshrink

Problem installing Ez publish 4 on Win XP

Problem installing Ez publish 4 on Win XP

Thursday 04 September 2008 9:28:58 pm - 8 replies

I have some major problem installing Ez publish 4 on my windows XP.
I’m running
Apache 2.0.6
PHP 5.2.6
MySQL 5.0
-however when I try to start installation of Ez, the publisher claims that I’m running PHP version 4.
In Firefox the error-message seems like this:
Unsupported PHP version " . phpversion() . "
" ); print( "
eZ Publish 4.x does not run with PHP 4.
". "

I’m new into Ez, Apache, PHP and MySQL so I’ll apreciate any tip and ideas to my problem.

Henrihappy.gif Emoticon

Friday 05 September 2008 10:08:50 am

Hi Henriette and welcome to the ezecosystem happy.gif Emoticon

How did you install apache, php & mysql ? Did you use wamp ? I advise you this soft which installs the latest versions of apache, php & mysql.

According to what your ezpublish installation says, you're not running php 5. Could you please verify you php version in a small php script ? Just enter this in it :

<?php
     phpinfo();
?>

And save your file as "check.php" in your /www directory. In firefox, type : http://localhost/check.php and tell us what the php version is written !

Regards,

P.

Friday 05 September 2008 12:44:10 pm

Hi.
Thank you for your respond happy.gif Emoticon

I installed Apache, PHP and MySQL manually. (And it was installed in the mentioned order as well)

I ran the script as mentioned, and the outcome is version 5.2.6
I also ran the php –v in command, and the outcome was version 5.2.6 as well.
Maybe I should try wamp as you mentioned. I guess I have to uninstall Apache and MySQL before using wamp?

Henrihappy.gif Emoticon

Friday 05 September 2008 1:19:30 pm

Hei Henriette!

Yes, you'll have to uninstall it first.
I personally use wamp, and it will save you a lot of time, especially if you need to test other php / apache / mysql versions at some time:
http://www.wampserver.com/en/

Some recommended optimizations to wamp for development setup on a machine with some memory:
php.ini (open with the try icon, to be sure you get the correct one)

max_execution_time = 120
max_input_time = 130
memory_limit = 164M

error_reporting = E_ALL|E_STRICT

post_max_size = 100M

upload_max_filesize = 100M

extension=php_apc.dll
extension=php_curl.dll
extension=php_gd2.dll
;extension=php_ldap.dll
extension=php_mbstring.dll
extension=php_mcrypt.dll
extension=php_mysql.dll

[Date]
date.timezone = CET

[APC]
apc.enabled = 1
apc.cache_by_default = 1
apc.enable_cli = 0
apc.shm_segments = 1
apc.shm_size = 96
apc.stat=1

httpd.conf

# look for a section that looks like this
<Directory "c:/www/">
# and set the Allow from section to something like this so apache isn't 
# accepting request from everyone without your knowledge
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1 192.168.1 10.0.10

</Directory>

# if you also use a different web server on your machine, set apache to
# use a different port
Listen 81
ServerName localhost:81 

To install apc, download it (if it isn't included) from (the one for 5.2.1 works for 5.2.6 as well):
http://pecl4win.php.net/ext.php/php_apc.dll

And download it to your php extension folder, mine is:
extension_dir = "c:/wamp/bin/php/php5.2.6/ext/"

Should probably use xdebug during development, but doesn't work that well with apc.

Modified on Friday 05 September 2008 1:21:01 pm by André R

Friday 05 September 2008 1:34:37 pm

Thanx guys.

I'll give wamp a try tonight. happy.gif Emoticon

Henrihappy.gif Emoticon

Friday 05 September 2008 8:57:20 pm

Unfortunally I received the same error-message after using wamps.

Unsupported PHP version " . phpversion() . "
" ); print( "
eZ Publish 4.x does not run with PHP 4.

Maybe I’m doing something wrong here. (Feel quite stupid now)

Friday 05 September 2008 9:23:56 pm

Seems we're overlooking something here, the text your posting includes 'print(' and 'phpversion()' witch indicates that the php file is served as html, aka php is not handling your php files.

This is what I get if I change to php4.4.7 and try to run eZ Publish 4.0.1:

Parse error: syntax error, unexpected ',', expecting '(' in C:\www\stable4\index.php on line 113

Reason, ezp 4.0.1 use class constants, a feature not supported by php 4.x.

So how have you setup php?
Is the wamp icon in the tray totaly white?
How do you access ezp?
And how did you access the phpinfo() php file?
Are there any rewrite rules involved?

Saturday 06 September 2008 5:09:43 pm

Hi !
You have an automated bundle solution here: http://bitnami.org/stack/ezpublish
But, it seems that the updated version of the ez publish 4.0.1 is not yet done. This, despite the promise given: http://bitnami.org/forums/forums/28/topics/433

Best regards

Monday 08 September 2008 4:37:07 pm

Hi MBuet,

We have already updated eZpublish to 4.0.1 version. You can find it at http://bitnami.org/stack/ezpublish

I hope you enjoy it!,

Best regards,
Manuel.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from