eZ Community » Forums » Install & configuration » Problem Uploading Large Files
expandshrink

Problem Uploading Large Files

Problem Uploading Large Files

Wednesday 28 September 2011 12:13:57 pm - 11 replies

Hello Everybody,

I've a problem in upload large size files (60-70 MB) on my website. I've installed an Ez 4.3.0 with EzFlow and I've created a class content that works fine with upload of files just below of 50mbs.

When I try to upload it, something goes wrong and my web browser close the operation with an error (in FF i receive a CONNECTION HAS BEEN CANCELLED, in Chrome i receive a ERROR 101 - net::ERR_CONNECTION_RESET)

My php configuration:

post_max_size = 100MB

upload_max_filesize = 100MB

max_input_time = 660

max_execution_time = 660

Why do u think it happens?

Tnx a lot for everyone who will support me?

Kind Regards.
Paolo. 

Wednesday 28 September 2011 1:20:26 pm

If you are using IIS webserver and php as fastcgi, consider raising the iis-security-filter "content-length" setting. IIS will deny/block/drop any requests which have a content-length larger than 30MB. 

 

http://forums.iis.net/t/1066272.aspx

Wednesday 28 September 2011 2:39:45 pm

Tnx for your reply Christian.

No it's not my problem: i'm working with HTTPD (just sorry for not told you that before ... sad.gif Emoticon )

Wednesday 28 September 2011 2:48:30 pm

then consider to review your apache/httpd errorlogs (ie /var/log/apache2/error.log) and/or the php errorlog. you can also shoot with the huge cannons and consider sniffing the traffic with wireshark or tcpdump on either side, the client or server to find out, what exactly happens when your browsers where exitting with errors.

other than that, there are sooo many networking, proxy, softwre, firewalling, ... issues to take care of...

edit: simple one, did you restart apache/php-fastcgi after tweaking settings?

Modified on Wednesday 28 September 2011 2:49:10 pm by Christian Rößler

Wednesday 28 September 2011 3:00:45 pm

Update: Checked HTTPD and PHP error logs.

No problem found there...

Obviously I restarted HTTPD after i've edit file size parameters

I hope that there's something that block my upload, but what is strange is that 50 MBs files have been uploaded with no problems.

Modified on Wednesday 28 September 2011 3:28:13 pm by Paolo Riva

Wednesday 28 September 2011 3:55:12 pm

@ Paolo

What version of apache / httpd are you using?

Have you reviewed your web server and virtual host configuration to ensure your not using the LimitRequestBody directive?

http://httpd.apache.org/docs/2.0/mod/core.html#LimitRequestBody

http://www.cyberciti.biz/faq/apache-limiting-upload-size/

 

Cheers,

Heath

Wednesday 28 September 2011 4:08:42 pm

Hello Heath...tnx for your support.

I'm using Apache HTTP 2.0 so i'm going to check about LimitRequestBody directive and I take u updated about problem resolution.

Tnx a lot for your support (Christian too blunk.gif Emoticon ).

Kind Regards.
Paolo 

Friday 30 September 2011 4:23:27 pm

@Heath: LimitRequestBody directive is not the problem (i've made a grep -R and look over every configuration file of HTTPD but there's no line about it - my ram is thanking me... happy.gif Emoticon ).

I try to create an upload form in php (out of Ez Publish installation) but obv on that server.

I find the same problem (so the problem is not EzP).

I try to do the same thing out of our internal network (currently we've done it only from there). I let you know how this test would go...

Tnx a lot.

Paolo.

Modified on Friday 30 September 2011 5:06:25 pm by Paolo Riva

Friday 30 September 2011 5:08:34 pm

PROBLEM SOLVED:

It's simply a firewall server configuration that blocks all the files with dimension over 50 MBs. Now server allow upload of files with dimension under 100MBs and I've no problems.

Tnx a lot to everyone.

Paolo.

Friday 30 September 2011 8:24:48 pm

Hello Paolo,

Congratulations! That is fantastic to hear! I'm so glad.

You did a great job troubleshooting this problem back from eZ Publish -> PHP -> Server -> Network -> Firewall

I'm impressed. Take care, if you ever need help again feel free to come back to the forums, we will be happy to help.

 

Cheers,

Heath

Monday 03 October 2011 9:12:12 am

@Heath: Tnx a lot and I'm very impressed to...cause i've impressed you blunk.gif Emoticon.

Tnx a lot.

Paolo.

Sunday 09 October 2011 8:27:40 am

The reply has been removed because of violation of forum rules.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from